ruby-ffi-rzmq-core_1.0.6-1_all.deb


Advertisement

Description

ruby-ffi-rzmq-core - FFI wrapper around the ZeromMQ (ØMQ) networking library for Ruby

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename ruby-ffi-rzmq-core_1.0.6-1_all.deb
Package name ruby-ffi-rzmq-core
Package version 1.0.6
Package release 1
Package architecture all
Package type deb
Category ruby
Homepage https://github.com/chuckremes/ffi-rzmq-core
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 9.38 KB
Installed size 45.00 KB
ØMQ is a library which extends the standard socket interfaces with features
traditionally provided by specialised messaging middleware products.
ØMQ sockets provide an abstraction of asynchronous message queues, multiple
messaging patterns, message filtering (subscriptions), seamless access to
multiple transport protocols and more.
This package contains only the FFI wrapper for the ZeroMQ (0mq) networking
library. It has been split from ruby-ffi-rzmq so that it can be used by any
other ZeroMQ Ruby library that want to provide their own high-level Ruby API.

Alternatives

Package Version Architecture Repository
ruby-ffi-rzmq-core_1.0.6-1_all.deb 1.0.6 all Debian Main
ruby-ffi-rzmq-core - - -

Requires

Name Value
libzmq5 -
ruby -
ruby-ffi >= 1.9.3debian-1+b1
ruby-interpreter -

Replaces

Name Value
ruby-ffi-rzmq << 2.0~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ruby-ffi-rzmq-core_1.0.6-1_all.deb
Source Package ruby-ffi-rzmq-core

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-ffi-rzmq-core deb package:
    # sudo apt-get install ruby-ffi-rzmq-core

Files

Path
/usr/lib/ruby/vendor_ruby/ffi-rzmq-core.rb
/usr/lib/ruby/vendor_ruby/ffi-rzmq-core/constants.rb
/usr/lib/ruby/vendor_ruby/ffi-rzmq-core/libc.rb
/usr/lib/ruby/vendor_ruby/ffi-rzmq-core/libzmq.rb
/usr/lib/ruby/vendor_ruby/ffi-rzmq-core/libzmq4.rb
/usr/lib/ruby/vendor_ruby/ffi-rzmq-core/structures.rb
/usr/lib/ruby/vendor_ruby/ffi-rzmq-core/utilities.rb
/usr/lib/ruby/vendor_ruby/ffi-rzmq-core/version.rb
/usr/share/doc/ruby-ffi-rzmq-core/changelog.Debian.gz
/usr/share/doc/ruby-ffi-rzmq-core/copyright
/usr/share/rubygems-integration/all/specifications/ffi-rzmq-core-1.0.6.gemspec

Changelog

2018-08-19 - Cédric Boutillier <boutil@debian.org>
ruby-ffi-rzmq-core (1.0.6-1) unstable; urgency=medium
* New upstream version 1.0.6
* Remove version in the gem2deb build-dependency
* Move debian/watch to gemwatch.debian.net
* Bump Standards-Version to 4.2.0 (no changes needed)
* Bump debhelper compatibility level to 11
* Use salsa.debian.org in Vcs-* fields
* Refresh 0001-load-so-from-libzmq3-or-q1.patch
* Drop 0002-correct-mem-alloc-for-libzmq-4.1.patch, not needed anymore
* Use https for homepage and copyright format url
* Add 0003-loadpath-in-tests.patch to fix autopkgtests
* Set testsuite to autopkgtest-pkg-ruby
2016-02-24 - Cédric Boutillier <boutil@debian.org>
ruby-ffi-rzmq-core (1.0.4-3) unstable; urgency=medium
* add patch to fix memory allocation message for libzmq 4.1+
2016-02-24 - Cédric Boutillier <boutil@debian.org>
ruby-ffi-rzmq-core (1.0.4-2) unstable; urgency=medium
* Also build-depend on libzmq5
* Update patch to find libzmq.so.5
2016-02-24 - Cédric Boutillier <boutil@debian.org>
ruby-ffi-rzmq-core (1.0.4-1) unstable; urgency=medium
* Imported Upstream version 1.0.4
* wrap and sort control file
* set debhelper compatibility level to 9
* Depend on libzmq5 instead of libzmq3
* Use secure urls for Vcs-* fields
* Bump Standards-Version to 3.9.7 (no changes needed)
2014-03-21 - Cédric Boutillier <boutil@debian.org>
ruby-ffi-rzmq-core (1.0.3-1) unstable; urgency=medium
* Initial release

See Also

Package Description
ruby-ffi-rzmq_2.0.6-2_all.deb FFI based Ruby bindings for ZeroMQ (ØMQ) networking library
ruby-ffi-yajl_2.3.1-1+b1_amd64.deb Ruby FFI wrapper around YAJL 2.x
ruby-ffi_1.9.10debian-1+b4_amd64.deb load dynamic libraries, bind functions from within ruby code
ruby-fftw3_1.0.2-2_amd64.deb Ruby interface to the FFTW Ver.3 library
ruby-file-tail_1.2.0-1_all.deb Ruby library for following still-growing files
ruby-filepath_0.7-1_all.deb small library to manipulate paths
ruby-filesystem_0.5-5.1+b8_amd64.deb Ruby extension for file-system information
ruby-fission_0.5.0-2_all.deb Command line tool to manage VMware Fusion VMs
ruby-fix-trinity-output_1.0.0-2_all.deb Fix output fastq files from trinityrnaseq
ruby-fixwhich_1.0.2-2_all.deb ruby module that emulates the 'which' program
ruby-flexmock_2.0.4-1_all.deb simple and flexible mock objects for testing
ruby-flipper_0.13.0-3_all.deb Feature flipper for ANYTHING
ruby-flot-rails_0.0.7-1_all.deb jQuery Flot for Rails Asset pipeline
ruby-flowdock_0.7.1-1_all.deb Ruby library for using Flowdock's API
ruby-fog-aliyun_0.3.2-2_all.deb Fog provider for Aliyun Web Services
Advertisement
Advertisement