ruby-dnsruby_1.61.2-1_all.deb


Advertisement

Description

ruby-dnsruby - Ruby DNS and DNSSEC client library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename ruby-dnsruby_1.61.2-1_all.deb
Package name ruby-dnsruby
Package version 1.61.2
Package release 1
Package architecture all
Package type deb
Category ruby
Homepage https://github.com/alexdalitz/dnsruby
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 121.39 KB
Installed size 657.00 KB
Dnsruby is a pure Ruby DNS client library. It provides a complete DNS
client implementation, including full DNSSEC support.  Dnsruby is
currently used in projects such as OpenDNSSEC and ISC's DLV service.

Alternatives

Package Version Architecture Repository
ruby-dnsruby_1.61.2-1_all.deb 1.61.2 all Debian Main
ruby-dnsruby - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ruby-dnsruby_1.61.2-1_all.deb
Source Package dnsruby

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-dnsruby deb package:
    # sudo apt-get install ruby-dnsruby

Files

Path
/usr/lib/ruby/vendor_ruby/dnsruby.rb
/usr/lib/ruby/vendor_ruby/dnsruby/DNS.rb
/usr/lib/ruby/vendor_ruby/dnsruby/bit_mapping.rb
/usr/lib/ruby/vendor_ruby/dnsruby/bitmap.rb
/usr/lib/ruby/vendor_ruby/dnsruby/cache.rb
/usr/lib/ruby/vendor_ruby/dnsruby/code_mapper.rb
/usr/lib/ruby/vendor_ruby/dnsruby/code_mappers.rb
/usr/lib/ruby/vendor_ruby/dnsruby/config.rb
/usr/lib/ruby/vendor_ruby/dnsruby/dnssec.rb
/usr/lib/ruby/vendor_ruby/dnsruby/hosts.rb
/usr/lib/ruby/vendor_ruby/dnsruby/ipv4.rb
/usr/lib/ruby/vendor_ruby/dnsruby/ipv6.rb
/usr/lib/ruby/vendor_ruby/dnsruby/key_cache.rb
/usr/lib/ruby/vendor_ruby/dnsruby/name.rb
/usr/lib/ruby/vendor_ruby/dnsruby/packet_sender.rb
/usr/lib/ruby/vendor_ruby/dnsruby/recursor.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resolv.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resolver.rb
/usr/lib/ruby/vendor_ruby/dnsruby/select_thread.rb
/usr/lib/ruby/vendor_ruby/dnsruby/single_resolver.rb
/usr/lib/ruby/vendor_ruby/dnsruby/single_verifier.rb
/usr/lib/ruby/vendor_ruby/dnsruby/the_log.rb
/usr/lib/ruby/vendor_ruby/dnsruby/update.rb
/usr/lib/ruby/vendor_ruby/dnsruby/validator_thread.rb
/usr/lib/ruby/vendor_ruby/dnsruby/version.rb
/usr/lib/ruby/vendor_ruby/dnsruby/zone_reader.rb
/usr/lib/ruby/vendor_ruby/dnsruby/zone_transfer.rb
/usr/lib/ruby/vendor_ruby/dnsruby/message/decoder.rb
/usr/lib/ruby/vendor_ruby/dnsruby/message/encoder.rb
/usr/lib/ruby/vendor_ruby/dnsruby/message/header.rb
/usr/lib/ruby/vendor_ruby/dnsruby/message/message.rb
/usr/lib/ruby/vendor_ruby/dnsruby/message/question.rb
/usr/lib/ruby/vendor_ruby/dnsruby/message/section.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/A.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/AAAA.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/AFSDB.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/APL.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/CAA.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/CDNSKEY.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/CDS.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/CERT.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/DHCID.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/DLV.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/DNSKEY.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/DS.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/GPOS.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/HINFO.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/HIP.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/IN.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/IPSECKEY.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/ISDN.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/KX.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/LOC.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/MINFO.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/MX.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/NAPTR.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/NSAP.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/NSEC.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/NSEC3.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/NSEC3PARAM.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/NXT.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/OPT.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/PX.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/RP.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/RR.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/RRSIG.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/RRSet.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/RT.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/SOA.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/SPF.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/SRV.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/SSHFP.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/TKEY.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/TLSA.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/TSIG.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/TXT.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/URI.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/X25.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/domain_name.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/generic.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/resource.rb
/usr/lib/ruby/vendor_ruby/dnsruby/resource/type_bitmap.rb
/usr/share/doc/ruby-dnsruby/DNSSEC
/usr/share/doc/ruby-dnsruby/EVENTMACHINE
/usr/share/doc/ruby-dnsruby/EXAMPLES.gz
/usr/share/doc/ruby-dnsruby/README.md
/usr/share/doc/ruby-dnsruby/changelog.Debian.gz
/usr/share/doc/ruby-dnsruby/copyright
/usr/share/rubygems-integration/all/specifications/dnsruby-1.61.2.gemspec

Changelog

2018-11-06 - Marc Dequènes (Duck) <Duck@DuckCorp.org>
dnsruby (1.61.2-1) unstable; urgency=medium
* New upstream release (Closes: #908888, #908887, #910754).
* New maintainer/uploaders with permission from the previous one.
Thanks Ondřej Surý for your work.
* Updated watch file.
* Updated VCS URLs (Alioth->Salsa).
* Updated homepage.
* Switch to source format 3.0 (quilt).
* Switch to compat level 11.
* Update copyright file and rewrite it in machine-readable format.
* Removed versioning in gem2deb's build-dep.
* Remove build dependency on 'graphviz', no longer necessary.
* Remove obsolete relations to an ancient transition.
* Bump Standards-Version to 4.2.1.
2014-08-27 - Ondřej Surý <ondrej@debian.org>
dnsruby (1.54-2) unstable; urgency=medium
* Fix Vcs-Urls to point to anonscm.d.o
* Update d/gbp.conf for master/pristine-tar/upstream branch names
2013-08-26 - Ondřej Surý <ondrej@debian.org>
dnsruby (1.54-1) unstable; urgency=low
* New upstream version 1.54
* Drop libruby- transitional packages
2011-11-21 - Ondřej Surý <ondrej@debian.org>
dnsruby (1.53-1) unstable; urgency=low
* Build-Depends on gem2deb 0.2.3~ to allow backports
* Conflict with 1.52-2~ instead of 1.52 to allow backports
* Imported Upstream version 1.53
2011-05-25 - Ondřej Surý <ondrej@debian.org>
dnsruby (1.52-2) unstable; urgency=low
* Convert package to gem2deb build system
2011-03-19 - Ondřej Surý <ondrej@debian.org>
dnsruby (1.52-1) unstable; urgency=low
* Imported Upstream version 1.52
2010-12-02 - Ondřej Surý <ondrej@debian.org>
dnsruby (1.51-1) unstable; urgency=low
* New upstrem release 1.51
* Add script to repack gem to tar.gz
2010-08-24 - Ondřej Surý <ondrej@debian.org>
dnsruby (1.49-1) unstable; urgency=low
* New upstream release
* Bump standards version to 3.9.1
2010-08-04 - Ondřej Surý <ondrej@debian.org>
dnsruby (1.48-1) unstable; urgency=low
* New upstream release
2010-05-28 - Ondřej Surý <ondrej@debian.org>
dnsruby (1.47-1) unstable; urgency=low
* New upstream release.

See Also

Package Description
ruby-docile_1.1.5-2_all.deb Docile keeps your Ruby DSLs tame and well-behaved
ruby-docker-api_1.22.2-1_all.deb Ruby gem to interact with docker.io remote API
ruby-domain-name_0.5.20160216-2_all.deb Domain Name manipulation library for Ruby
ruby-doorkeeper_4.4.2-1_all.deb OAuth 2 provider for Rails and Grape
ruby-dotenv_2.4.0-1_all.deb configuration variable loader
ruby-eb_2.6-3+b8_amd64.deb EB library interface for the Ruby
ruby-ecasound_2.9.1-7_all.deb multitrack-capable audio recorder and effect processor (ruby bindings)
ruby-ed25519_1.2.4-1_amd64.deb efficient digital signature library providing the Ed25519 algorithm
ruby-eim-xml_0.0.4-4_all.deb Easy IMplemented XML by Ruby
ruby-ejs_1.1.1-2_all.deb EJS (Embedded JavaScript) template compiler
ruby-elasticsearch-api_1.0.12-1_all.deb Ruby implementation of the Elasticsearch REST API
ruby-elasticsearch-transport_1.0.12-1_all.deb low-level Ruby client for connecting to Elasticsearch
ruby-elasticsearch_1.0.12-1_all.deb Ruby client for connecting to an Elasticsearch cluster
ruby-em-hiredis-doc_0.3.1-1_all.deb fast and simple Redis client for EventMachine (documentation)
ruby-em-hiredis_0.3.1-1_all.deb fast and simple Redis client for EventMachine
Advertisement
Advertisement