ruby-ddmemoize_1.0.0-1_all.deb


Advertisement

Description

ruby-ddmemoize - Ruby library providing support for memoizing functions

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename ruby-ddmemoize_1.0.0-1_all.deb
Package name ruby-ddmemoize
Package version 1.0.0
Package release 1
Package architecture all
Package type deb
Category ruby
Homepage https://github.com/ddfreyne/ddmemoize
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 4.85 KB
Installed size 25.00 KB
The DDMemoize library adds support for memoizing Ruby
functions, allowing for storing previously computed values.
It provides the following features:
* Supports memoizing functions on frozen objects
* Releases memoized values when needed in order to reduce
memory pressure
* Optionally records metrics

Alternatives

Package Version Architecture Repository
ruby-ddmemoize_1.0.0-1_all.deb 1.0.0 all Debian Main
ruby-ddmemoize - - -

Requires

Name Value
ruby -
ruby-ddmetrics >= 1.0
ruby-interpreter -
ruby-ref >= 2.0

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ruby-ddmemoize_1.0.0-1_all.deb
Source Package ruby-ddmemoize

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-ddmemoize deb package:
    # sudo apt-get install ruby-ddmemoize

Files

Path
/usr/lib/ruby/vendor_ruby/ddmemoize.rb
/usr/lib/ruby/vendor_ruby/ddmemoize/version.rb
/usr/share/doc/ruby-ddmemoize/README.md
/usr/share/doc/ruby-ddmemoize/changelog.Debian.gz
/usr/share/doc/ruby-ddmemoize/copyright
/usr/share/rubygems-integration/all/specifications/ddmemoize-1.0.0.gemspec

Changelog

2018-09-18 - C├ędric Boutillier <boutil@debian.org>
ruby-ddmemoize (1.0.0-1) unstable; urgency=medium
* Initial release

See Also

Package Description
ruby-ddmetrics_1.0.1-1_all.deb Non-timeseries measurements for Ruby programs
ruby-ddplugin_1.0.2-1_all.deb plugins management for Ruby apps
ruby-debian_0.3.9+b8_amd64.deb ruby interface for dpkg
ruby-declarative-option_0.1.0-1_all.deb Dynamic options for declarative to evaluate at runtime
ruby-declarative_0.0.10-1_all.deb DSL for nested schemas
ruby-deep-merge_1.1.1-1_all.deb recursively merge Hash elements in Ruby
ruby-default-value-for_3.1.0-1_all.deb provides a way to specify default values for ActiveRecord models
ruby-delayed-job-active-record_4.1.3-1_all.deb ActiveRecord backend for DelayedJob
ruby-delayed-job_4.1.5-1_all.deb database-backed asynchronous priority queue system
ruby-delayer-deferred_2.0.0-3_all.deb Ruby implementation of JSDeferred
ruby-delayer_0.0.2-5_all.deb Ruby library providing delay the processing
ruby-delorean_2.1.0-2_all.deb lets you travel in time with Ruby by mocking Time.now
ruby-dependor_1.0.1-2_all.deb classes and modules that simplifing dependency injection in Ruby
ruby-descendants-tracker_0.0.4-2_all.deb Ruby module that adds descendant tracking to a class
ruby-dev_2.5.1_amd64.deb Header files for compiling extension modules for Ruby (default version)
Advertisement
Advertisement