ruby-clutter-gdk_3.3.2-1_all.deb


Advertisement

Description

ruby-clutter-gdk - Clutter-Gdk bindings for the Ruby language

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename ruby-clutter-gdk_3.3.2-1_all.deb
Package name ruby-clutter-gdk
Package version 3.3.2
Package release 1
Package architecture all
Package type deb
Category ruby
Homepage http://ruby-gnome2.osdn.jp/
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 15.32 KB
Installed size 30.00 KB
Clutter-Gdk is a library for GDK specific API of Clutter. This library
provides some specific API, allowing integration with the GDK API for
manipulating the stage window and handling events outside of Clutter.
This package contains libraries for using Clutter-Gdk with the Ruby language.

Alternatives

Package Version Architecture Repository
ruby-clutter-gdk_3.3.2-1_all.deb 3.3.2 all Debian Main
ruby-clutter-gdk - - -

Requires

Name Value
gir1.2-clutter-1.0 -
ruby -
ruby-clutter >= 3.3.2-1
ruby-gdk3 >= 3.3.2-1
ruby-interpreter -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ruby-clutter-gdk_3.3.2-1_all.deb
Source Package ruby-gnome2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-clutter-gdk deb package:
    # sudo apt-get install ruby-clutter-gdk

Files

Path
/usr/lib/ruby/vendor_ruby/clutter-gdk.rb
/usr/share/doc/ruby-clutter-gdk/changelog.Debian.gz
/usr/share/doc/ruby-clutter-gdk/copyright
/usr/share/rubygems-integration/all/specifications/clutter-gdk-3.3.2.gemspec

Changelog

2019-02-07 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
ruby-gnome2 (3.3.2-1) unstable; urgency=medium
* New upstream version 3.3.2
2019-01-13 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
ruby-gnome2 (3.3.1-1) unstable; urgency=medium
* New upstream version 3.3.1
* Refresh patches.
* Update Standards-Version to 4.3.0
2018-11-05 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
ruby-gnome2 (3.3.0-1) unstable; urgency=medium
* New upstream version 3.3.0
* offer gksourceview4 instead of gtksourceview3 (Closes: #912930)
* refresh patches
* Update Standards-Version to 4.2.1
2018-08-12 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
ruby-gnome2 (3.2.9-1) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* New upstream version 3.2.8
* New upstream version 3.2.9
* d/p/do-no-depend-dependency-check.patch:
rsvg2 and webkit2-gtk do not depend dependency-check
* d/rules: rsvg2 and webkit2-gtk have own gemspecs now.
* d/p/ignored-test-modules.patch: do not test gtksourceview4
* d/changelog: eliminate lintian warning: file-contains-trailing-whitespace
* d/ruby-gtksourceview2.*: remove already dropped ruby-gtksourceview2 files
* refresh patches.
* Update Standards-Version to 4.2.0
2018-06-10 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
ruby-gnome2 (3.2.7-1) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* New upstream release.
* upstream has some *.gemspecs
- d/rules: rsvg2, webkit2-gtk and webkit2-gtk do not have *.gemspec.
* do not depend native-package-installer
- d/p/do-not-use-native-package-installer.patch: update.
- d/p/do-no-depend-dependency-check.patch: new patch.
* refresh patches.
2018-05-05 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
ruby-gnome2 (3.2.5-2) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* d/p/glib2_fix_a_bug_that_signal_created_by_signal_new_may_be_GC-ed.patch:
fix "warning: GRC losure invoking callback: already destroyed: (anonymous)"
see https://dev.mikutter.hachune.net/issues/1221
2018-05-04 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
ruby-gnome2 (3.2.5-1) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* New upstream release.
- Ruby/Poppler: Added a workaround for poppler-glib 0.63 bug. see #896596
2018-04-09 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
ruby-gnome2 (3.2.4-1) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* New upstream release.
- d/p/fix_a_bug_that_some_constant_names_are_not_defined.patch: removed,
imported upstream.
* Refresh patches.
2018-04-08 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
ruby-gnome2 (3.2.3-2) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* glib2: fix a bug that some constant names aren't defined (Closes: #894816).
- d/p/fix_a_bug_that_some_constant_names_are_not_defined.patch: new patch.
* Update Standards-Version to 4.1.4
2018-04-04 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
ruby-gnome2 (3.2.3-1) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* New upstream release.
- gi: fix overflow bug on 32bit (Closes: #766020)
- refresh patches.
* eliminate lintian warning: file-contains-trailing-whitespace
* eliminate lintian warning: insecure-copyright-format-uri

See Also

Package Description
ruby-clutter-gtk_3.3.2-1_all.deb Clutter-Gtk bindings for the Ruby language
ruby-clutter_3.3.2-1_all.deb Clutter bindings for the Ruby language
ruby-cmdparse_2.0.6-1_all.deb Advanced command line parsing Ruby module supporting sub-commands
ruby-cocaine_0.5.8-1_all.deb library for running command line commands in Ruby
ruby-cocoon_1.2.6-2_all.deb tool to handle nested forms using jQuery
ruby-codemirror-rails_5.16.0-1_all.deb use codemirror with rails
ruby-coderay_1.1.2-2_all.deb Ruby library for syntax highlighting
ruby-coercible_1.0.0-2_all.deb powerful, flexible and configurable coercion library
ruby-coffee-rails_4.2.2-1_all.deb Coffee Script adapter for the Rails asset pipeline
ruby-coffee-script-source_1.10.0-1_all.deb CoffeeScript Compiler - Ruby integration
ruby-coffee-script_2.4.1-1_all.deb Ruby CoffeeScript Compiler
ruby-color_1.8-2_all.deb Ruby library to provide RGB, CMYK and other colorspace support
ruby-colorator_1.1.0-1_all.deb String core extensions for terminal coloring
ruby-colored_1.2-2_all.deb library to add colors or attributes to text
ruby-colorize_0.8.1-1_all.deb color methods to Ruby String class
Advertisement
Advertisement