ruby-asset-sync_2.6.0-1_all.deb


Advertisement

Description

ruby-asset-sync - synchronises assets in a Rails app and Amazon/Rackspace cloud

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename ruby-asset-sync_2.6.0-1_all.deb
Package name ruby-asset-sync
Package version 2.6.0
Package release 1
Package architecture all
Package type deb
Category ruby
Homepage https://github.com/rumblelabs/asset_sync
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 28.55 KB
Installed size 85.00 KB
After you run assets:precompile your compiled assets will be synchronised
with your Amazon S3/Cloudfront or Rackspace Cloudfiles.
Asset Sync is built to run with the new Rails Asset Pipeline feature introduced
in Rails 3.1.  After you run __bundle exec rake assets:precompile__ your assets
will be synchronised to your cloud account, optionally deleting unused files
and only uploading the files it needs to.

Alternatives

Package Version Architecture Repository
ruby-asset-sync_2.6.0-1_all.deb 2.6.0 all Debian Main
ruby-asset-sync - - -

Requires

Name Value
ruby -
ruby-activemodel >= 2:4.1~
ruby-fog-core -
ruby-interpreter -
ruby-mime-types >= 2.99~
ruby-unf -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ruby-asset-sync_2.6.0-1_all.deb
Source Package ruby-asset-sync

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-asset-sync deb package:
    # sudo apt-get install ruby-asset-sync

Files

Path
/usr/lib/ruby/vendor_ruby/asset_sync.rb
/usr/lib/ruby/vendor_ruby/asset_sync/asset_sync.rb
/usr/lib/ruby/vendor_ruby/asset_sync/config.rb
/usr/lib/ruby/vendor_ruby/asset_sync/engine.rb
/usr/lib/ruby/vendor_ruby/asset_sync/multi_mime.rb
/usr/lib/ruby/vendor_ruby/asset_sync/railtie.rb
/usr/lib/ruby/vendor_ruby/asset_sync/storage.rb
/usr/lib/ruby/vendor_ruby/asset_sync/version.rb
/usr/lib/ruby/vendor_ruby/generators/asset_sync/install_generator.rb
/usr/lib/ruby/vendor_ruby/generators/asset_sync/templates/asset_sync.rb
/usr/lib/ruby/vendor_ruby/generators/asset_sync/templates/asset_sync.yml
/usr/lib/ruby/vendor_ruby/tasks/asset_sync.rake
/usr/share/doc/ruby-asset-sync/README.md.gz
/usr/share/doc/ruby-asset-sync/changelog.Debian.gz
/usr/share/doc/ruby-asset-sync/changelog.gz
/usr/share/doc/ruby-asset-sync/copyright
/usr/share/rubygems-integration/all/specifications/asset_sync-2.6.0.gemspec

Changelog

2018-12-25 - Pirate Praveen <praveen@debian.org>
ruby-asset-sync (2.6.0-1) unstable; urgency=medium
* New upstream version 2.6.0
* Bump Standards-Version to 4.3.0 (no changes needed)
* Tighten dependencies
* Refresh patches
* Refresh packaging with dh-make-ruby -w
* Enable tests again (rspec3 is now available)
2018-06-20 - Hari Govind S <harigovindind@gmail.com>
ruby-asset-sync (2.4.0-1) unstable; urgency=medium
* Team upload
* New upstream release
* Bump standards version to 4.1.4
* Updated Vcs- urls to salsa
* Updated copyright url to use https
* Updated debian/watch to version 4
2018-03-19 - Pirate Praveen <praveen@debian.org>
ruby-asset-sync (2.2.0-2) unstable; urgency=medium
* Reupload to unstable
2017-09-30 - Sruthi Chandran <srud@disroot.org>
ruby-asset-sync (2.2.0-1) experimental; urgency=medium
* Team upload
* New upstream release
* Enable autopkgtest
2015-05-12 - Pirate Praveen <praveen@debian.org>
ruby-asset-sync (1.1.0-2) unstable; urgency=medium
* Re-upload to unstable
2014-11-20 - Pirate Praveen <praveen@debian.org>
ruby-asset-sync (1.1.0-1) experimental; urgency=medium
* New upstream release.
* Bump standards version to 3.9.6 (no changes).
* Refresh patches.
* Remove versioned build dep on rails.
* Disable tests (needs rspec3).
2013-12-23 - Christian Hofstaedtler <zeha@debian.org>
ruby-asset-sync (1.0.0-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Build-Depend on simplecov instead of rcov
* Refresh patches
* Update Standards-Version to 3.9.5 (no changes)
* Update Build-Depends for ruby2.0, drop ruby1.8
2013-06-05 - Praveen Arimbrathodiyil <praveen@debian.org>
ruby-asset-sync (0.5.4-1) unstable; urgency=low
* Initial release (Closes: #711306)

See Also

Package Description
ruby-ast_2.3.0-1_all.deb Ruby library for working with abstract syntax trees
ruby-atk_3.3.2-1_all.deb ATK bindings for the Ruby language
ruby-atomic_1.1.16-2+b8_amd64.deb atomic reference implementation for JRuby, Rubinius, and MRI
ruby-attr-required_1.0.0-2_all.deb attr_required and attr_optional support for Ruby
ruby-augeas_0.5.0-3+b6_amd64.deb Augeas bindings for the Ruby language
ruby-autoprefixer-rails_8.6.5+dfsg-3_all.deb Rails integration for the autoprefixer tool
ruby-avl-tree_1.1.3-1_all.deb AVL and red-black trees in Ruby
ruby-awesome-nested-set_3.0.0-1_all.deb awesome nested set implementation for Active Record
ruby-awesome-print_1.8.0-1_all.deb pretty print Ruby objects with proper indentation and colors
ruby-aws-sdk_1.67.0-2_all.deb Amazon Web Services SDK for Ruby
ruby-aws_2.10.2-5_all.deb AWS Ruby Library for interfacing with Amazon Web Services
ruby-axiom-types_0.1.1-1_all.deb Ruby module for abstract types for logic programming
ruby-babosa_1.0.2-2_all.deb library for creating slugs
ruby-backbone-on-rails_1.2.0.0-2_all.deb simple library for using Backbone with Rails
ruby-backports_3.11.1-2_all.deb backports of new features for older versions of Ruby
Advertisement
Advertisement