ruby-ascii85_1.0.3-1_all.deb


Advertisement

Description

ruby-ascii85 - Ruby library to encode/decode the Ascii85 format

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename ruby-ascii85_1.0.3-1_all.deb
Package name ruby-ascii85
Package version 1.0.3
Package release 1
Package architecture all
Package type deb
Category ruby
Homepage https://github.com/datawraith/ascii85gem
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 9.34 KB
Installed size 35.00 KB
Ascii85 (also called "Base85") is a form of binary-to-text encoding, which is
mainly used in Adobe's PostScript and PDF format. This package provides a
ruby library to encode/decode Ascii85.
It ships also a command line utility, which can encode/decode files to the
standard output.

Alternatives

Package Version Architecture Repository
ruby-ascii85_1.0.3-1_all.deb 1.0.3 all Debian Main
ruby-ascii85 - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ruby-ascii85_1.0.3-1_all.deb
Source Package ruby-ascii85

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-ascii85 deb package:
    # sudo apt-get install ruby-ascii85

Files

Path
/usr/bin/ascii85
/usr/lib/ruby/vendor_ruby/ascii85.rb
/usr/lib/ruby/vendor_ruby/Ascii85/version.rb
/usr/share/doc/ruby-ascii85/README.md
/usr/share/doc/ruby-ascii85/changelog.Debian.gz
/usr/share/doc/ruby-ascii85/changelog.gz
/usr/share/doc/ruby-ascii85/copyright
/usr/share/man/man1/ascii85.1.gz
/usr/share/rubygems-integration/all/specifications/Ascii85-1.0.3.gemspec

Changelog

2018-07-30 - Cédric Boutillier <boutil@debian.org>
ruby-ascii85 (1.0.3-1) unstable; urgency=medium
* New upstream version 1.0.3
* Run wrap-and-sort on packaging files
* Move debian/watch to gemwatch.debian.net
* Bump Standards-Version to 4.1.5 (no changes needed)
* Use salsa.debian.org in Vcs-* fields
* Bump debhelper compatibility level to 11
* README is now markdown
* Update upstream email address
2014-10-14 - Cédric Boutillier <boutil@debian.org>
ruby-ascii85 (1.0.2-3) unstable; urgency=medium
* Reupload to update rubygems-integration metadata
* Bump Standards-Version to 3.9.6 (no changes needed)
* Set Testsuite to autopkgtest-pkg-ruby
* Change homepage to the page of the Github repository
* Refresh remove_rubygems.patch to remove the relative path when requiring
the library in tests
2013-05-27 - Cédric Boutillier <boutil@debian.org>
ruby-ascii85 (1.0.2-2) unstable; urgency=low
* debian/patches: add fix_path_in_bin.patch to use the correct path to find
the ascii85 library. Thanks Sam Morris (Closes: #710006).
2013-05-19 - Cédric Boutillier <boutil@debian.org>
ruby-ascii85 (1.0.2-1) unstable; urgency=low
* New upstream version
* debian/control: 
+ remove obsolete DM-Upload-Allowed flag
+ use canonical URI in Vcs-* fields
+ bump Standards-Version to 3.9.4 (no changes needed)
+ change in Build-Depends ruby-rspec to ruby-minitest to reflect upstream
test framework change
+ update my email address
* debian/copyright:
+ use DEP5 copyright-format/1.0 official URL for Format field
+ update my email address and years
* debian/ruby-test-files.yaml: drop spec_helper.rb, not present any more
* debian/patches:
+ drop 01_spec_fix_requires.diff, not needed anymore
+ add remove_rubygems.patch
2012-06-26 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-ascii85 (1.0.1-2) unstable; urgency=low
* Bump build dependency on gem2deb to >= 0.3.0~
2011-09-02 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-ascii85 (1.0.1-1) unstable; urgency=low
* Initial release (Closes: #640110)

See Also

Package Description
ruby-asciidoctor-pdf_1.5.0~alpha.17.dev-5_all.deb Converts AsciiDoc documents to PDF using Prawn
ruby-asciidoctor-plantuml_0.0.8-1_all.deb extension for Asciidoctor to enable support for PlantUML diagrams
ruby-asciidoctor_1.5.8-1_all.deb AsciiDoc to HTML rendering for Ruby (core libraries)
ruby-asetus_0.3.0-1_all.deb configuration library with YAML/JSON/TOML backends
ruby-asset-sync_2.6.0-1_all.deb synchronises assets in a Rails app and Amazon/Rackspace cloud
ruby-ast_2.3.0-1_all.deb Ruby library for working with abstract syntax trees
ruby-atk_3.3.2-1_all.deb ATK bindings for the Ruby language
ruby-atomic_1.1.16-2+b8_amd64.deb atomic reference implementation for JRuby, Rubinius, and MRI
ruby-attr-required_1.0.0-2_all.deb attr_required and attr_optional support for Ruby
ruby-augeas_0.5.0-3+b6_amd64.deb Augeas bindings for the Ruby language
ruby-autoprefixer-rails_8.6.5+dfsg-3_all.deb Rails integration for the autoprefixer tool
ruby-avl-tree_1.1.3-1_all.deb AVL and red-black trees in Ruby
ruby-awesome-nested-set_3.0.0-1_all.deb awesome nested set implementation for Active Record
ruby-awesome-print_1.8.0-1_all.deb pretty print Ruby objects with proper indentation and colors
ruby-aws-sdk_1.67.0-2_all.deb Amazon Web Services SDK for Ruby
Advertisement
Advertisement