python3-grib_2.0.4-1_amd64.deb


Advertisement

Description

python3-grib - Python 3 module for reading and writing GRIB files

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename python3-grib_2.0.4-1_amd64.deb
Package name python3-grib
Package version 2.0.4
Package release 1
Package architecture amd64
Package type deb
Category python
Homepage https://github.com/jswhit/pygrib
License -
Maintainer Alastair McKinstry <mckinstry@debian.org>
Download size 266.48 KB
Installed size 1.03 MB
Python 3 module for reading and writing GRIB (editions 1 and 2) files.
GRIB is the World Meterological Organization standard for
distributing gridded data. The module is a Python 3 interface
to the GRIB API C library from the
European Centre for Medium-Range Weather Forecasts (ECMWF).
This package also contains the cnvgrib1to2, grib_list, grib_repack, and
cnvgrib2to1 scripts.

Alternatives

Package Version Architecture Repository
python3-grib_2.0.4-1_i386.deb 2.0.4 i386 Debian Main
python3-grib - - -

Requires

Name Value
libc6 >= 2.4
libeccodes-data -
libeccodes-dev -
libeccodes0 -
libgrib2c-dev -
python3 << 3.8
python3 >= 3.7~
python3-numpy >= 1:1.16.0~rc1
python3-numpy-abi9 -
python3-pyproj -
python3:any -

Replaces

Name Value
python-grib << 2.0.0-1
python-grib-doc << 2.0.0-2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python3-grib_2.0.4-1_amd64.deb
Source Package pygrib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-grib deb package:
    # sudo apt-get install python3-grib

Files

Path
/usr/bin/cnvgrib1to2
/usr/bin/cnvgrib2to1
/usr/bin/grib_list
/usr/bin/grib_repack
/usr/lib/python3/dist-packages/g2clib.cpython-37m-x86_64-linux-gnu.so
/usr/lib/python3/dist-packages/ncepgrib2.py
/usr/lib/python3/dist-packages/pygrib-2.0.4.egg-info
/usr/lib/python3/dist-packages/pygrib.cpython-37m-x86_64-linux-gnu.so
/usr/lib/python3/dist-packages/redtoreg.cpython-37m-x86_64-linux-gnu.so
/usr/share/doc/python3-grib/changelog.Debian.gz
/usr/share/doc/python3-grib/changelog.gz
/usr/share/doc/python3-grib/copyright
/usr/share/man/man1/cnvgrib1to2.1.gz
/usr/share/man/man1/cnvgrib2to1.1.gz
/usr/share/man/man1/grib_list.1.gz
/usr/share/man/man1/grib_repack.1.gz

Changelog

2019-02-17 - Alastair McKinstry <mckinstry@debian.org>
pygrib (2.0.4-1) unstable; urgency=medium
* New upstream release
* Standards-Version: 4.3.0
* Remove hard-coded 'xz' compression
2018-08-26 - Alastair McKinstry <mckinstry@debian.org>
pygrib (2.0.3-1) unstable; urgency=medium
* New upstream release
* eccodes.patch now merged upstream
* Standards-Version: 4.2.0; no changes required
2018-07-05 - Alastair McKinstry <mckinstry@debian.org>
pygrib (2.0.2-4) unstable; urgency=medium
* regenerate cython files
* Point VCS at salsa.debian.org
* Standards-Version: 4.1.4
* Drop obsolete X-Python*-Version clauses from d/control
* Build against python3.7
2018-02-05 - Alastair McKinstry <mckinstry@debian.org>
pygrib (2.0.2-3) unstable; urgency=medium
* Standards-Version: 4.1.3; no changes required
* Change dependencies from libgrib-api-dev to libeccodes-dev
* Temporarily disable g2libc until memory linking issue solved
( See: #889321)
2017-08-16 - Alastair McKinstry <mckinstry@debian.org>
pygrib (2.0.2-2) unstable; urgency=medium
* Link against libeccodes instead of libgrib-api (which is deprecated)
* Standards-Version: 4.0.1; no changes required
2016-11-26 - Alastair McKinstry <mckinstry@debian.org>
pygrib (2.0.2-1) unstable; urgency=medium
* New upstream release
* DH_COMPAT is now 10
* Mark python-grib-doc as M-A: foreign
2016-06-13 - Alastair McKinstry <mckinstry@debian.org>
pygrib (2.0.1-4) unstable; urgency=medium
* Remove more unnecessary openjpeg, png dependencies
2016-06-11 - Alastair McKinstry <mckinstry@debian.org>
pygrib (2.0.1-3) unstable; urgency=medium
* Standards-Version: 3.9.8
* remove unnecessary dependencies. Closes: #826826
* Add gdb.conf file to debian/
2016-02-29 - Alastair McKinstry <mckinstry@debian.org>
pygrib (2.0.1-2) unstable; urgency=medium
* Drop jasper from Debian as obsolete; using openjpeg instead.
* Standards-Version: 3.9.7 ; no changes required.
* add {python,python3}-pyproj as build-dependencies.
* Patch: use setuptools not distutils
2016-01-26 - Alastair McKinstry <mckinstry@debian.org>
pygrib (2.0.1-1) unstable; urgency=medium
* New upstream release.
* Change homepage from code.google.com to github.

See Also

Package Description
python3-gribapi_1.28.0-2_amd64.deb Python3 module for the ECMWF GRIB API library
python3-gridfs_3.7.1-1.1_all.deb Python3 implementation of GridFS for MongoDB
python3-grpc-tools_1.14.1-1_amd64.deb Protobuf code generator for gRPC (Python 3)
python3-grpcio_1.16.1-1_amd64.deb GRPC system (Python 3)
python3-gssapi_1.4.1-1+b1_amd64.deb Python 3 interface to GSSAPI
python3-gst-1.0_1.14.4-1+b1_amd64.deb GStreamer GObject Introspection overrides for Python (Python 3)
python3-gsw_3.3.0-1_amd64.deb Python 3 implementation of the Thermodynamic Equation of Seawater
python3-gtkspellcheck_4.0.5-1_all.deb Python 3 spellchecking library for GTK+ based on Enchant
python3-gtts-token_1.1.1-1_all.deb Calculates a token to run the Google Translate text to speech (Python 3)
python3-gtts_1.2.0-1_all.deb Wrapper and CLI utility for the Google TTS (Text-to-Speech) API (Python 3)
python3-gudhi_2.3.0+dfsg-2+b1_amd64.deb Python 3 interface to the GUDHI library
python3-guess-language_0.5.2-5_all.deb library to detect the natural language of a text (Python 3 version)
python3-guestfs_1.40.2-2_amd64.deb guest disk image management system - Python 3 bindings
python3-guidata_1.7.6-1_all.deb dataset manipulation GUI generator - Python 3
python3-guiqwt_3.0.3-3_amd64.deb efficient 2D data-plotting library - Python 3
Advertisement
Advertisement