python3-geopy_1.18.1-1_all.deb


Advertisement

Description

python3-geopy - geocoding toolbox for Python3

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename python3-geopy_1.18.1-1_all.deb
Package name python3-geopy
Package version 1.18.1
Package release 1
Package architecture all
Package type deb
Category python
Homepage https://github.com/geopy/geopy
License -
Maintainer Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Download size 50.89 KB
Installed size 334.00 KB
geopy makes it easy for developers to locate the coordinates of addresses,
cities, countries, and landmarks across the globe using third-party geocoders
and other sources of data, such as wikis.
It also comes with the necessary means for parsing geographical coordinates
and geodesic distance calculation (using great-circle distance or Vincenty
distance). The distance module also contains useful routines for converting
between length and angle units.
This package contains the Python 3 version of the library.

Alternatives

Package Version Architecture Repository
python3-geopy_1.18.1-1_all.deb 1.18.1 all Debian Main
python3-geopy - - -

Requires

Name Value
python3-geographiclib -
python3:any -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python3-geopy_1.18.1-1_all.deb
Source Package geopy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-geopy deb package:
    # sudo apt-get install python3-geopy

Files

Path
/usr/lib/python3/dist-packages/geopy/__init__.py
/usr/lib/python3/dist-packages/geopy/compat.py
/usr/lib/python3/dist-packages/geopy/distance.py
/usr/lib/python3/dist-packages/geopy/exc.py
/usr/lib/python3/dist-packages/geopy/format.py
/usr/lib/python3/dist-packages/geopy/location.py
/usr/lib/python3/dist-packages/geopy/point.py
/usr/lib/python3/dist-packages/geopy/timezone.py
/usr/lib/python3/dist-packages/geopy/units.py
/usr/lib/python3/dist-packages/geopy/util.py
/usr/lib/python3/dist-packages/geopy-1.18.1.egg-info/PKG-INFO
/usr/lib/python3/dist-packages/geopy-1.18.1.egg-info/dependency_links.txt
/usr/lib/python3/dist-packages/geopy-1.18.1.egg-info/requires.txt
/usr/lib/python3/dist-packages/geopy-1.18.1.egg-info/top_level.txt
/usr/lib/python3/dist-packages/geopy/extra/__init__.py
/usr/lib/python3/dist-packages/geopy/extra/rate_limiter.py
/usr/lib/python3/dist-packages/geopy/geocoders/__init__.py
/usr/lib/python3/dist-packages/geopy/geocoders/arcgis.py
/usr/lib/python3/dist-packages/geopy/geocoders/azure.py
/usr/lib/python3/dist-packages/geopy/geocoders/baidu.py
/usr/lib/python3/dist-packages/geopy/geocoders/banfrance.py
/usr/lib/python3/dist-packages/geopy/geocoders/base.py
/usr/lib/python3/dist-packages/geopy/geocoders/bing.py
/usr/lib/python3/dist-packages/geopy/geocoders/databc.py
/usr/lib/python3/dist-packages/geopy/geocoders/geocodeearth.py
/usr/lib/python3/dist-packages/geopy/geocoders/geocodefarm.py
/usr/lib/python3/dist-packages/geopy/geocoders/geolake.py
/usr/lib/python3/dist-packages/geopy/geocoders/geonames.py
/usr/lib/python3/dist-packages/geopy/geocoders/googlev3.py
/usr/lib/python3/dist-packages/geopy/geocoders/here.py
/usr/lib/python3/dist-packages/geopy/geocoders/ignfrance.py
/usr/lib/python3/dist-packages/geopy/geocoders/mapbox.py
/usr/lib/python3/dist-packages/geopy/geocoders/opencage.py
/usr/lib/python3/dist-packages/geopy/geocoders/openmapquest.py
/usr/lib/python3/dist-packages/geopy/geocoders/osm.py
/usr/lib/python3/dist-packages/geopy/geocoders/pelias.py
/usr/lib/python3/dist-packages/geopy/geocoders/photon.py
/usr/lib/python3/dist-packages/geopy/geocoders/pickpoint.py
/usr/lib/python3/dist-packages/geopy/geocoders/smartystreets.py
/usr/lib/python3/dist-packages/geopy/geocoders/tomtom.py
/usr/lib/python3/dist-packages/geopy/geocoders/what3words.py
/usr/lib/python3/dist-packages/geopy/geocoders/yandex.py
/usr/share/doc/python3-geopy/changelog.Debian.gz
/usr/share/doc/python3-geopy/copyright

Changelog

2019-01-01 - Daniele Tricoli <eriol@debian.org>
geopy (1.18.1-1) unstable; urgency=medium
* New upstream release.
* debian/control
- Update to use my debian.org mail address.
- Bump Standards-Version to 4.3.0 (no changes needed).
* debian/copyright
- Update to use my debian.org mail address.
* debian/patches/0001-Prevent-encoding-issues-reading-README.rst.patch
- Refresh.
2018-08-28 - Daniele Tricoli <eriol@mornie.org>
geopy (1.16.0-1) unstable; urgency=medium
[ Ondřej Nový ]
* Fixed VCS URL (https)
* d/control: Set Vcs-* to salsa.debian.org
* d/copyright: Use https protocol in Format field
* d/control: Remove ancient X-Python-Version field
* Convert git repository from git-dpm to gbp layout
[ Daniele Tricoli ]
* New upstream release. (Closes: #906749)
* Refresh patches after git-dpm to gbp pq conversion
* Add gbp.conf.
* Bump debhelper compat level to 11.
* debian/control
- Add python{,3}-geographiclib to Depends.
- Remove python{,3}-requests{,-oauthlib} from Recommends.
- Add autodep8 tests.
- Bump Standards-Version to 4.2.1 (no changes needed).
* debian/copyright
- Update copyright years.
- Remove Files-Excluded field since no more needed.
* debian/patches/04_use_lt_and_eq_instead_of_cmp.patch
- Drop since it's not needed anymore.
* debian/patches/0001-Prevent-encoding-issues-reading-README.rst.patch
- Prevent encoding issues reading README.rst.
2015-11-06 - Daniele Tricoli <eriol@mornie.org>
geopy (1.11.0+ds1-1) unstable; urgency=medium
* New upstream release.
* Remove prebuilt python objects.
* debian/control
- Update Homepage field.
- Update Vcs fields for git migration.
* debian/copyright
- Update copyright years.
- Use Files-Excluded to remove shipped prebuilt python objects.
- Change upstream copyright holders to reflect license file update.
* debian/watch
- Use pypi.debian.net redirector.
2014-10-22 - Daniele Tricoli <eriol@mornie.org>
geopy (1.3.0-1) unstable; urgency=medium
* New upstream release.
* debian/control
- Bump Standards-Version to 3.9.6 (no changes needed).
- Add python{,3}-tz to Reccomends since Google geocoder needs them to
locate timezones.
* debian/copyright
- Update upstream copyright years.
- Update Upstream-Contact.
* debian/rules
- Use PYBUILD_NAME instead of PYBUILD_DESTDIR_python{2,3}.
2014-03-31 - Daniele Tricoli <eriol@mornie.org>
geopy (0.99-1) unstable; urgency=medium
* New upstream release
2014-03-08 - Daniele Tricoli <eriol@mornie.org>
geopy (0.98.3-1) unstable; urgency=medium
* New upstream release
2014-02-13 - Daniele Tricoli <eriol@mornie.org>
geopy (0.98-1) unstable; urgency=medium
* New upstream release
* Switched to pybuild
* debian/control
- Bumped Standards-Version to 3.9.5 (no changes needed)
- Removed python-beautifulsoup from (Build-)Depends since not used anymore
- Added python(3)-requests and python(3)-requests-oauthlib to Recommends
since YahooPlaceFinder geocoder needs them
- Removed python-nose from Build-Depends since tests are not shipped
anymore
* debian/copyright
- Updated copyright year
* debian/patches/01_add_missing_test_file.patch
- Removed since no more used upstream
* debian/patches/02_fix_missing_imports.patch:
- Removed since upstream removed MediaWiki and SemanticMediaWiki geocoders
* debian/patches/03_fix_typo.patch
- Removed since upstream removed SemanticMediaWiki geocoder and Geohash
module
* debian/patches/04_use_lt_and_eq_instead_of_cmp.patch
- Refreshed

See Also

Package Description
python3-geotiepoints_1.1.7-1_amd64.deb Interpolation of geographic tiepoints in Python
python3-germinate_2.31_all.deb expand dependencies in seed packages (Python 3 interface)
python3-gerritlib_0.8.0-1_all.deb client library for accessing Gerrit with Python3
python3-getdns_1.0.0~b1-1+b4_amd64.deb modern asynchronous DNS API (python 3 bindings)
python3-gevent_1.3.7-1_amd64.deb gevent is a coroutine-based Python networking library
python3-gfapy_1.0.0+dfsg-3_amd64.deb flexible and extensible software library for handling sequence graphs
python3-gffutils_0.9-1_all.deb Work with GFF and GTF files in a flexible database framework
python3-gflags_1.5.1-5_all.deb implementation of the Google command line flags module - Python 3.x
python3-ghdiff_0.4-2_all.deb Generator of Github-style HTML for unified diffs
python3-gi-cairo_3.30.4-1_amd64.deb Python 3 Cairo bindings for the GObject library
python3-gi_3.30.4-1_amd64.deb Python 3 bindings for gobject-introspection libraries
python3-gimmik_2.1-1_all.deb generator of matrix multiplication kernels (Python 3)
python3-ginga_2.7.2-2_all.deb Astronomical image toolkit for Python
python3-git-os-job_1.0.1-2_all.deb Show the OpenStack job logs for a commit - Python 3.x
python3-git_2.1.11-1_all.deb Python library to interact with Git repositories - Python 3.x
Advertisement
Advertisement