python3-cupshelpers_1.5.11-4_all.deb


Advertisement

Description

python3-cupshelpers - Python utility modules around the CUPS printing system

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename python3-cupshelpers_1.5.11-4_all.deb
Package name python3-cupshelpers
Package version 1.5.11
Package release 4
Package architecture all
Package type deb
Category python
Homepage https://github.com/zdohnal/system-config-printer
License -
Maintainer Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Download size 120.75 KB
Installed size 239.00 KB
These Python modules, that come from the system-config-printer
distribution, help building applications and utilities around the CUPS
Python bindings.

Alternatives

Package Version Architecture Repository
python3-cupshelpers_1.5.11-4_all.deb 1.5.11 all Debian Main
python3-cupshelpers - - -

Requires

Name Value
python3-cups >= 1.9.42
python3-dbus -
python3-requests -
python3:any -

Replaces

Name Value
python-cupshelpers <= 1.5

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python3-cupshelpers_1.5.11-4_all.deb
Source Package system-config-printer

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-cupshelpers deb package:
    # sudo apt-get install python3-cupshelpers

Files

Path
/etc/cupshelpers/preferreddrivers.xml
/usr/lib/python3/dist-packages/cupshelpers-1.0.egg-info
/usr/lib/python3/dist-packages/cupshelpers/__init__.py
/usr/lib/python3/dist-packages/cupshelpers/config.py
/usr/lib/python3/dist-packages/cupshelpers/cupshelpers.py
/usr/lib/python3/dist-packages/cupshelpers/installdriver.py
/usr/lib/python3/dist-packages/cupshelpers/openprinting.py
/usr/lib/python3/dist-packages/cupshelpers/ppds.py
/usr/lib/python3/dist-packages/cupshelpers/xmldriverprefs.py
/usr/share/doc/python3-cupshelpers/changelog.Debian.gz
/usr/share/doc/python3-cupshelpers/changelog.gz
/usr/share/doc/python3-cupshelpers/copyright

Changelog

2018-12-27 - Jeremy Bicha <jbicha@debian.org>
system-config-printer (1.5.11-4) unstable; urgency=medium
* Add -Wl,-O1 to our LDFLAGS
* Bump Standards-Version to 4.3.0
2018-09-29 - Jeremy Bicha <jbicha@debian.org>
system-config-printer (1.5.11-3) unstable; urgency=medium
* Cherry-pick define-classes-for-Secret-only-when-libsecret-installed.patch:
- Don't crash when gir1.2-secret-1 is not installed (Closes: #892256)
* Bump Standards-Version to 4.2.1
* Don't install AUTHORS since it duplicates debian/copyright
* Remove upstream signing key.
- Releases haven't been signed since moving to Github
2018-03-20 - Jeremy Bicha <jbicha@debian.org>
system-config-printer (1.5.11-2) unstable; urgency=medium
* Build-Depend on python3-distutils
2018-02-26 - Laurent Bigonville <bigon@debian.org>
system-config-printer (1.5.11-1) unstable; urgency=medium
[ Jeremy Bicha ]
* Update Vcs fields for migration to https://salsa.debian.org/
[ Laurent Bigonville ]
* New upstream release.
- Drop d/p/0010-no-start-printer-applet-gnome.patch, applied upstream
- Use libsecret instead of gnome-keyring (Closes: #867952)
- debian/system-config-printer.install: Fix installation of appdata file
* debian/rules: Fix the URL to download the orig tarball using get-orig-source
* d/p/0003-Use-ValueError-instead-of-ImportError-to-catch-excep.patch: Fix
exception handling when importing libsecret, that should made it really
optional (Closes: #868039)
* d/p/0004-Fix-constructing-the-auth-dialog.patch: Fix constructing the auth
dialog, from upstream
* d/p/0005-Require-proper-version-of-GDK-and-GTK-in-scp-dbus-se.patch,
d/p/0006-Set-programe-name-for-scp-dbus-service-as-well.patch: Require
version of GDK and GTK bindings before importing them and properly set the
program name even when scp-dbus-service is D-Bus activated.
2017-12-16 - Jeremy Bicha <jbicha@debian.org>
system-config-printer (1.5.9-3) unstable; urgency=medium
* Update Vcs fields for conversion to git
* Add debian/gbp.conf
* Bump Standards-Version to 4.1.2
* Bump debhelper compat to 11
2017-06-21 - Laurent Bigonville <bigon@debian.org>
system-config-printer (1.5.9-2) unstable; urgency=medium
[ Jeremy Bicha ]
* Update debian/watch and Homepage to point to github repo
* Update Vcs links
[ Laurent Bigonville ]
* debian/control.in: Make the system-config-printer-common package recommend
cups-pk-helper and python3-smbc package instead of system-config-printer,
the code using these modules are in that package.
* debian/rules: Remove the dbus/org.fedoraproject.Config.Printing.service
file during the clean target so it's generated with the proper path
2017-02-23 - Laurent Bigonville <bigon@debian.org>
system-config-printer (1.5.9-1) experimental; urgency=medium
* New upstream release.
- Drop debian/patches/0008-fix-device-sorting.patch,
debian/patches/0009-fix-udev-add-printer-shbang.patch: Merged upstream
- debian/patches/0007-fix-pk-package-name.patch: Refreshed
* Switch to dh sequences from cdbs
* Do not install smburi.py and debug.py in python3-cupshelpers anymore, this
doesn't seem needed anymore
* Bump debhelper compatibility to version 10
* Drop debian/patches/03_install_layout.patch, this doesn't seem needed
anymore and adjust debian/python3-cupshelpers.install
* debian/control.in: Add gir1.2-polkit-1.0 to the dependencies
2017-02-23 - Laurent Bigonville <bigon@debian.org>
system-config-printer (1.5.7-3) unstable; urgency=medium
* debian/patches/0010-no-start-printer-applet-gnome.patch: Do not start the
printer-applet in GNOME or Cinnamon {gnome,cinnamon}-settings-daemon is
already taking care of this.
* debian/rules: Move the definition of DEB_PYTHON3_MODULE_PACKAGES before
including python-module.mk otherwise cdbs is not calling dh_python3 as
expected

See Also

Package Description
python3-cursive_0.2.1-2_all.deb OpenStack specific validation of digital signatures - Python 3
python3-curtsies_0.2.12-1_all.deb library for terminal interaction (Python 3)
python3-cutadapt_1.18-1_amd64.deb Clean biological sequences from high-throughput sequencing reads (Python 3)
python3-cv-bridge_1.13.0+ds-2+b12_amd64.deb cv_bridge ROS package - Python 3 bindings
python3-cvxopt_1.1.9+dfsg-3+b1_amd64.deb Python3 package for convex optimization
python3-cxx-dev_7.0.3-2_all.deb Set of facilities to extend Python3 with C++
python3-cycler_0.10.0-1_all.deb composable kwarg iterator (Python 3)
python3-cymem_2.0.2-1_amd64.deb cython memory pool for RAII-style memory management
python3-cymruwhois_1.6-3.1_all.deb Python library for interfacing with the whois.cymru.com service (Python 3)
python3-cypari2_1.3.1-2_amd64.deb Python interface to PARI -- Python 3
python3-cysignals-bare_1.8.1+ds-2_amd64.deb interrupt and signal handling for Cython -- Python 3 - bare
python3-cysignals-pari_1.8.1+ds-2_amd64.deb interrupt and signal handling for Cython -- Python 3 - PARI/GP
python3-cytoolz_0.9.0.1-2_amd64.deb Toolz in Cython: High performance functional utilities
python3-cyvcf2_0.10.4-1_amd64.deb VCF parser based on htslib (Python 3)
python3-d2to1_0.2.12-1_all.deb Python3 support for distutils2-like setup.cfg files as package metadata
Advertisement
Advertisement