python3-cookiecutter_1.6.0-3_all.deb


Advertisement

Description

python3-cookiecutter - create projects from project templates (Python 3 module)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename python3-cookiecutter_1.6.0-3_all.deb
Package name python3-cookiecutter
Package version 1.6.0
Package release 3
Package architecture all
Package type deb
Category python
Homepage https://github.com/audreyr/cookiecutter
License -
Maintainer Vincent Bernat <bernat@debian.org>
Download size 45.52 KB
Installed size 153.00 KB
Cookiecutter is command-line utility that creates projects from
project templates, e.g. creating a Python package project from a
Python package project template.
It can also be used as a Python module. It supports local and remote
templates. The templating is done with Jinja2 and there is no
limitation on the language used by the templated projects (Python,
Ruby, Javascript, C, HTML, Postscript...).
This package contains the Python 3 module.

Alternatives

Package Version Architecture Repository
python3-cookiecutter_1.6.0-3_all.deb 1.6.0 all Debian Main
python3-cookiecutter - - -

Requires

Name Value
python3-binaryornot -
python3-click -
python3-future -
python3-jinja2 -
python3-jinja2-time -
python3-requests -
python3-ruamel.yaml >= 0.10.12
python3-whichcraft -
python3-yaml -
python3:any -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python3-cookiecutter_1.6.0-3_all.deb
Source Package cookiecutter

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-cookiecutter deb package:
    # sudo apt-get install python3-cookiecutter

Files

Path
/usr/lib/python3/dist-packages/cookiecutter/__init__.py
/usr/lib/python3/dist-packages/cookiecutter/__main__.py
/usr/lib/python3/dist-packages/cookiecutter/cli.py
/usr/lib/python3/dist-packages/cookiecutter/config.py
/usr/lib/python3/dist-packages/cookiecutter/environment.py
/usr/lib/python3/dist-packages/cookiecutter/exceptions.py
/usr/lib/python3/dist-packages/cookiecutter/extensions.py
/usr/lib/python3/dist-packages/cookiecutter/find.py
/usr/lib/python3/dist-packages/cookiecutter/generate.py
/usr/lib/python3/dist-packages/cookiecutter/hooks.py
/usr/lib/python3/dist-packages/cookiecutter/log.py
/usr/lib/python3/dist-packages/cookiecutter/main.py
/usr/lib/python3/dist-packages/cookiecutter/prompt.py
/usr/lib/python3/dist-packages/cookiecutter/replay.py
/usr/lib/python3/dist-packages/cookiecutter/repository.py
/usr/lib/python3/dist-packages/cookiecutter/utils.py
/usr/lib/python3/dist-packages/cookiecutter/vcs.py
/usr/lib/python3/dist-packages/cookiecutter/zipfile.py
/usr/lib/python3/dist-packages/cookiecutter-1.6.0.egg-info/PKG-INFO
/usr/lib/python3/dist-packages/cookiecutter-1.6.0.egg-info/dependency_links.txt
/usr/lib/python3/dist-packages/cookiecutter-1.6.0.egg-info/entry_points.txt
/usr/lib/python3/dist-packages/cookiecutter-1.6.0.egg-info/not-zip-safe
/usr/lib/python3/dist-packages/cookiecutter-1.6.0.egg-info/requires.txt
/usr/lib/python3/dist-packages/cookiecutter-1.6.0.egg-info/top_level.txt
/usr/share/doc/python3-cookiecutter/changelog.Debian.gz
/usr/share/doc/python3-cookiecutter/changelog.gz
/usr/share/doc/python3-cookiecutter/copyright

Changelog

2018-10-10 - Vincent Bernat <bernat@debian.org>
cookiecutter (1.6.0-3) unstable; urgency=medium
[ Vincent Bernat ]
* Switch to Python 3 for cookiecutter package. Closes: #902869.
* Patch test suite to work with unreleased version of python-click.
Closes: #908687.
[ Ondřej Nový ]
* Use 'python3 -m sphinx' instead of sphinx-build for building docs
2018-02-13 - Ondřej Nový <onovy@debian.org>
cookiecutter (1.6.0-2) unstable; urgency=medium
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
* d/copyright: Use https protocol in Format field
[ Gianfranco Costamagna ]
* Bump std-version to 4.1.3, no changes required.
* Team upload.
* Apply changes of 1.5.1-2 on top of 1.6.0
* Drop catchlog dependency (Closes: #894533)
- Enforce minimum pytest version
2017-11-12 - Vincent Bernat <bernat@debian.org>
cookiecutter (1.6.0-1) unstable; urgency=medium
* New upstream release.
* d/control: bump Standards-Version.
* d/control: build-depends on python*-pytest-cov.
* d/control: build-depends on python3-sphinx.
* d/patches: update privacy breach patch.
2017-09-16 - Vincent Bernat <bernat@debian.org>
cookiecutter (1.5.1-1) unstable; urgency=medium
* New upstream release.
* d/control: bump Standards-Version.
* Refresh patches after git-dpm to gbp pq conversion
2017-08-06 - Vincent Bernat <bernat@debian.org>
cookiecutter (1.5.0-2) unstable; urgency=medium
[ Ben Finney ]
* Add “Suggests: python-cookiecutter-doc” dependency.
Closes: #853038.
* Add “Suggests” to the documentation package for any of the code
packages.
2016-12-25 - Vincent Bernat <bernat@debian.org>
cookiecutter (1.5.0-1) unstable; urgency=medium
* New upstream release.
* Switch to debhelper 9.
2016-10-25 - Vincent Bernat <bernat@debian.org>
cookiecutter (1.4.0-3) unstable; urgency=medium
* Make the build reproducible by avoiding nondeterministic kwargs.
Closes: #834861.
* Change section for "cookiecutter" binary package to "devel".
Closes: #832198.
* Remove any privacy-breach images from documentation. Closes: #836159.
2016-07-03 - Vincent Bernat <bernat@debian.org>
cookiecutter (1.4.0-2) unstable; urgency=medium
* Build-Depends on python-sphinx-rtd-theme. Closes: #829364.
2016-05-28 - Vincent Bernat <bernat@debian.org>
cookiecutter (1.4.0-1) unstable; urgency=medium
[ Ondřej Nový ]
* Fixed VCS URL (https)
[ Vincent Bernat ]
* New upstream version.
* Update build-dependencies.
* Add a patch to use PyYAML instead of poyo.
* Bump Standards-Version. No changes.
2015-12-20 - Vincent Bernat <bernat@debian.org>
cookiecutter (1.3.0-2) unstable; urgency=medium
* Really depends on python{,3}-ruamel.yaml. Somehow, the previous
version was not uploaded correctly. Closes: #808382.

See Also

Package Description
python3-cookies_2.2.1-2_all.deb Python 3 RFC 6265-compliant cookie parser and renderer
python3-coreapi_2.3.3-3_all.deb Python3 client library for Core API
python3-coreschema_0.0.4-2_all.deb Python3 utilities to describe an abstract data schema to coreapi
python3-cotyledon_1.6.8-3_all.deb framework for defining long-running services - Python 3.x
python3-cov-core_1.15.0-2_all.deb plugin core for use by pytest-cov, nose-cov and nose2-cov
python3-coverage-test-runner_1.13.1-2_all.deb fail Python program unit tests unless they test everything
python3-coverage_4.5.2+dfsg.1-1_amd64.deb code coverage tool for Python 3
python3-cpl_0.7.4-2_amd64.deb Control pipeline recipes from the ESO (Python3)
python3-cpuinfo_4.0.0-1_all.deb Python module for getting CPU info (Python 3)
python3-cracklib_2.9.6-2_amd64.deb Python3 bindings for password checker library cracklib2
python3-cram_0.7-3_all.deb functional testing framework for command line applications - Python 3.x
python3-crank_0.7.2-4_all.deb dispatch mechanism for use across frameworks - Python 3.x
python3-crcelk_1.3-1_all.deb Implementation of the CRC algorithm (Python 3)
python3-crcmod_1.7+dfsg-1+b1_amd64.deb CRC Generator - Python 3.x
python3-croniter_0.3.24-2_all.deb provides iteration for datetime object with cron like format - Python 3.x
Advertisement
Advertisement