python-jpy_0.9.0-2_amd64.deb


Advertisement

Description

python-jpy - Bi-directional Python-Java bridge

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename python-jpy_0.9.0-2_amd64.deb
Package name python-jpy
Package version 0.9.0
Package release 2
Package architecture amd64
Package type deb
Category python uitoolkit::ncurses
Homepage https://github.com/bcdev/jpy.git
License -
Maintainer Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Download size 55.81 KB
Installed size 197.00 KB
jpy is a **bi-directional** Python-Java bridge which you can use to embed
Java code in Python programs or the other way round.
It has been designed particularly with regard to maximum
data transfer speed between the two languages.
It comes with a number of outstanding features:
* Fully translates Java class hierarchies to Python
* Transparently handles Java method overloading
* Support of Java multi-threading
* Fast and memory-efficient support of primitive Java array parameters via
`Python buffers <http://docs.python.org/3.3/c-api/buffer.html>`_
* Support of Java methods that modify primitive Java array parameters
(mutable parameters)
* Java arrays translate into Python sequence objects
* Java API for accessing Python objects (``jpy.jar``)
This package provides the Python interface.

Alternatives

Package Version Architecture Repository
python-jpy_0.9.0-2_i386.deb 0.9.0 i386 Debian Main
python-jpy - - -

Requires

Name Value
default-jre -
java7-runtime-headless -
libc6 >= 2.14
python << 2.8
python >= 2.7~
python:any >= 2.7.5-5~
python:any << 2.8

Provides

Name Value
python2.7-jpy -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python-jpy_0.9.0-2_amd64.deb
Source Package jpy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-jpy deb package:
    # sudo apt-get install python-jpy

Files

Path
/usr/lib/python2.7/dist-packages/jdl.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/jpy.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/jpyconfig.properties
/usr/lib/python2.7/dist-packages/jpyconfig.py
/usr/lib/python2.7/dist-packages/jpyutil.py
/usr/lib/python2.7/dist-packages/jpy-0.9.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/jpy-0.9.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/jpy-0.9.0.egg-info/top_level.txt
/usr/share/doc/python-jpy/README.md.gz
/usr/share/doc/python-jpy/changelog.Debian.gz
/usr/share/doc/python-jpy/changelog.gz
/usr/share/doc/python-jpy/copyright

Changelog

2018-07-09 - Alastair McKinstry <mckinstry@debian.org>
jpy (0.9.0-2) unstable; urgency=medium
* Drop obsolete X-Python*-Version field in d/control
* Stanrdards-Version: 4.1.5
* Change refs in d/docs to .md files from .rst; debhelper now fails on this
change, not silently. Closes: #903333
2018-05-21 - Alastair McKinstry <mckinstry@debian.org>
jpy (0.9.0-1) unstable; urgency=medium
* Change version from 0.9 to 0.9.0 to match upstream
* Standards-Version: 4.1.4
2018-02-11 - Alastair McKinstry <mckinstry@debian.org>
jpy (0.9-1) unstable; urgency=medium
* New upstream release
- no_ez-setup patch obsolete
- Patch added to not build Java component with Maven (yet)
* Standards-Version: 4.1.3
* Move VCS to point to salsa.debian.org
2017-08-02 - Alastair McKinstry <mckinstry@debian.org>
jpy (0.8-9) unstable; urgency=medium
* Log class has no method warning. Use error instead. 
2017-08-02 - Alastair McKinstry <mckinstry@debian.org>
jpy (0.8-8) unstable; urgency=medium
* Add patch to disable failure on test failure (mips test fails
randomly due to resource issues) Closes: #866536
2017-07-05 - Alastair McKinstry <mckinstry@debian.org>
jpy (0.8-7) unstable; urgency=medium
* Ignore tests on mips, mipsel; they fail intermittently due to low mem
2017-07-03 - Alastair McKinstry <mckinstry@debian.org>
jpy (0.8-6) unstable; urgency=medium
* Update watch file
* DH_COMPAT=10, debhelper dependency updated
* Standards-Version: 4.0.0; no changes required
2016-09-05 - Alastair McKinstry <mckinstry@debian.org>
jpy (0.8-5) unstable; urgency=medium
[ Fernando Seiti Furusato ]
* debian/patches/ppc64el.patch: fixing ppc64el arch dir to fix FTBFS.
OpenJDK is currently using notation 'ppc64le'. Closes: #833174
[ Chris Lamb ]
* Patch for bit-reproduciblity. Closes: #834897.
[Alastair McKinstry]
* Enable powerpc, arm64, sparc64 archs.
2016-07-07 - Alastair McKinstry <mckinstry@debian.org>
jpy (0.8-4) unstable; urgency=medium
* Adapt patch to detect more archs correctly
2016-07-07 - Alastair McKinstry <mckinstry@debian.org>
jpy (0.8-3) unstable; urgency=medium
* Remove hard-coded amd64/i386 arch for JVM search.
Use `dpkg --print-architecture`

See Also

Package Description
python-jpylyzer-doc_1.18.0-3_all.deb JP2 (JPEG 2000 Part 1) validator and properties extractor - doc
python-jpylyzer_1.18.0-3_all.deb JP2 (JPEG 2000 Part 1) validator and properties extractor
python-jpype_0.6.3+dfsg-1+b1_amd64.deb Binding the worlds of Java and Python (for Python 2)
python-jsbeautifier_1.6.4-7_all.deb JavaScript unobfuscator and beautifier (python2)
python-jsmin_2.2.2-1_all.deb JavaScript minifier written in Python - Python 2.x
python-json-pointer-doc_1.10-1_all.deb resolve JSON pointers - doc
python-json-pointer_1.10-1_all.deb resolve JSON pointers - Python 2.7
python-json-tricks_3.11.0-1_all.deb Python module with extra features for JSON files
python-jsondiff_1.1.1-2_all.deb diff JSON and JSON-like structures in Python 2
python-jsonext_0.4.1-1_all.deb serialisation to/from JSON for extra types — Python 2
python-jsonhyperschema-codec_1.0.3-1_all.deb Python2 JSON Hyper-Schema codec for Core API
python-jsonpatch_1.21-1_all.deb library to apply JSON patches - Python 2.x
python-jsonpath-rw-ext-doc_1.1.3-1_all.deb Extensions for JSONPath RW - doc
python-jsonpath-rw-ext_1.1.3-1_all.deb extensions for JSONPath RW - Python 2.x
python-jsonpath-rw_1.4.0-3_all.deb extended implementation of JSONPath for Python 2.x
Advertisement
Advertisement