python-gmpy2-doc_2.1.0~a4-1_all.deb


Advertisement

Description

python-gmpy2-doc - documentation for python-gmpy2

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename python-gmpy2-doc_2.1.0~a4-1_all.deb
Package name python-gmpy2-doc
Package version 2.1.0~a4
Package release 1
Package architecture all
Package type deb
Category python
Homepage https://pypi.python.org/pypi/gmpy2
License -
Maintainer Martin Kelly <martin@martingkelly.com>
Download size 58.53 KB
Installed size 385.00 KB
gmpy is a C-coded Python extension module that wraps the GMP library to
provide to Python code fast multiprecision arithmetic (integer, rational, and
float), random number generation, advanced number-theoretical functions, and
more.
This package installs additional documentation for python-gmpy2 and
python3-gmpy2.

Alternatives

Package Version Architecture Repository
python-gmpy2-doc_2.1.0~a4-1_all.deb 2.1.0~a4 all Debian Main
python-gmpy2-doc - - -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python-gmpy2-doc_2.1.0~a4-1_all.deb
Source Package python-gmpy2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-gmpy2-doc deb package:
    # sudo apt-get install python-gmpy2-doc

Files

Path
/usr/share/doc-base/python-gmpy2-doc
/usr/share/doc/python-gmpy2-doc/changelog.Debian.gz
/usr/share/doc/python-gmpy2-doc/changelog.gz
/usr/share/doc/python-gmpy2-doc/copyright
/usr/share/doc/python-gmpy2/html/advmpz.html
/usr/share/doc/python-gmpy2/html/cython.html
/usr/share/doc/python-gmpy2/html/genindex.html
/usr/share/doc/python-gmpy2/html/history.html
/usr/share/doc/python-gmpy2/html/index.html
/usr/share/doc/python-gmpy2/html/intro.html
/usr/share/doc/python-gmpy2/html/mpc.html
/usr/share/doc/python-gmpy2/html/mpfr.html
/usr/share/doc/python-gmpy2/html/mpq.html
/usr/share/doc/python-gmpy2/html/mpz.html
/usr/share/doc/python-gmpy2/html/objects.inv
/usr/share/doc/python-gmpy2/html/overview.html
/usr/share/doc/python-gmpy2/html/search.html
/usr/share/doc/python-gmpy2/html/searchindex.js
/usr/share/doc/python-gmpy2/html/_sources/advmpz.rst.txt
/usr/share/doc/python-gmpy2/html/_sources/cython.rst.txt
/usr/share/doc/python-gmpy2/html/_sources/history.rst.txt
/usr/share/doc/python-gmpy2/html/_sources/index.rst.txt
/usr/share/doc/python-gmpy2/html/_sources/intro.rst.txt
/usr/share/doc/python-gmpy2/html/_sources/mpc.rst.txt
/usr/share/doc/python-gmpy2/html/_sources/mpfr.rst.txt
/usr/share/doc/python-gmpy2/html/_sources/mpq.rst.txt
/usr/share/doc/python-gmpy2/html/_sources/mpz.rst.txt
/usr/share/doc/python-gmpy2/html/_sources/overview.rst.txt
/usr/share/doc/python-gmpy2/html/_static/ajax-loader.gif
/usr/share/doc/python-gmpy2/html/_static/basic.css
/usr/share/doc/python-gmpy2/html/_static/classic.css
/usr/share/doc/python-gmpy2/html/_static/comment-bright.png
/usr/share/doc/python-gmpy2/html/_static/comment-close.png
/usr/share/doc/python-gmpy2/html/_static/comment.png
/usr/share/doc/python-gmpy2/html/_static/default.css
/usr/share/doc/python-gmpy2/html/_static/doctools.js
/usr/share/doc/python-gmpy2/html/_static/documentation_options.js
/usr/share/doc/python-gmpy2/html/_static/down-pressed.png
/usr/share/doc/python-gmpy2/html/_static/down.png
/usr/share/doc/python-gmpy2/html/_static/file.png
/usr/share/doc/python-gmpy2/html/_static/jquery.js
/usr/share/doc/python-gmpy2/html/_static/language_data.js
/usr/share/doc/python-gmpy2/html/_static/minus.png
/usr/share/doc/python-gmpy2/html/_static/plus.png
/usr/share/doc/python-gmpy2/html/_static/pygments.css
/usr/share/doc/python-gmpy2/html/_static/searchtools.js
/usr/share/doc/python-gmpy2/html/_static/sidebar.js
/usr/share/doc/python-gmpy2/html/_static/underscore.js
/usr/share/doc/python-gmpy2/html/_static/up-pressed.png
/usr/share/doc/python-gmpy2/html/_static/up.png

Changelog

2019-01-10 - Martin Kelly <martin@martingkelly.com>
python-gmpy2 (2.1.0~a4-1) unstable; urgency=medium
[ Ondřej Nový ]
* Convert git repository from git-dpm to gbp layout
[ Martin Kelly ]
* Update to 2.1.0~a4 (Closes: #918802).
* Fix a variety of Lintian warnings.
2018-07-22 - Martin Kelly <martin@martingkelly.com>
python-gmpy2 (2.0.8-3) unstable; urgency=medium
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
* d/copyright: Use https protocol in Format field
* d/watch: Use https protocol
* d/control: Remove ancient X-Python-Version field
* d/control: Remove ancient X-Python3-Version field
[ Martin Kelly ]
* d/control: Change sphinx build-depends to use Python 3
* d/control: Bump policy version to 4.1.5 (no changes needed)
2017-03-11 - Martin Kelly <martin@martingkelly.com>
python-gmpy2 (2.0.8-2) unstable; urgency=medium
* Fixed all known copyrights and licenses (Closes: #857455).
2017-03-07 - Martin Kelly <martin@martingkelly.com>
python-gmpy2 (2.0.8-1) unstable; urgency=medium
[ Martin Kelly ]
* Corrected a few stale entries in copyright file (also fixes a lintian
warning).
* Bumped policy version to 3.9.8.0
* Use Multi-Arch: same for binary packages
* Create -doc package
* Update packaging copyright dates
[ Ondřej Nový ]
* Fixed VCS URL (https)
2015-12-02 - Martin Kelly <martin@martingkelly.com>
python-gmpy2 (2.0.7-2) unstable; urgency=medium
* Overhauled debian/rules to use pybuild. Things look a lot better now!
Since dpkg-buildpackage -A and dpkg-buildpackage -B now work correctly,
this also Closes: #805958.
* Update URL in changelog to PyPi.
2015-08-23 - Martin Kelly <martin@martingkelly.com>
python-gmpy2 (2.0.7-1) unstable; urgency=medium
* New upstream release
* Fixed duplicate long description lintian error
2015-06-23 - Martin Kelly <martin@martingkelly.com>
python-gmpy2 (2.0.5-1) unstable; urgency=medium
* New upstream release
* Fixed watch file to use PyPi redirector
* Removed bogus test correction patches that are now present upstream
* Made the Sphinx manpage use the most recent changelog entry for build date
so we get reproducible builds
2014-11-01 - Martin Kelly <martin@martingkelly.com>
python-gmpy2 (2.0.4-2) unstable; urgency=medium
* Adding in upstream patch for bogus test failures. We can drop the patch at
next release. Closes: #767417.
* Adding Multi-Arch: foreign so that just one copy of the -common package is
required for multi-arch setups.
2014-10-26 - Martin Kelly <martin@martingkelly.com>
python-gmpy2 (2.0.4-1) unstable; urgency=medium
* New upstream release
* Updated Standards-Version to 3.9.6.0 (no changes needed)
* Using machine-readable copyright file
* Copyright is GPL 3 now, not GPL 2; fixed
* Fixed build error by adding -a flag to dh_* scripts
* Added dh-python to Build-Depends
* Dropping manpage patch (it's now fixed upstream)
* Unit tests now return error code, so the package build will fail if they
fail
2014-02-23 - Martin Kelly <martin@martingkelly.com>
python-gmpy2 (2.0.3-1) unstable; urgency=medium
* New upstream release
* Updated Standards-Version to 3.9.5.0 (no changes needed)
* Changed Python 3 dev build dependency to python3-all-dev
* Added Python and Python 3 as build dependencies (needed to run setup.py)

See Also

Package Description
python-gmpy2_2.1.0~a4-1_amd64.deb interfaces GMP to Python 2 for fast, unbound-precision computations
python-gmpy_1.17-4_amd64.deb interfaces GMP to Python for fast, unbound-precision computations
python-gnatpython-doc_54-3_all.deb Python framework to ease development of test suites (examples)
python-gnatpython_54-3+b1_amd64.deb Python framework to ease development of test suites
python-gnocchiclient-doc_7.0.2-2_all.deb bindings to the OpenStack Gnocchi API - doc
python-gnocchiclient_7.0.2-2_all.deb bindings to the OpenStack Gnocchi API - Python 2.7
python-gnucap_0.0.2-1.1_amd64.deb Python 2 bindings for the GNU Circuit Analysis Package
python-gnupg_0.4.4-1_all.deb Python wrapper for the GNU Privacy Guard (Python 2.x)
python-gnuplot_1.8-6_all.deb Python interface to the gnuplot plotting program
python-gnuplotlib_0.28-1_all.deb Gnuplot-based plotter for numpy
python-gnutls_3.1.2-1_amd64.deb Python wrapper for the GNUTLS library
python-gobject-2-dev_2.28.6-13_all.deb development headers for the static GObject Python bindings
python-gobject-2_2.28.6-13+b1_amd64.deb deprecated static Python bindings for the GObject library
python-gobject_3.30.4-1_all.deb Python 2.x bindings for GObject - transitional package
python-goocalendar_0.4-2_all.deb Calendar widget for GTK+ using PyGoocanvas (Python 2)
Advertisement
Advertisement