python-gabbi-doc_1.40.0-4_all.deb


Advertisement

Description

python-gabbi-doc - declarative HTTP testing library - doc

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename python-gabbi-doc_1.40.0-4_all.deb
Package name python-gabbi-doc
Package version 1.40.0
Package release 4
Package architecture all
Package type deb
Category doc
Homepage https://github.com/cdent/gabbi
License -
Maintainer Debian OpenStack <openstack-devel@lists.alioth.debian.org>
Download size 50.67 KB
Installed size 354.00 KB
Gabbi is a tool for running HTTP tests where requests and responses are
represented in a declarative form.
Gabbi works to bridge the gap between human readable YAML files that represent
HTTP requests and expected responses and the obscured realm of Python-based,
object-oriented unit tests in the style of the unittest module and its
derivatives.
Each YAML file represents an ordered list of HTTP requests along with the
expected responses. This allows a single file to represent a process in the
API being tested. For example:
* Create a resource.
* Retrieve a resource.
* Delete a resource.
* Retrieve a resource again to confirm it is gone.
At the same time it is still possible to ask gabbi to run just one request.
If it is in a sequence of tests, those tests prior to it in the YAML file will
be run (in order). In any single process any test will only be run once.
Concurrency is handled such that one file runs in one process.
These features mean that it is possible to create tests that are useful for
both humans (as tools for improving and developing APIs) and automated CI
systems.
This package contains the documentation.

Alternatives

Package Version Architecture Repository
python-gabbi-doc_1.40.0-4_all.deb 1.40.0 all Debian Main
python-gabbi-doc - - -

Requires

Name Value
libjs-sphinxdoc >= 1.0

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python-gabbi-doc_1.40.0-4_all.deb
Source Package python-gabbi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-gabbi-doc deb package:
    # sudo apt-get install python-gabbi-doc

Files

Path
/usr/share/doc-base/python-gabbi-doc
/usr/share/doc/python-gabbi-doc/changelog.Debian.gz
/usr/share/doc/python-gabbi-doc/copyright
/usr/share/doc/python-gabbi-doc/html/example.html
/usr/share/doc/python-gabbi-doc/html/faq.html
/usr/share/doc/python-gabbi-doc/html/fixtures.html
/usr/share/doc/python-gabbi-doc/html/format.html
/usr/share/doc/python-gabbi-doc/html/gabbi.html
/usr/share/doc/python-gabbi-doc/html/genindex.html
/usr/share/doc/python-gabbi-doc/html/handlers.html
/usr/share/doc/python-gabbi-doc/html/host.html
/usr/share/doc/python-gabbi-doc/html/index.html
/usr/share/doc/python-gabbi-doc/html/jsonpath.html
/usr/share/doc/python-gabbi-doc/html/loader.html
/usr/share/doc/python-gabbi-doc/html/objects.inv
/usr/share/doc/python-gabbi-doc/html/py-modindex.html
/usr/share/doc/python-gabbi-doc/html/release.html
/usr/share/doc/python-gabbi-doc/html/runner.html
/usr/share/doc/python-gabbi-doc/html/search.html
/usr/share/doc/python-gabbi-doc/html/searchindex.js
/usr/share/doc/python-gabbi-doc/html/_sources/example.rst.txt
/usr/share/doc/python-gabbi-doc/html/_sources/faq.rst.txt
/usr/share/doc/python-gabbi-doc/html/_sources/fixtures.rst.txt
/usr/share/doc/python-gabbi-doc/html/_sources/format.rst.txt
/usr/share/doc/python-gabbi-doc/html/_sources/gabbi.rst.txt
/usr/share/doc/python-gabbi-doc/html/_sources/handlers.rst.txt
/usr/share/doc/python-gabbi-doc/html/_sources/host.rst.txt
/usr/share/doc/python-gabbi-doc/html/_sources/index.rst.txt
/usr/share/doc/python-gabbi-doc/html/_sources/jsonpath.rst.txt
/usr/share/doc/python-gabbi-doc/html/_sources/loader.rst.txt
/usr/share/doc/python-gabbi-doc/html/_sources/release.rst.txt
/usr/share/doc/python-gabbi-doc/html/_sources/runner.rst.txt
/usr/share/doc/python-gabbi-doc/html/_static/ajax-loader.gif
/usr/share/doc/python-gabbi-doc/html/_static/basic.css
/usr/share/doc/python-gabbi-doc/html/_static/classic.css
/usr/share/doc/python-gabbi-doc/html/_static/comment-bright.png
/usr/share/doc/python-gabbi-doc/html/_static/comment-close.png
/usr/share/doc/python-gabbi-doc/html/_static/comment.png
/usr/share/doc/python-gabbi-doc/html/_static/default.css
/usr/share/doc/python-gabbi-doc/html/_static/doctools.js
/usr/share/doc/python-gabbi-doc/html/_static/down-pressed.png
/usr/share/doc/python-gabbi-doc/html/_static/down.png
/usr/share/doc/python-gabbi-doc/html/_static/file.png
/usr/share/doc/python-gabbi-doc/html/_static/jquery.js
/usr/share/doc/python-gabbi-doc/html/_static/minus.png
/usr/share/doc/python-gabbi-doc/html/_static/plus.png
/usr/share/doc/python-gabbi-doc/html/_static/pygments.css
/usr/share/doc/python-gabbi-doc/html/_static/searchtools.js
/usr/share/doc/python-gabbi-doc/html/_static/sidebar.js
/usr/share/doc/python-gabbi-doc/html/_static/theme_override.css
/usr/share/doc/python-gabbi-doc/html/_static/underscore.js
/usr/share/doc/python-gabbi-doc/html/_static/up-pressed.png
/usr/share/doc/python-gabbi-doc/html/_static/up.png

Changelog

2018-03-18 - Thomas Goirand <zigo@debian.org>
python-gabbi (1.40.0-4) unstable; urgency=medium
* Fixed Python 3 shebang.
2018-03-11 - Thomas Goirand <zigo@debian.org>
python-gabbi (1.40.0-3) unstable; urgency=medium
* Python 3 has priority over Python 2.
2018-02-25 - Thomas Goirand <zigo@debian.org>
python-gabbi (1.40.0-2) unstable; urgency=medium
* Uploading to unstable.
2018-02-19 - Thomas Goirand <zigo@debian.org>
python-gabbi (1.40.0-1) experimental; urgency=medium
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
[ Thomas Goirand ]
* New upstream release.
* Standards-Version is now 4.1.3.
2017-11-01 - Thomas Goirand <zigo@debian.org>
python-gabbi (1.35.0-2) unstable; urgency=medium
* Uploading to unstable.
2017-10-08 - Thomas Goirand <zigo@debian.org>
python-gabbi (1.35.0-1) experimental; urgency=medium
[ Ondřej Nový ]
* Standards-Version is 3.9.8 now (no change)
* d/rules: Changed UPSTREAM_GIT protocol to https
* d/copyright: Changed source URL to https protocol
[ Daniel Baumann ]
* Updating vcs fields.
* Updating copyright format url.
* Updating maintainer field.
* Running wrap-and-sort -bast.
* Updating standards version to 4.0.0.
* Removing gbp.conf, not used anymore or should be specified in the
developers dotfiles.
* Correcting permissions in debian packaging files.
* Updating standards version to 4.0.1.
* Updating standards version to 4.1.0.
[ Thomas Goirand ]
* New upstream release.
* Fixed (build-)depends for this release.
2016-04-04 - Thomas Goirand <zigo@debian.org>
python-gabbi (1.12.0-2) unstable; urgency=medium
[ Ondřej Nový ]
* Fixed VCS URLs (https).
[ Thomas Goirand ]
* Uploading to unstable.
* Standards-Version: 3.9.7 (no change).
2016-01-25 - Thomas Goirand <zigo@debian.org>
python-gabbi (1.12.0-1) experimental; urgency=medium
* New upstream release.
* Fixed (build-)depends for this release.
* Added 50-no-external-site-css.patch.
* Fixed debian/copyright ordering.
* Removed Pre-Depends: dpkg (>= 1.15.6~).
* Ran wrap-and-sort -t -a.
2015-10-15 - Thomas Goirand <zigo@debian.org>
python-gabbi (1.6.1-2) unstable; urgency=medium
* Uploading to unstable.
* Fixed watch file.
2015-09-09 - Thomas Goirand <zigo@debian.org>
python-gabbi (1.6.1-1) experimental; urgency=medium
* New upstream release.
* Fixed (build-)depends for this release.
* Do not run unit tests as it's broken and requires internet.
* Using update-alternatives to provide /usr/bin/gabbi-run.

See Also

Package Description
python-gabbi_1.40.0-4_all.deb declarative HTTP testing library - Python 2.x
python-gadfly_1.0.0-16_all.deb SQL database and parser generator for Python
python-gamera-dev_3.4.3-1_all.deb framework for document analysis applications (header files)
python-gamera.toolkits.greekocr_1.0.1-11_all.deb toolkit for building OCR systems for polytonal Greek
python-gamera.toolkits.ocr_1.2.2-6_all.deb toolkit for building OCR systems
python-gamera_3.4.3-1_amd64.deb framework for building document analysis applications
python-gamin_0.1.10-5+b1_amd64.deb Python binding for the gamin client library
python-gammu_2.12-1_amd64.deb Python module to communicate with mobile phones (Python 2)
python-ganeti-rapi_2.16.0-5_all.deb cluster virtualization manager - RAPI client library
python-gasp_0.3.4-2_all.deb procedural Python graphics library for beginning programmers
python-gastables_0.3-2.2_all.deb compressible flow gas table modules for Python
python-gbulb-doc_0.6.1-0.1_all.deb PEP 3156 event loop based on GLib (common documentation)
python-gccjit-doc_0.4-8_all.deb Python bindings for libgccjit (documentation)
python-gccjit_0.4-8_amd64.deb Python bindings for libgccjit
python-gcm-client_0.1.4-1_all.deb Python client for Google Cloud Messaging (GCM)
Advertisement
Advertisement