python-cliff_2.13.0-1_all.deb


Advertisement

Description

python-cliff - command line interface formulation framework - Python 2.x

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename python-cliff_2.13.0-1_all.deb
Package name python-cliff
Package version 2.13.0
Package release 1
Package architecture all
Package type deb
Category implemented-in::python python
Homepage https://github.com/dreamhost/cliff
License -
Maintainer Debian OpenStack <team+openstack@tracker.debian.org>
Download size 40.54 KB
Installed size 271.00 KB
Cliff is a framework for building command line programs. It uses plugins to
define sub-commands, output formatters, and other extensions.
The cliff framework is meant to be used to create multi-level commands such as
Subversion and git, where the main program handles some basic argument parsing
and then invokes a sub-command to do the work.
This package provides the Python 2.x module.

Alternatives

Package Version Architecture Repository
python-cliff_2.13.0-1_all.deb 2.13.0 all Debian Main
python-cliff - - -

Requires

Name Value
python-cmd2 >= 0.8.5
python-docutils -
python-pbr >= 2.0.0
python-prettytable -
python-pyparsing -
python-six >= 1.10.0
python-stevedore >= 1.20.0
python-unicodecsv -
python-yaml -
python:any >= 2.7~
python:any << 2.8

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python-cliff_2.13.0-1_all.deb
Source Package python-cliff

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-cliff deb package:
    # sudo apt-get install python-cliff

Files

Path
/usr/lib/python2.7/dist-packages/cliff/__init__.py
/usr/lib/python2.7/dist-packages/cliff/_argparse.py
/usr/lib/python2.7/dist-packages/cliff/app.py
/usr/lib/python2.7/dist-packages/cliff/columns.py
/usr/lib/python2.7/dist-packages/cliff/command.py
/usr/lib/python2.7/dist-packages/cliff/commandmanager.py
/usr/lib/python2.7/dist-packages/cliff/complete.py
/usr/lib/python2.7/dist-packages/cliff/display.py
/usr/lib/python2.7/dist-packages/cliff/help.py
/usr/lib/python2.7/dist-packages/cliff/hooks.py
/usr/lib/python2.7/dist-packages/cliff/interactive.py
/usr/lib/python2.7/dist-packages/cliff/lister.py
/usr/lib/python2.7/dist-packages/cliff/show.py
/usr/lib/python2.7/dist-packages/cliff/sphinxext.py
/usr/lib/python2.7/dist-packages/cliff/utils.py
/usr/lib/python2.7/dist-packages/cliff-2.13.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/cliff-2.13.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/cliff-2.13.0.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/cliff-2.13.0.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/cliff-2.13.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/cliff-2.13.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/cliff/formatters/__init__.py
/usr/lib/python2.7/dist-packages/cliff/formatters/base.py
/usr/lib/python2.7/dist-packages/cliff/formatters/commaseparated.py
/usr/lib/python2.7/dist-packages/cliff/formatters/json_format.py
/usr/lib/python2.7/dist-packages/cliff/formatters/shell.py
/usr/lib/python2.7/dist-packages/cliff/formatters/table.py
/usr/lib/python2.7/dist-packages/cliff/formatters/value.py
/usr/lib/python2.7/dist-packages/cliff/formatters/yaml_format.py
/usr/lib/python2.7/dist-packages/cliff/tests/__init__.py
/usr/lib/python2.7/dist-packages/cliff/tests/base.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_app.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_columns.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_command.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_command_hooks.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_commandmanager.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_complete.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_csv.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_json.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_shell.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_table.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_value.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_formatters_yaml.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_help.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_interactive.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_lister.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_show.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_sphinxext.py
/usr/lib/python2.7/dist-packages/cliff/tests/test_utils.py
/usr/lib/python2.7/dist-packages/cliff/tests/utils.py
/usr/share/doc/python-cliff/changelog.Debian.gz
/usr/share/doc/python-cliff/copyright

Changelog

2018-09-11 - Thomas Goirand <zigo@debian.org>
python-cliff (2.13.0-1) unstable; urgency=medium
[ Ondřej Nový ]
* d/control: Use team+openstack@tracker.debian.org as maintainer
[ Thomas Goirand ]
* New upstream release.
* Fixed (build-)depends for this release.
* Apply Ubuntu patch (Closes: #898732):
- d/control, d/compat: Set debhelper>=10.
- d/control: Enable autopkgtest-pkg-python tests.
- d/control: Drop (Build-)Depends on python3-unicodecsv as its only
needed for Python 2 (LP: #1736717).
2018-03-03 - Thomas Goirand <zigo@debian.org>
python-cliff (2.11.0-1) unstable; urgency=medium
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
[ Thomas Goirand ]
* New upstream release.
* Fixed (build-)depends for this release.
* Standards-Version is now 4.1.3.
2017-11-01 - Thomas Goirand <zigo@debian.org>
python-cliff (2.8.0-3) unstable; urgency=medium
* Uploading to unstable.
* Fixed watch file.
* Standards-Version is now 4.1.1.
2017-10-01 - Thomas Goirand <zigo@debian.org>
python-cliff (2.8.0-2) experimental; urgency=medium
* Add missing (build-)dep: python{3,}-docutils (Closes: #877129).
2017-09-24 - Thomas Goirand <zigo@debian.org>
python-cliff (2.8.0-1) experimental; urgency=medium
[ Ondřej Nový ]
* d/rules: Changed UPSTREAM_GIT protocol to https
[ Daniel Baumann ]
* Updating vcs fields.
* Updating copyright format url.
* Updating maintainer field.
* Running wrap-and-sort -bast.
* Updating standards version to 4.0.0.
* Removing gbp.conf, not used anymore or should be specified in the
developers dotfiles.
* Updating standards version to 4.0.1.
* Updating standards version to 4.1.0.
[ Thomas Goirand ]
* New upstream release.
* Fixed (build-)depends for this release.
* Using pkgos-dh_auto_{test,install}.
* Removed patch: removes-argparse-from-requirements.txt.
* Removed patch: fix python 3.5 unit tests.
* Removed dh_installchangelogs overrides.
2016-04-11 - Thomas Goirand <zigo@debian.org>
python-cliff (1.15.0-4) unstable; urgency=medium
* Added missing python{3,}-setuptools build-depends (Closes: #820688).
* Standards-Version: 3.9.8 (no change).
2016-02-06 - Thomas Goirand <zigo@debian.org>
python-cliff (1.15.0-3) unstable; urgency=medium
* Removed argparse from requirements.txt (Closes: #810126).
* Added patch to fix Python 3.5 unit tests (in fact, removing some broken
tests).
* Running unit tests for all available versions of Python.
* VCS URLs using HTTPS.
2015-11-20 - Thomas Goirand <zigo@debian.org>
python-cliff (1.15.0-2) unstable; urgency=medium
* Added missing build-depends on python{3,}-yaml.
2015-10-15 - Thomas Goirand <zigo@debian.org>
python-cliff (1.15.0-1) unstable; urgency=medium
* New upstream release.
* Uploading to unstable.
* Moved the package to PKG OpenStack as I lost write access to the DPMT.
* Added build-depends openstack-pkg-tools.
* Added export OSLO_PACKAGE_VERSION.
2015-09-02 - Thomas Goirand <zigo@debian.org>
python-cliff (1.14.0-1) experimental; urgency=medium
* New upstream release.
* Fixed (build-)depends for this release.
* Removed skip-test.patch now useless.

See Also

Package Description
python-cligj_0.5.0-1_all.deb Python 2 library for processing GeoJSON commands
python-clint_0.5.1-1_all.deb Python Command-line Application Tools
python-clips_1.0.7.348+clips-4_amd64.deb Python module to interface the CLIPS expert system shell library
python-cloud-sptheme_1.9.4-1_all.deb Cloud Sphinx theme and related extensions
python-cloudfiles_1.7.11-3_all.deb Python language bindings for Cloud Files API
python-cloudkittyclient-doc_1.2.0-4_all.deb API client for Rating as a Service project - doc
python-cloudkittyclient_1.2.0-4_all.deb API client for Rating as a Service project - Python 2.7
python-cloudpickle_0.8.0-1_all.deb Extended pickling support for Python 2 objects
python-cluster_1.3.3-1.1_all.deb allows grouping a list of arbitrary objects into related groups (clusters)
python-clustershell_1.8.1-1_all.deb clustershell python2 libraries
python-cmd2_0.8.5-2_all.deb enhanced Python cmd module - Python 2.x
python-cmislib-doc_0.5.1+dfsg-2_all.deb CMIS client library for Python (documentation)
python-cmislib_0.5.1+dfsg-2_all.deb CMIS client library for Python
python-cmor_3.4.0-2_amd64.deb Python interface to CMOR
python-coards_1.0.5-3_all.deb COARDS-compliant time parser (Python 2)
Advertisement
Advertisement