puppet-module-puppetlabs-postgresql_5.4.0-1_all.deb


Advertisement

Description

puppet-module-puppetlabs-postgresql - Puppet module for PostgreSQL database

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename puppet-module-puppetlabs-postgresql_5.4.0-1_all.deb
Package name puppet-module-puppetlabs-postgresql
Package version 5.4.0
Package release 1
Package architecture all
Package type deb
Category admin
Homepage https://forge.puppet.com/puppetlabs/postgresql
License -
Maintainer Puppet Package Maintainers <pkg-puppet-devel@lists.alioth.debian.org>
Download size 60.54 KB
Installed size 225.00 KB
Puppet lets you centrally manage every important aspect of your system
using a cross-platform specification language that manages all the
separate elements normally aggregated in different files, like users,
cron jobs, and hosts, along with obviously discrete elements like
packages, services, and files.
The PostgreSQL module allows you to easily manage postgres databases
with Puppet.

Alternatives

Package Version Architecture Repository
puppet-module-puppetlabs-postgresql_5.4.0-1_all.deb 5.4.0 all Debian Main
puppet-module-puppetlabs-postgresql - - -

Requires

Name Value
puppet >= 4
puppet-common >= 3
puppet-module-puppetlabs-apt -
puppet-module-puppetlabs-concat -
puppet-module-puppetlabs-stdlib -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package puppet-module-puppetlabs-postgresql_5.4.0-1_all.deb
Source Package puppet-module-puppetlabs-postgresql

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install puppet-module-puppetlabs-postgresql deb package:
    # sudo apt-get install puppet-module-puppetlabs-postgresql

Files

Path
/usr/share/doc/puppet-module-puppetlabs-postgresql/NOTICE
/usr/share/doc/puppet-module-puppetlabs-postgresql/README.Debian
/usr/share/doc/puppet-module-puppetlabs-postgresql/README.md.gz
/usr/share/doc/puppet-module-puppetlabs-postgresql/changelog.Debian.gz
/usr/share/doc/puppet-module-puppetlabs-postgresql/changelog.gz
/usr/share/doc/puppet-module-puppetlabs-postgresql/copyright
/usr/share/lintian/overrides/puppet-module-puppetlabs-postgresql
/usr/share/puppet/modules.available/puppetlabs-postgresql/metadata.json
/usr/share/puppet/modules.available/puppetlabs-postgresql/files/RPM-GPG-KEY-PGDG
/usr/share/puppet/modules.available/puppetlabs-postgresql/files/validate_postgresql_connection.sh
/usr/share/puppet/modules.available/puppetlabs-postgresql/lib/puppet/parser/functions/postgresql_acls_to_resources_hash.rb
/usr/share/puppet/modules.available/puppetlabs-postgresql/lib/puppet/parser/functions/postgresql_escape.rb
/usr/share/puppet/modules.available/puppetlabs-postgresql/lib/puppet/parser/functions/postgresql_password.rb
/usr/share/puppet/modules.available/puppetlabs-postgresql/lib/puppet/provider/postgresql_conf/parsed.rb
/usr/share/puppet/modules.available/puppetlabs-postgresql/lib/puppet/provider/postgresql_conn_validator/ruby.rb
/usr/share/puppet/modules.available/puppetlabs-postgresql/lib/puppet/provider/postgresql_psql/ruby.rb
/usr/share/puppet/modules.available/puppetlabs-postgresql/lib/puppet/provider/postgresql_replication_slot/ruby.rb
/usr/share/puppet/modules.available/puppetlabs-postgresql/lib/puppet/type/postgresql_conf.rb
/usr/share/puppet/modules.available/puppetlabs-postgresql/lib/puppet/type/postgresql_conn_validator.rb
/usr/share/puppet/modules.available/puppetlabs-postgresql/lib/puppet/type/postgresql_psql.rb
/usr/share/puppet/modules.available/puppetlabs-postgresql/lib/puppet/type/postgresql_replication_slot.rb
/usr/share/puppet/modules.available/puppetlabs-postgresql/lib/puppet/util/postgresql_validator.rb
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/client.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/globals.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/params.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/repo.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/validate_db_connection.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/lib/devel.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/lib/docs.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/lib/java.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/lib/perl.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/lib/python.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/repo/apt_postgresql_org.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/repo/yum_postgresql_org.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/config.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/config_entry.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/contrib.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/database.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/database_grant.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/db.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/extension.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/grant.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/grant_role.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/initdb.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/install.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/passwd.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/pg_hba_rule.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/pg_ident_rule.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/plperl.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/plpython.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/postgis.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/reassign_owned_by.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/recovery.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/reload.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/role.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/schema.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/service.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/table_grant.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/manifests/server/tablespace.pp
/usr/share/puppet/modules.available/puppetlabs-postgresql/templates/pg_hba_rule.conf
/usr/share/puppet/modules.available/puppetlabs-postgresql/templates/pg_ident_rule.conf
/usr/share/puppet/modules.available/puppetlabs-postgresql/templates/recovery.conf.erb
/usr/share/puppet/modules.available/puppetlabs-postgresql/templates/systemd-override.erb

Changelog

2018-04-29 - Sebastien Badia <sbadia@debian.org>
puppet-module-puppetlabs-postgresql (5.4.0-1) unstable; urgency=medium
* New upstream version 5.4.0
* d/control:
+ Bump to Standards-Version 4.1.4 (no changes needed)
+ Relax debhelper version
2018-03-23 - Sebastien Badia <sbadia@debian.org>
puppet-module-puppetlabs-postgresql (5.3.0-1) unstable; urgency=medium
[ Thomas Bechtold ]
* Remove myself from Uploaders (Closes: #892677)
[ Sebastien Badia ]
* New upstream version 5.3.0 (Closes: #866042)
* d/upstream: Added Upstream metadata
* d/compat: Fix compat version to 11
* d/control:
+ Bump to Standards-Version 4.1.3 (no changes needed)
+ Use salsa.debian.org in Vcs-* fields
+ Added Rules-Requires-Root option
+ Added myself as Uploader
* d/copyright: Fix copyright globing
* d/docs: Add missing NOTICE file (for Apache2 license)
* d/watch: Bump to version 4 and use HTTPS for URI
2016-11-19 - Stig Sandbeck Mathisen <ssm@debian.org>
puppet-module-puppetlabs-postgresql (4.8.0-1) unstable; urgency=medium
* Imported upstream release 4.8.0
* debian/copyright: Use https URL
* Use debhelper 10
2016-05-24 - Stig Sandbeck Mathisen <ssm@debian.org>
puppet-module-puppetlabs-postgresql (4.7.1-2) unstable; urgency=medium
* Update dependencies for puppet 4
2016-05-17 - Stig Sandbeck Mathisen <ssm@debian.org>
puppet-module-puppetlabs-postgresql (4.7.1-1) unstable; urgency=medium
* Imported upstream relase 4.7.1
* Remove unnecessary version from dependency
* Declare compliance with Debian policy 3.9.8
* Update VCS-* URLs
* Add myself to Uploaders list
2015-12-21 - Stig Sandbeck Mathisen <ssm@debian.org>
puppet-module-puppetlabs-postgresql (4.6.1-1) unstable; urgency=medium
* Team upload.
* Imported upstream release 4.6.1
* [edfce6a] Add lintian override for module content
2015-10-02 - Stig Sandbeck Mathisen <ssm@debian.org>
puppet-module-puppetlabs-postgresql (4.6.0-1) unstable; urgency=medium
* Team upload.
* Imported upstream release 4.6.0-1
* [9529e9b] Drop backporeted upstream changes
* [8a79ed5] Add DEP-8 test suite
2015-02-21 - Stig Sandbeck Mathisen <ssm@debian.org>
puppet-module-puppetlabs-postgresql (4.0.0-2) unstable; urgency=medium
* [221918d] Import upstream commit 9bb1c5e to select correct postgresql
version on jessie. Thanks to Andrew Starr-Bochicchio (Closes: #777607)
2014-10-24 - Stig Sandbeck Mathisen <ssm@debian.org>
puppet-module-puppetlabs-postgresql (4.0.0-1) unstable; urgency=medium
* Imported upstream relase 4.0.0
* Declare compliance with Debian policy 3.9.6
* Update debian/control metadata with cme (Vcs-*)
* Update dependencies
* Update file lists
2014-03-07 - Thomas Bechtold <toabctl@debian.org>
puppet-module-puppetlabs-postgresql (3.3.3-1) unstable; urgency=medium
* New upstream release.

See Also

Package Description
puppet-module-puppetlabs-rabbitmq_5.3.1-5_all.deb Puppet module for rabbitmq, manage everything from vhosts to exchanges
puppet-module-puppetlabs-rsync_1.1.0-1_all.deb Puppet module for rsync clients, repositories, and servers
puppet-module-puppetlabs-stdlib_5.0.0-1_all.deb Puppet module standard library
puppet-module-puppetlabs-tftp_0.2.3-2_all.deb Puppet module for managing tftp-hpa
puppet-module-puppetlabs-translate_1.1.0-1_all.deb Puppet module for translate
puppet-module-puppetlabs-vcsrepo_1.3.2-1_all.deb use Puppet to easily deploy content from your version control system (VCS)
puppet-module-puppetlabs-xinetd_3.0.0-1_all.deb Puppet module for xinetd
puppet-module-richardc-datacat_0.6.2-1_all.deb Puppet module for data structure rendered using a template
puppet-module-rodjek-logrotate_1.1.1+ds1-1_all.deb Logrotate module for Puppet
puppet-module-sahara_13.1.0-1_all.deb Puppet module for OpenStack Sahara
puppet-module-saz-memcached_3.1.0-1_all.deb Puppet module for memcached
puppet-module-saz-rsyslog_2.2.1-1_all.deb Puppet module for rsyslog
puppet-module-saz-ssh_2.8.1-2_all.deb Puppet module for Ssh configuration (client and server)
puppet-module-sbitio-monit_1.0.0-2_all.deb Puppet module for Monit
puppet-module-swift_13.1.0-4_all.deb Puppet module for OpenStack Swift
Advertisement
Advertisement