preludedb-utils_4.1.0-2+b2_amd64.deb


Advertisement

Description

preludedb-utils - Security Information and Events Management System [ Library utils ]

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename preludedb-utils_4.1.0-2+b2_amd64.deb
Package name preludedb-utils
Package version 4.1.0
Package release 2+b2
Package architecture amd64
Package type deb
Category utils
Homepage https://www.prelude-siem.org/
License -
Maintainer Pierre Chifflier <pollux@debian.org>
Download size 129.50 KB
Installed size 173.00 KB
The PreludeDB Library provides an abstraction layer upon the type and the
format of the database used to store IDMEF alerts. It allows developers to use
the Prelude IDMEF database easily and efficiently without worrying about SQL,
and to access the database independently of the type/format of the database.
This package contains the Prelude shared library tools.

Alternatives

Package Version Architecture Repository
preludedb-utils_4.1.0-2+b2_i386.deb 4.1.0 i386 Debian Main
preludedb-utils - - -

Requires

Name Value
libc6 >= 2.4
libgnutls30 >= 3.6.5
libltdl7 >= 2.4.6
libprelude23 >= 4.1
libpreludedb7 >= 4.1

Replaces

Name Value
libpreludedb0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package preludedb-utils_4.1.0-2+b2_amd64.deb
Source Package libpreludedb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install preludedb-utils deb package:
    # sudo apt-get install preludedb-utils

Files

Path
/usr/bin/preludedb-admin
/usr/share/doc/preludedb-utils/changelog.Debian.amd64.gz
/usr/share/doc/preludedb-utils/changelog.Debian.gz
/usr/share/doc/preludedb-utils/changelog.gz
/usr/share/doc/preludedb-utils/copyright
/usr/share/man/man1/preludedb-admin.1.gz

Changelog

2018-04-30 - Thomas Andrejak <thomas.andrejak@gmail.com>
libpreludedb (4.1.0-2) unstable; urgency=medium
* Update dependencies (Closes: #896240, #896266)
* Bump Standard-Version to 4.1.4, no changes needed
2018-03-11 - Thomas Andrejak <thomas.andrejak@gmail.com>
libpreludedb (4.1.0-1) unstable; urgency=medium
* Bump version 4.1.0 (Closes: #892553)
- remove unnecessary patch: 006-update-gtkdoc-files.patch
- Update dependencies: libprelude 4.1 is required
* d/control:
- Update descriptions
- Add multiarch fields
* d/rules: add missing include architecture.mk
* Update copyrights dates
* Add symbols for libpreludedb7 and libpreludedbcpp2
2018-02-10 - Thomas Andrejak <thomas.andrejak@gmail.com>
libpreludedb (3.1.0-2) unstable; urgency=medium
* Bump Standard-Version to 4.1.3, no changes needed
* Bump debhelper version to 11
* Update compat file from 10 to 11
* New patches:
- 007-update_m4_postgresql.patc
Fix compatibility with new libpq (Closes: #887940)
- 008-Fix_libdir_definition.patch
Fix libdir definition (Closes: #722799)
* Update d/control Vcs-* entries to migrate to Salsa
2017-11-20 - Thomas Andrejak <thomas.andrejak@gmail.com>
libpreludedb (3.1.0-1) unstable; urgency=medium
* Push to unstable
* Add Thomas Andrejak as uploader in d/control
* Bump Standard-Version to 4.1.1, no changes needed
* Remove trailing whitespace in d/changelog
2017-09-24 - Thomas Andrejak <thomas.andrejak@gmail.com>
libpreludedb (3.1.0-0.2) experimental; urgency=medium
* Non-maintainer upload.
* Update gtkdoc files to be compatible with gtkdoc-1.26 (Closes: #876709)
- Update gtk-doc.make and m4/gtk-doc.m4
- Using https://github.com/GNOME/gtk-doc
* Add libglib2.0-dev to build-dep-indep because it is required for gtk-doc
2017-08-15 - Thomas Andrejak <thomas.andrejak@gmail.com>
libpreludedb (3.1.0-0.1) experimental; urgency=medium
* Non-maintainer upload.
* Add support and dependencies for Python3 bindings
* Add PreludeDB documentation with gtk-doc
* Cleanup rules file
- Clean all directives
- Support Build profiles nopython
- Build the documentation only when building the indep packages
* Addition of the upstream signing key
* Update of watch file
* Bump version 3.1.0 (Closes: #872260)
- Bump soname version: C to 7, C++ to 2
- Patches :
- Remove unnecessary patches now upstream included them
- 001-manpages.patch: Fix manpage syntax
- 002-undefined_non_weak_symbol.patch: Fix undefined non weak symbol
- 003-Add-pkg-config-file.patch: Deprecate libpreludedb-config
for pkg-config
- 004-Add_support_for_python_3.5_and_3.6.patch: Add simultaneous
support for python 3.5 and 3.6
- 005-Clarify_License.patch: Clarify README.LICENSE
* Control :
- Remove unnecessary PreDepends
- Change Priority from extra to optional
- Add Vcs fields
- Bump Standards-Version to 4.0.1
- Bump debhelper compat level to 10, drop explicit autoreconf, now part
of debhelper standard sequence.
- Set Homepage field
- Remove of uneccesary/duplicated Section fields
* Rewriting of copyright file to fit the machine-readable format
* Add missing copyright information
* Add new package: preludedb-utils
- Handle preludedb-admin and it's manpage
2017-01-12 - Andreas Beckmann <anbe@debian.org>
libpreludedb (1.0.0-2.4) unstable; urgency=medium
* Non-maintainer upload.
* Mickael Profeta has retired, promote Pierre Chifflier from Uploaders to
Maintainer.  (Closes: #838923)
* Switch Build-Depends to default-libmysqlclient-dev.
(Closes: #845867, #790467)
* Use dh_autoreconf.  (Closes: #744617, #558580)
* Add missing Build-Depends: dh-python.
* Add missing build-arch/build-indep targets.
* Switch to source format 3.0 (quilt).

See Also

Package Description
premake4_4.3+repack1-2+b1_amd64.deb cross-platform build script generator
prepair-data_0.7.1-3_all.deb polygon repair tool -- example data
prepair_0.7.1-3+b2_amd64.deb polygon repair tool
preprocess_1.1.0+ds-1_all.deb portable multi-language file preprocessor
prerex_6.5.4-1_amd64.deb course prerequisite chart editor for LaTeX/TikZ
presage-dbus_0.9.1-2.1_all.deb intelligent predictive text entry platform (D-Bus service)
presage_0.9.1-2.1+b2_amd64.deb intelligent predictive text entry platform (tools and demos)
presentty_0.2.0-1_amd64.deb Console-based presentation software
preview-latex-style_11.91-2_all.deb extraction of elements from LaTeX documents as graphics
preview.app_0.8.5-11+b1_amd64.deb General purpose image viewer for GNUstep
previsat_3.5.1.7+dfsg1-3_amd64.deb satellite tracking software for observing purposes
prewikka_4.1.5-3_all.deb Security Information and Events Management System [ Web Interface ]
price.app_1.3.0-3+b1_amd64.deb Image filtering and manipulation using GNUstep
prime-phylo_1.0.11-7+b1_amd64.deb bayesian estimation of gene trees taking the species tree into account
primer3-examples_2.4.0-2_all.deb tool to design flanking oligo nucleotides for DNA amplification (examples)
Advertisement
Advertisement