opam_2.0.3-1_amd64.deb


Advertisement

Description

opam - package manager for OCaml

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename opam_2.0.3-1_amd64.deb
Package name opam
Package version 2.0.3
Package release 1
Package architecture amd64
Package type deb
Category ocaml uitoolkit::ncurses
Homepage https://opam.ocaml.org
License -
Maintainer Debian OCaml Maintainers <debian-ocaml-maint@lists.debian.org>
Download size 1.57 MB
Installed size 7.53 MB
OPAM stands for OCaml PAckage Manager. It aims to suit to a vast number
of users and use cases, and has unique features:
* Powerful handling of dependencies: versions constraints, optional
dependencies, conflicts, etc.
* Multiple repositories backends: HTTP, rsync, git
* Ease to create packages and repositories
* Ability to switch between different compiler versions
Typically, OPAM will probably make your life easier if you recognize
yourself in at least one of these profiles:
* You use multiple versions of the OCaml compiler, or you hack the compiler
yourself and needs to frequently switch between compiler versions.
* You use or develop software that needs a specific and/or modified version
of the OCaml compiler to be installed.
* You use or develop software that depends on a specific version of an OCaml
library, or you just want to install a specific version of a package, not
just the latest one.
* You want to create your own packages yourself, put them on your own
repository, with minimal effort.

Alternatives

Package Version Architecture Repository
opam_2.0.3-1_i386.deb 2.0.3 i386 Debian Main
opam - - -

Requires

Name Value
aspcud -
bubblewrap -
build-essential -
curl -
libbz2-1.0 -
libc6 >= 2.28
mccs -
opam-doc = 2.0.3-1
opam-installer = 2.0.3-1
packup -
unzip -
wget -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package opam_2.0.3-1_amd64.deb
Source Package opam

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install opam deb package:
    # sudo apt-get install opam

Files

Path
/usr/bin/opam
/usr/share/doc/opam

Changelog

2019-02-01 - Mehdi Dogguy <mehdi@debian.org>
opam (2.0.3-1) unstable; urgency=medium
* New (bugfix) upstream release
* Restrict dependency on bubblewrap on [linux-any] (Closes: #918345)
* Update patches
2018-12-02 - Mehdi Dogguy <mehdi@debian.org>
opam (2.0.1-1) unstable; urgency=medium
* New upstream release
* Remove patch integrated by upstream:
- 0001-Configure-user-identity-in-the-test-Git-repository.patch
* Do not try to build (and ship) dev-manual.pdf as it is not
provided in upstream's tarball anymore
* Add patch to fix spelling errors in manpages and binaries
- 0002-Fix-spelling-error-in-manpage.patch
* Update copyright file
* Rename opam-docs package into opam-doc
* Ship README.md and CHANGES files in opam-installer
2018-10-20 - Ralf Treinen <treinen@debian.org>
opam (2.0.0-5) unstable; urgency=medium
* Team upload.
* debian/rules: create separate targets build-indep and build-arch
(Closes: #909542).
* invoke in opam/{preinst,postint,postrm} dpkg-maintscript-helper
to handle the transition of /usr/share/doc/opam from a directory
to a symlink (Closes: #910222).
* install README.md and CHANGES into package opam-docs. Do not install
extra LICENSE file, add it to debian/not-installed.
* drop invocation of dh-exec in opam-installer.install, drop
build-dependency dh-exec.
* list extra files to remove by dh_clean in debian/clean.
* drop duplicated build-dependency cppo.
* change build-dependency on jbuilder to dune.
2018-09-22 - Mehdi Dogguy <mehdi@debian.org>
opam (2.0.0-4) unstable; urgency=medium
* Add a strict dependency on bubblewrap (Closes: #909086)
2018-09-08 - Nicolas Braud-Santoni <nicolas@braud-santoni.eu>
opam (2.0.0-3) unstable; urgency=high
* debian/control
+ Fix typo in Breaks+Replaces for opam-installer (Closes: #907403)
+ Fix typo in the Description of opam-installer
2018-09-04 - Nicolas Braud-Santoni <nicolas@braud-santoni.eu>
opam (2.0.0-2) unstable; urgency=high
* opam-installer Replaces opam-docs (<< 2.0.0-1)
Closes: #907403
* Declare compliance with policy v4.2.1.
No change required.
2018-08-03 - Nicolas Braud-Santoni <nicolas@braud-santoni.eu>
opam (2.0.0-1) unstable; urgency=medium
[Nicolas Braud-Santoni]
* Team upload.
* Add myself to uploaders.
* Split opam-installer in its own package
Symlink usr/share/doc/opam to opam-installer
* New upstream version 2.0.0 (2018-07-24)
- Add jbuilder, cppo and libopam-file-format-ocaml-dev to Build-Depends
- Remove obsolete patches
- Fix the upstream testsuite
* Update debian/copyright
* Update debian/watch
- Switch to uscan 4
- Use github.com/ocaml/opam
- Correctly handle pre-releases (alpha, beta, rc)
- Correctly name the downloaded tarball
* Bump Standards-Version to 4.1.5
- debian/copyright: Use HTTPS for the format URI
- Set Rules-Requires-Root to no
* Update homepage to https://opam.ocaml.org
* debian/copyright: Fix license information.
- LICENSE states LGPL, with a linking exception, not GPL.
- Use FSFUL label for corresponding license
* Switch to debhelper 11
* debian/rules
- Rely dh_auto_test to correctly skip tests when needed
- Fail on missing installable files
[ Mehdi Dogguy ]
* Add aspcud to Build-Depends as it is needed to run the testsuite
* Move the packaging repository to salsa.debian.org
* Add 'm4' in Recommends (LP: #1289944)
* Promote solvers aspcud, mccs and packup as dependencies
* Specify libdir when running configure script
* Remove obsolete override_dh_{auto_,}install targets
* It is not necessary to depend on 'tar' (Closes: #900118)
* Constraint minimal required versions for:
- ocaml >= 4.3.0
- ocaml-re >= 1.7.2
- cmdliner >= 1.0.2
* Add git and openssl to build-depends (needed for the test-suite)
* Add a 'test' target in upstream's Makefile so that dh_auto_test runs the
test-suite.
- Add patch 0002-Add-a-test-target.patch

See Also

Package Description
opari2_2.0.4-1_amd64.deb OpenMP Pragma And Region Instrumentor - translation tool
opari_1.1+dfsg-7_amd64.deb OpenMP Pragma And Region Instrumentor - translation tool
open-adventure_1.4+git20170917.0.d512384-2_amd64.deb colossal cave adventure, the 1995 430-point version
open-cobol_2.2-5_all.deb transitional dummy package for gnucobol
open-infrastructure-apache-icons_20170701-3_all.deb Additional utilities for Apache (transitional package)
open-infrastructure-apache-tools_20170701-3_all.deb Additional utilities for Apache
open-infrastructure-ceph-tools_20180915-3_all.deb Additional utilities to manage Ceph
open-infrastructure-container-tools_20190301-lts2-1~deb10u1_all.deb manage systemd-nspawn containers
open-infrastructure-storage-tools_20180915-3_all.deb Additional utilities to manage Ceph (transitional package)
open-infrastructure-system-boot_20190202-1_all.deb Boot Debian-based system images
open-infrastructure-system-build_20190202-1_all.deb Build Debian-based system images
open-infrastructure-system-config_20190202-1_all.deb Configure Debian-based system images
open-infrastructure-system-images_20190202-1_all.deb Debian-based system images
open-invaders-data_0.3-4.3_all.deb Space Invaders clone (data package)
open-invaders_0.3-4.3+b1_amd64.deb Space Invaders clone
Advertisement
Advertisement