ocl-icd-opencl-dev_2.2.12-2_amd64.deb


Advertisement

Description

ocl-icd-opencl-dev - OpenCL development files

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename ocl-icd-opencl-dev_2.2.12-2_amd64.deb
Package name ocl-icd-opencl-dev
Package version 2.2.12
Package release 2
Package architecture amd64
Package type deb
Category devel::library libdevel role::devel-lib
Homepage https://forge.imag.fr/projects/ocl-icd/
License -
Maintainer Debian OpenCL Maintainers <pkg-opencl-devel@lists.alioth.debian.org>
Download size 10.45 KB
Installed size 22.00 KB
OpenCL (Open Computing Language) is a multivendor open standard for
general-purpose parallel programming of heterogeneous systems that include
CPUs, GPUs and other processors.
This package provides the development files: headers and libraries.
It also ensures that the ocl-icd ICD loader is installed so its additional
features (compared to the OpenCL norm) can be used: .pc file, avaibility to
select an ICD without root privilege, etc.

Alternatives

Package Version Architecture Repository
ocl-icd-opencl-dev_2.2.12-2_i386.deb 2.2.12 i386 Debian Main
ocl-icd-opencl-dev - - -

Requires

Name Value
ocl-icd-libopencl1 = 2.2.12-2
opencl-c-headers -
opencl-headers -

Provides

Name Value
opencl-dev -

Conflicts

Name Value
opencl-dev -

Replaces

Name Value
amd-libopencl1 << 1:13.4-4~
nvidia-libopencl1 << 305~
ocl-icd-libopencl1 << 2.1.3-5~
opencl-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ocl-icd-opencl-dev_2.2.12-2_amd64.deb
Source Package ocl-icd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ocl-icd-opencl-dev deb package:
    # sudo apt-get install ocl-icd-opencl-dev

Files

Path
/usr/lib/x86_64-linux-gnu/libOpenCL.so
/usr/lib/x86_64-linux-gnu/pkgconfig/OpenCL.pc
/usr/share/doc/ocl-icd-opencl-dev/changelog.Debian.gz
/usr/share/doc/ocl-icd-opencl-dev/changelog.gz
/usr/share/doc/ocl-icd-opencl-dev/copyright

Changelog

2018-12-17 - Andreas Beckmann <anbe@debian.org>
ocl-icd (2.2.12-2) unstable; urgency=medium
* Team upload.
[ Vincent Danjean ]
* Remove useless dependency in DH compat 10
[ Andreas Beckmann ]
* Move package under team maintenance. Set Maintainer to Debian OpenCL
Maintainers and move Vincent to Uploaders.
* Switch Vcs-* URLs to salsa.debian.org.
* Provide libopencl-2.2-1.
* Relax the dependencies for OpenCL 1.0/1.1 symbols. All known
libOpenCL.so.1 implementations support these.  (LP: #1581582)
* Fix some Lintian issues and cleanup cruft.
* Stop recommending no longer existing libpoclu-dev.
* ocl-icd-libopencl1.symbols: Add Build-Depends-Package field.
* Switch to debhelper-compat (= 11).
* Bump Standards-Version to 4.2.1 (no changes needed).
2017-11-29 - Vincent Danjean <vdanjean@debian.org>
ocl-icd (2.2.12-1) unstable; urgency=medium
* New upstream release
+ add support for OpenCL 2.2
2017-01-20 - Vincent Danjean <vdanjean@debian.org>
ocl-icd (2.2.11-1) unstable; urgency=medium
* New upstream release
+ OCL_ICD_ASSUME_ICD_EXTENSION must be set if the ICD is non compliant
(for example, if it does not export clGetPlatformInfo)
2016-12-03 - Vincent Danjean <vdanjean@debian.org>
ocl-icd (2.2.10-2) unstable; urgency=medium
* migrate to automatic dbgsym packages
2016-12-03 - Vincent Danjean <vdanjean@debian.org>
ocl-icd (2.2.10-1) unstable; urgency=medium
* New upstream release
+ clGetPlatformInfo is now taken is priority from the dispatch table
(Closes: #845682)
* ocl-icd-dev is now marked Multi-Arch: same
2016-09-09 - Vincent Danjean <vdanjean@debian.org>
ocl-icd (2.2.9-2) unstable; urgency=medium
* Now that C++ OpenCL headers are split, do not force their installation.
ocl-icd-opencl-dev depends on "opencl-c-headers | opencl-headers" instead
of only the later.
* enable bindnow linker flags as suggested by lintian
2016-03-03 - Vincent Danjean <vdanjean@debian.org>
ocl-icd (2.2.9-1) unstable; urgency=medium
* New upstream release
+ Report the correct supported OpenCL version when asked
+ Add support for OPENCL_VENDOR_PATH envvar
* Apply 'cme fix dpkg', ie update Standard-Versions and Vcs-Git.
2015-12-17 - Vincent Danjean <vdanjean@debian.org>
ocl-icd (2.2.8-1) unstable; urgency=medium
* New upstream release
OpenCL 2.1 supported
* remove upstream applied patch
* add libopencl-2.1-1 virtual package and fix symbol file
2015-06-09 - Vincent Danjean <vdanjean@debian.org>
ocl-icd (2.2.7-2) unstable; urgency=medium
* cleanup packaging
+ avoid running autoreconf both times
+ avoid hack to set (reproductible) date in documentation (Closes: #747720)
hurd-i386 should work now
+ run all tests on mips64
2015-06-09 - Vincent Danjean <vdanjean@debian.org>
ocl-icd (2.2.7-1) unstable; urgency=medium
* New upstream release
+ really use real prototypes in tests
Fix "FTBFS on mips64el - testsuite errors" (Closes: #774876)
Fix "use simpler prototypes in automatic tests" (Closes: #749682)

See Also

Package Description
oclgrind_18.3-2_amd64.deb OpenCL device simulator
ocp-indent_1.7.0-1_amd64.deb OCaml indentation tool for emacs and vim - runtime
ocplib-simplex-ocaml-dev_0.4-1_amd64.deb simplex library for solving linear inequalities
ocproxy_1.60-1+b1_amd64.deb SOCKS proxy for openconnect
ocrad_0.27-2_amd64.deb optical character recognition program
ocrfeeder_0.8.1-4_all.deb Document layout analysis and optical character recognition system
ocrmypdf-doc_8.0.1+dfsg-1_all.deb add an OCR text layer to PDF files - documentation
ocrmypdf_8.0.1+dfsg-1_all.deb add an OCR text layer to PDF files
ocrodjvu_0.10.4-1_all.deb tool to perform OCR on DjVu documents
ocserv_0.12.2-3_amd64.deb OpenConnect VPN server compatible with Cisco AnyConnect VPN
ocsinventory-agent_2.4.2-3_amd64.deb Hardware and software inventory tool (client)
ocsinventory-reports_2.5+dfsg1-1_all.deb Hardware and software inventory tool (Administration Console)
ocsinventory-server_2.5+dfsg1-1_all.deb Hardware and software inventory tool (Communication Server)
octave-arduino_0.3.0-2_all.deb Octave Arduino Toolkit
octave-bart_0.4.04-2_all.deb Octave bindings for BART
Advertisement
Advertisement