obfsproxy_0.2.13-3_all.deb


Advertisement

Description

obfsproxy - pluggable transport proxy for Tor

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename obfsproxy_0.2.13-3_all.deb
Package name obfsproxy
Package version 0.2.13
Package release 3
Package architecture all
Package type deb
Category net
Homepage https://www.torproject.org/projects/obfsproxy.html
License -
Maintainer Debian Privacy Tools Maintainers <pkg-privacy-maintainers@lists.alioth.debian.org>
Download size 72.44 KB
Installed size 347.00 KB
obfsproxy is a tool that attempts to circumvent censorship by
transforming the Tor traffic between the client and the bridge. This way
censors, who usually monitor traffic between the client and the bridge, will
see innocent-looking transformed traffic instead of the actual Tor traffic.
It is written in Python and is compliant with the Tor pluggable transports
specification, and its modular architecture allows it to support multiple
pluggable transports.

Alternatives

Package Version Architecture Repository
obfsproxy_0.2.13-3_all.deb 0.2.13 all Debian Main
obfsproxy - - -

Requires

Name Value
python >= 2.7
python-argparse -
python-crypto -
python-pkg-resources -
python-pyptlib >= 0.0.6
python-twisted-core -
python-yaml -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Mirror ftp.br.debian.org
Binary Package obfsproxy_0.2.13-3_all.deb
Source Package obfsproxy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install obfsproxy deb package:
    # sudo apt-get install obfsproxy

Files

Path
/usr/bin/obfsproxy
/usr/lib/python2.7/dist-packages/obfsproxy/__init__.py
/usr/lib/python2.7/dist-packages/obfsproxy/_version.py
/usr/lib/python2.7/dist-packages/obfsproxy/pyobfsproxy.py
/usr/lib/python2.7/dist-packages/obfsproxy-0.2.13.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/obfsproxy-0.2.13.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/obfsproxy-0.2.13.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/obfsproxy-0.2.13.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/obfsproxy-0.2.13.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/obfsproxy/common/__init__.py
/usr/lib/python2.7/dist-packages/obfsproxy/common/aes.py
/usr/lib/python2.7/dist-packages/obfsproxy/common/argparser.py
/usr/lib/python2.7/dist-packages/obfsproxy/common/heartbeat.py
/usr/lib/python2.7/dist-packages/obfsproxy/common/hmac_sha256.py
/usr/lib/python2.7/dist-packages/obfsproxy/common/log.py
/usr/lib/python2.7/dist-packages/obfsproxy/common/modexp.py
/usr/lib/python2.7/dist-packages/obfsproxy/common/rand.py
/usr/lib/python2.7/dist-packages/obfsproxy/common/serialize.py
/usr/lib/python2.7/dist-packages/obfsproxy/common/transport_config.py
/usr/lib/python2.7/dist-packages/obfsproxy/managed/__init__.py
/usr/lib/python2.7/dist-packages/obfsproxy/managed/client.py
/usr/lib/python2.7/dist-packages/obfsproxy/managed/server.py
/usr/lib/python2.7/dist-packages/obfsproxy/network/__init__.py
/usr/lib/python2.7/dist-packages/obfsproxy/network/buffer.py
/usr/lib/python2.7/dist-packages/obfsproxy/network/extended_orport.py
/usr/lib/python2.7/dist-packages/obfsproxy/network/http.py
/usr/lib/python2.7/dist-packages/obfsproxy/network/launch_transport.py
/usr/lib/python2.7/dist-packages/obfsproxy/network/network.py
/usr/lib/python2.7/dist-packages/obfsproxy/network/socks.py
/usr/lib/python2.7/dist-packages/obfsproxy/network/socks5.py
/usr/lib/python2.7/dist-packages/obfsproxy/test/__init__.py
/usr/lib/python2.7/dist-packages/obfsproxy/test/test_aes.py
/usr/lib/python2.7/dist-packages/obfsproxy/test/test_buffer.py
/usr/lib/python2.7/dist-packages/obfsproxy/test/test_obfs3_dh.py
/usr/lib/python2.7/dist-packages/obfsproxy/test/test_socks.py
/usr/lib/python2.7/dist-packages/obfsproxy/test/test_socks5.py
/usr/lib/python2.7/dist-packages/obfsproxy/test/tester.py
/usr/lib/python2.7/dist-packages/obfsproxy/test/transports/__init__.py
/usr/lib/python2.7/dist-packages/obfsproxy/test/transports/test_b64.py
/usr/lib/python2.7/dist-packages/obfsproxy/test/transports/test_obfs3_dh.py
/usr/lib/python2.7/dist-packages/obfsproxy/test/transports/test_scramblesuit.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/__init__.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/b64.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/base.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/dummy.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/obfs2.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/obfs3.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/obfs3_dh.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/transports.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/scramblesuit/__init__.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/scramblesuit/const.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/scramblesuit/fifobuf.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/scramblesuit/message.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/scramblesuit/mycrypto.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/scramblesuit/packetmorpher.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/scramblesuit/probdist.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/scramblesuit/replay.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/scramblesuit/scramblesuit.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/scramblesuit/state.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/scramblesuit/ticket.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/scramblesuit/uniformdh.py
/usr/lib/python2.7/dist-packages/obfsproxy/transports/scramblesuit/util.py
/usr/share/doc/obfsproxy/NEWS.Debian.gz
/usr/share/doc/obfsproxy/README
/usr/share/doc/obfsproxy/README.Debian
/usr/share/doc/obfsproxy/changelog.Debian.gz
/usr/share/doc/obfsproxy/changelog.gz
/usr/share/doc/obfsproxy/copyright
/usr/share/doc/obfsproxy/obfs3-protocol-spec.txt.gz
/usr/share/doc/obfsproxy/obfs3-threat-model.txt
/usr/share/man/man1/obfsproxy.1.gz

Changelog

2017-11-23 - intrigeri <intrigeri@debian.org>
obfsproxy (0.2.13-3) unstable; urgency=medium
* Team upload.
* Don't install the AppArmor profile and remove it from disk
unless the user has modified it (Closes: #882103)
* Set "Priority: optional": since Debian Policy version 4.0.1,
the priority extra has been deprecated.
2016-09-22 - Ximin Luo <infinity0@debian.org>
obfsproxy (0.2.13-2) unstable; urgency=medium
* Team upload.
* Add PYTHONPATH=. when running the tests. (Closes: #837247)
* Update to latest Standards-Version; no changes required.
2015-08-28 - Jérémy Bobbio <lunar@debian.org>
obfsproxy (0.2.13-1) unstable; urgency=medium
* Package is now maintained as part of the pkg-privacy team.
* Use debhelper compat level 9.
* Use pybuild as the buildsystem.
* Migrate watch file to PyPI simple API.
* Bump Standards-Version to 3.9.6.
2014-09-03 - Jérémy Bobbio <lunar@debian.org>
obfsproxy (0.2.12-1) unstable; urgency=low
[ Jérémy Bobbio ]
* New upstream release.
* Put under the umbrella of the Anonymity Tools Debian Maintainers team
[ intrigeri ]
* Import AppArmor profile. (Closes: #739284)
* Install the AppArmor profile into the package, have dh_apparmor do its
magics.
* Add Suggests: apparmor.
* Bump copyright years on debian/* for Lunar, at his request.
* Use canonical URLs for the Vcs-* control fields.
2014-07-18 - Jérémy Bobbio <lunar@debian.org>
obfsproxy (0.2.11-1) unstable; urgency=medium
* New upstream release.
* Update Build-Depends and Depends.
* Document how to use a ScrambleSuit bridge in README.Debian.
2014-04-11 - Jérémy Bobbio <lunar@debian.org>
obfsproxy (0.2.8-1) unstable; urgency=low
* New upstream release.
2014-03-15 - Jérémy Bobbio <lunar@debian.org>
obfsproxy (0.2.7-1) unstable; urgency=low
* New upstream release.
* Update Build-Depends.
2014-02-24 - Jérémy Bobbio <lunar@debian.org>
obfsproxy (0.2.6-3) unstable; urgency=low
* Add python-gmpy to Recommends in order to save CPU when available.
2014-02-11 - Jérémy Bobbio <lunar@debian.org>
obfsproxy (0.2.6-2) unstable; urgency=low
* Use proper version number in debian/NEWS.
* Fix capitalization of ScrambleSuit.
2014-02-10 - Jérémy Bobbio <lunar@debian.org>
obfsproxy (0.2.6-1) unstable; urgency=low
* New upstream release.
* Configure watch file to verify upstream tarball signature.
* Update documentation to add Scramblesuit.
* Update Standards-Version, no changes required.

See Also

Package Description
obitools_1.2.12+dfsg-2_amd64.deb programs to analyze NGS data in a DNA metabarcoding context
obmenu_1.0-4_amd64.deb Graphical menu editor for openbox
obs-build_20180831-2_all.deb scripts for building RPM/debian packages for multiple distributions
obs-plugins_22.0.3+dfsg1-1_amd64.deb recorder and streamer for live video content (plugins)
obs-studio_22.0.3+dfsg1-1_amd64.deb recorder and streamer for live video content
obsession_20140608-2+b1_amd64.deb Session management helpers for lightweight desktop environments
obsidian-icon-theme_3.5-1_all.deb Intuitive Faenza-like icon theme
oca-core_11.0.20180730-1_all.deb Odoo Community business app
ocaml-base-nox_4.05.0-11_amd64.deb Runtime system for OCaml bytecode executables (no X)
ocaml-base_4.05.0-11_amd64.deb Runtime system for OCaml bytecode executables
ocaml-batteries-included_2.6.0-1_all.deb Batteries included: OCaml development platform - metapackage
ocaml-compiler-libs_4.05.0-11_amd64.deb OCaml interpreter and standard libraries
ocaml-core_3.12.0.1_all.deb OCaml core tools (metapackage)
ocaml-findlib_1.7.3-2+b1_amd64.deb management tool for OCaml libraries
ocaml-interp_4.05.0-11_amd64.deb OCaml interactive interpreter and standard libraries
Advertisement
Advertisement