node-which_1.3.0-2_all.deb


Advertisement

Description

node-which - Cross-platform 'which' module for Node.js

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename node-which_1.3.0-2_all.deb
Package name node-which
Package version 1.3.0
Package release 2
Package architecture all
Package type deb
Category javascript
Homepage https://github.com/isaacs/node-which
License -
Maintainer Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Download size 5.67 KB
Installed size 20.00 KB
node-which finds the first instance of a specified executable
in the PATH environment variable, simulating the behaviour of
the standard "which" program.
node-which supports all platforms supported by Node.js.
This is the module only, the binary being totally useless.
Node.js is an event-based server-side javascript engine.

Alternatives

Package Version Architecture Repository
node-which_1.3.0-2_all.deb 1.3.0 all Debian Main
node-which - - -

Requires

Name Value
node-isexe -
nodejs -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package node-which_1.3.0-2_all.deb
Source Package node-which

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-which deb package:
    # sudo apt-get install node-which

Files

Path
/usr/lib/nodejs/which/package.json
/usr/lib/nodejs/which/which.js
/usr/share/doc/node-which/README.md
/usr/share/doc/node-which/changelog.Debian.gz
/usr/share/doc/node-which/changelog.gz
/usr/share/doc/node-which/copyright

Changelog

2018-09-13 - Pirate Praveen <praveen@debian.org>
node-which (1.3.0-2) unstable; urgency=medium
* Team upload
* Drop node->nodejs rename patch
* Use salsa.debian.org in Vcs-* fields (Move from collab-maint to js-team)
* Bump Standards-Version to 4.2.1 (no changes needed)
* Bump debhelper compatibility level to 11
2017-12-04 - Pirate Praveen <praveen@debian.org>
node-which (1.3.0-1) unstable; urgency=medium
* Team upload
* New upstream release
2016-11-11 - Jérémy Lal <kapouer@melix.org>
node-which (1.2.11-1) unstable; urgency=medium
* New upstream version 1.2.11 (Closes: #843954)
* Depends node-isexe
* Copyright: Expat to ISC
* Autopkgtest
* Patch tests to support nodejs binary rename
2013-03-22 - Jérémy Lal <kapouer@melix.org>
node-which (1.0.5-2) unstable; urgency=low
* Use github url in watch file. 
2012-03-17 - Jérémy Lal <kapouer@melix.org>
node-which (1.0.5-1) unstable; urgency=low
* Initial release (Closes: #642416)

See Also

Package Description
node-wide-align_1.1.0-1_all.deb Wide-character aware text alignment function
node-widest-line_1.2.2-1_all.deb Get the visual width of the widest line in a string -
node-wildemitter_1.2.0-1_all.deb lightweight event emitter that supports wildcard handlers
node-with_3.0.0-2_all.deb compile-time `with` statement - Node.js module
node-wordwrap_1.0.0-1_all.deb word wrapping library for NodeJS
node-wrap-ansi_4.0.0-1_all.deb Wordwrap a string with ANSI escape codes
node-wrappy_1.0.2-1_all.deb Callback wrapping utility
node-write-file-atomic_2.3.0-1_all.deb Write files in an atomic fashion w/configurable ownership
node-write-file-promise_1.0.0-1_all.deb Write a file creating intermediate directories
node-ws_1.1.0+ds1.e6ddaae4-5_amd64.deb RFC-6455 WebSocket implementation module for Node.js
node-xdg-basedir_3.0.0-1_all.deb Get XDG Base Directory paths
node-xml2js_0.2.8-1_all.deb simple XML to JavaScript object converter - Node.js module
node-xmldom_0.1.27+ds-1_all.deb Standard XML DOM (Level2 CORE) implementation in pure javascript
node-xmlhttprequest-ssl_1.6.0-1_all.deb XMLHttpRequest for Node
node-xmlhttprequest_1.8.0-1_amd64.deb XMLHttpRequest for Node
Advertisement
Advertisement