node-accepts_1.3.5-1_all.deb


Advertisement

Description

node-accepts - higher-level content negotiation for Node.js

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename node-accepts_1.3.5-1_all.deb
Package name node-accepts
Package version 1.3.5
Package release 1
Package architecture all
Package type deb
Category javascript
Homepage https://github.com/jshttp/accepts
License -
Maintainer Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Download size 7.61 KB
Installed size 25.00 KB
Higher level content negotiation based on negotiator.
In addition to negotatior, it allows:
- Allows types as an array or arguments list, ie
`(['text/html', 'application/json'])`
as well as `('text/html', 'application/json')`.
- Allows type shorthands such as `json`.
- Returns `false` when no types match
- Treats non-existent headers as `*`
Node.js is an event-based server-side JavaScript engine.

Alternatives

Package Version Architecture Repository
node-accepts_1.3.5-1_all.deb 1.3.5 all Debian Main
node-accepts - - -

Requires

Name Value
node-mime-types >= 2.1.18
node-negotiator >= 0.6.1
nodejs -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package node-accepts_1.3.5-1_all.deb
Source Package node-accepts

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install node-accepts deb package:
    # sudo apt-get install node-accepts

Files

Path
/usr/lib/nodejs/accepts/index.js
/usr/lib/nodejs/accepts/package.json
/usr/share/doc/node-accepts/HISTORY.md.gz
/usr/share/doc/node-accepts/README.md.gz
/usr/share/doc/node-accepts/changelog.Debian.gz
/usr/share/doc/node-accepts/changelog.gz
/usr/share/doc/node-accepts/copyright

Changelog

2018-10-31 - Bastien Roucari├Ęs <rouca@debian.org>
node-accepts (1.3.5-1) unstable; urgency=medium
* Team upload
* Move to salsa
* Bump policy and compat
* Move to section javascript
* Run testsuite in CI
2014-10-11 - Leo Iannacone <l3on@ubuntu.com>
node-accepts (1.1.1-1) unstable; urgency=medium
* Imported Upstream version 1.1.1
* Bump Standard-Version 3.9.6
* Update usptream URLs from expressjs to jshttp
* debian/control:
- add dependency on node-mime-types
- builddep on debhelper version 8 instead of 9 - no
reason to require 9
- builddep on nodejs
- move to pkg-javascript
* debian/copyright:
- add Upstream-Contact
- fix upstream copyright year
- release debian files under the same upstream
license: Expat
* debian/rules:
- run upstream tests during build
- install HISTORY.md as upstream changelog
* Add autopkgtest suite
2014-04-16 - Leo Iannacone <l3on@ubuntu.com>
node-accepts (1.0.1-1) unstable; urgency=low
* Initial release (Closes: #744765)

See Also

Package Description
node-acorn-dynamic-import_3.0.0-1_all.deb Support dynamic imports in acorn
node-acorn-jsx_4.1.1-2_all.deb JSX parser based on node-acorn
node-acorn-object-spread_5.1.2-1_all.deb Plugin for object spread in acorn for Node.js
node-acorn_5.5.3+ds3-3_all.deb ECMAScript parser for Node.js
node-active-x-obfuscator_0.0.2-2_all.deb Safely obfuscate the string 'ActiveX' inside of JavaScript code
node-address_1.0.3-1_all.deb Get current machine IP, MAC and DNS servers
node-addressparser_1.0.1-1_all.deb parse e-mail addresses
node-after_0.8.2-1_all.deb Flow control for Node.js
node-ajv-keywords_2.1.0-1_all.deb Custom JSON-Schema keywords for Ajv validator
node-ajv_5.0.0-1_all.deb another JSON Schema Validator
node-almond_0.3.3+dfsg-2_amd64.deb minimal AMD API implementation for use in optimized browser builds
node-amdefine_1.0.1-1_all.deb Asynchronous Module Definition (AMD) for Node.js
node-ansi-align_2.0.0-1_all.deb align-text with ANSI support for CLIs
node-ansi-color-table_1.0.0-1_all.deb Color and format tables for ansi output - Node.js module
node-ansi-escapes_3.0.0-1_all.deb ANSI escape codes for manipulating the terminal
Advertisement
Advertisement