network-manager-openconnect-gnome_1.2.4-2_amd64.deb


Advertisement

Description

network-manager-openconnect-gnome - network management framework (OpenConnect plugin GNOME GUI)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename network-manager-openconnect-gnome_1.2.4-2_amd64.deb
Package name network-manager-openconnect-gnome
Package version 1.2.4
Package release 2
Package architecture amd64
Package type deb
Category implemented-in::c net role::plugin suite::gnome uitoolkit::gtk
Homepage http://www.gnome.org/projects/NetworkManager/
License -
Maintainer Mike Miller <mtmiller@debian.org>
Download size 31.26 KB
Installed size 156.00 KB
NetworkManager is a system network service that manages your network devices
and connections, attempting to keep active network connectivity when
available. It manages ethernet, WiFi, mobile broadband (WWAN), and PPPoE
devices, and provides VPN integration with a variety of different VPN
services.
This package provides the GNOME bits of NetworkManager's OpenConnect plugin.

Alternatives

Package Version Architecture Repository
network-manager-openconnect-gnome_1.2.4-2_i386.deb 1.2.4 i386 Debian Main
network-manager-openconnect-gnome - - -

Requires

Name Value
libatk1.0-0 >= 1.12.4
libc6 >= 2.4
libcairo-gobject2 >= 1.10.0
libcairo2 >= 1.2.4
libgdk-pixbuf2.0-0 >= 2.22.0
libglib2.0-0 >= 2.37.3
libgtk-3-0 >= 3.0.0
libnm0 >= 1.1.90
libopenconnect5 >= 7.05
libpango-1.0-0 >= 1.14.0
libpangocairo-1.0-0 >= 1.14.0
libsecret-1-0 >= 0.7
libxml2 >= 2.7.4
network-manager-openconnect = 1.2.4-2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package network-manager-openconnect-gnome_1.2.4-2_amd64.deb
Source Package network-manager-openconnect

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install network-manager-openconnect-gnome deb package:
    # sudo apt-get install network-manager-openconnect-gnome

Files

Path
/usr/lib/NetworkManager/nm-openconnect-auth-dialog
/usr/lib/x86_64-linux-gnu/NetworkManager/libnm-vpn-plugin-openconnect-editor.so
/usr/share/appdata/network-manager-openconnect.metainfo.xml
/usr/share/doc/network-manager-openconnect-gnome/NEWS.Debian.gz
/usr/share/doc/network-manager-openconnect-gnome/changelog.Debian.gz
/usr/share/doc/network-manager-openconnect-gnome/changelog.gz
/usr/share/doc/network-manager-openconnect-gnome/copyright
/usr/share/gnome-vpn-properties/openconnect/nm-openconnect-dialog.ui

Changelog

2019-03-01 - Mike Miller <mtmiller@debian.org>
network-manager-openconnect (1.2.4-2) unstable; urgency=medium
[ Ondřej Nový ]
* d/control: Set Vcs-* to salsa.debian.org
[ Mike Miller ]
* Build-depend on debhelper-compat (= 12) instead of using d/compat
* d/rules:
- Use architecture.mk for DEB_HOST_MULTIARCH
- Drop cruft trying to save and restore generated source files
* Run wrap-and-sort on d/*.install
* d/control: Bump Standards-Version to 4.3.0 (no changes needed)
* d/copyright: Bump copyright to 2019 for debian/*
2018-08-11 - Michael Biebl <biebl@debian.org>
network-manager-openconnect (1.2.4-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Disable libnm-glib support (Closes: #862884, #898661)
* Install AppData file (Closes: #852705)
* Move libnm-vpn-plugin-openconnect and translations into main package
(Closes: #852706)
2016-12-08 - Mike Miller <mtmiller@debian.org>
network-manager-openconnect (1.2.4-1) unstable; urgency=medium
* New upstream version 1.2.4
- Support Juniper Network Connect / Junos Pulse Secure VPN (Closes: 789112)
* Bump network-manager-dev and libnm-*-dev dependency to (>= 1.2.0)
* Bump debhelper compat level to 10. Building with dh_autoreconf is the
default.
* d/control: Drop obsolete build-depends on libdbus-glib-1-dev and
libgconf2-dev
* d/control: Drop unnecessary build-depends on dh-autoreconf and dpkg-dev
* d/control: Drop obsolete versioned dependencies from pre-wheezy
* d/control: Drop obsolete Breaks/Replaces from pre-wheezy
* d/control: Sort fields according to "cme fix dpkg-control"
* d/control: Use canonical repository URL for Vcs-Git
* d/copyright: Update Format using "cme fix dpkg-copyright"
* Bump Standards-Version to 3.9.8, no changes needed
2016-05-28 - Mike Miller <mtmiller@debian.org>
network-manager-openconnect (1.2.2-1) unstable; urgency=medium
[ Aron Xu ]
* New upstream release.
[ Mike Miller ]
* Add dependency on network-manager (>= 1.2) to ensure non-absolute
plugin paths are handled.
* No longer need to build with configure option --enable-absolute-
paths.
2016-04-22 - Mike Miller <mtmiller@debian.org>
network-manager-openconnect (1.2.0-1) unstable; urgency=medium
* New upstream release. (Closes: #817057)
* Install nm-openconnect-service.name in its new location.
* Build with configure option --enable-absolute-paths.
* Bump network-manager-dev and libnm-*-dev dependency to (>= 1.1.0).
* Build-depend on libglib2.0-dev (>= 2.32).
* Drop unnecessary dependency on network-manager (>= 0.9.4.0-4).
* Update Vcs-* fields to use https.
* Bump Standards-Version to 3.9.7. No changes needed.
* Add "core" to short description for consistency.
2015-05-10 - Mike Miller <mtmiller@debian.org>
network-manager-openconnect (1.0.2-1) unstable; urgency=medium
* New upstream release.
- Fixes FTBFS when building with libopenconnect >= 5. (Closes: #784921)
* Build-depend on network-manager-dev and libnm-*-dev (>= 0.9.10).
* Bump Standards-Version to 3.9.6. No changes needed.
2014-09-15 - Mike Miller <mtmiller@debian.org>
network-manager-openconnect (0.9.10.0-1) unstable; urgency=medium
* New upstream release.
- Fixes FTBFS due to deprecated gnome-keyring API. (Closes: #759836)
* Build-depend on libsecret-1-dev, no longer build-depend on
libgnome-keyring-dev.
* Bump the build-dependency on libgtk-3-dev to (>= 3.4).
* Bump debhelper compatibility level to 9.
* No longer explicitly export dpkg-buildflags, debhelper v9 sets them.
* Use dh-autoreconf to regenerate the build system, drop autotools-dev.
(Closes: #750060)

See Also

Package Description
network-manager-openconnect_1.2.4-2_amd64.deb network management framework (OpenConnect plugin core)
network-manager-openvpn-gnome_1.8.10-1_amd64.deb network management framework (OpenVPN plugin GNOME GUI)
network-manager-openvpn_1.8.10-1_amd64.deb network management framework (OpenVPN plugin core)
network-manager-pptp-gnome_1.2.8-2_amd64.deb network management framework (PPTP plugin GNOME GUI)
network-manager-pptp_1.2.8-2_amd64.deb network management framework (PPTP plugin core)
network-manager-ssh-gnome_1.2.10-1_amd64.deb network management framework (SSH plugin GNOME GUI)
network-manager-ssh_1.2.10-1_amd64.deb network management framework (SSH plugin core)
network-manager-strongswan_1.4.4-2_amd64.deb network management framework (strongSwan plugin)
network-manager-vpnc-gnome_1.2.6-2_amd64.deb network management framework (VPNC plugin GNOME GUI)
network-manager-vpnc_1.2.6-2_amd64.deb network management framework (VPNC plugin core)
network-manager_1.14.6-2+deb10u1_amd64.deb network management framework (daemon and userspace tools)
networkd-dispatcher_2.0-2_all.deb Dispatcher service for systemd-networkd connection status changes
networking-bagpipe-doc_9.0.0-2_all.deb OpenStack virtual network service - BGP-based VPN - doc
networking-bgpvpn-doc_9.0.0-1_all.deb OpenStack virtual network service - BGP-MPLS VPN Extension - doc
networking-mlnx-common_13.1.0-2_all.deb OpenStack virtual network service - Mellanox plugin common files
Advertisement
Advertisement