needrestart_3.4-5_all.deb


Advertisement

Description

needrestart - check which daemons need to be restarted after library upgrades

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename needrestart_3.4-5_all.deb
Package name needrestart
Package version 3.4
Package release 5
Package architecture all
Package type deb
Category admin
Homepage https://github.com/liske/needrestart
License -
Maintainer Patrick Matthäi <pmatthaei@debian.org>
Download size 56.01 KB
Installed size 273.00 KB
needrestart checks which daemons need to be restarted after library upgrades.
It is inspired by checkrestart from the debian-goodies package.
Features:
- supports (but does not require) systemd
- binary blacklisting (i.e. display managers)
- tries to detect required restarts of interpreter based daemons
(supports Java, Perl, Python, Ruby)
- tries to detect required restarts of containers (docker, LXC)
- tries to detect pending kernel upgrades
- tries to detect pending microcode upgrades for Intel CPUs
- could be used as nagios check_command
- fully integrated into apt/dpkg using hooks

Alternatives

Package Version Architecture Repository
needrestart_3.4-5_all.deb 3.4 all Debian Main
needrestart - - -

Requires

Name Value
binutils -
dpkg >= 1.16.0
gettext-base -
libintl-perl -
libmodule-find-perl -
libmodule-scandeps-perl -
libproc-processtable-perl -
libsort-naturally-perl -
libterm-readkey-perl -
perl -
xz-utils -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package needrestart_3.4-5_all.deb
Source Package needrestart

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install needrestart deb package:
    # sudo apt-get install needrestart

Files

Path
/etc/apt/apt.conf.d/99needrestart
/etc/dpkg/dpkg.cfg.d/needrestart
/etc/needrestart/needrestart.conf
/etc/needrestart/notify.conf
/etc/needrestart/conf.d/README.needrestart
/etc/needrestart/hook.d/10-dpkg
/etc/needrestart/hook.d/20-rpm
/etc/needrestart/hook.d/90-none
/etc/needrestart/notify.d/200-write
/etc/needrestart/notify.d/400-notify-send
/etc/needrestart/notify.d/600-mail
/etc/needrestart/notify.d/README.needrestart
/etc/needrestart/restart.d/README.needrestart
/etc/needrestart/restart.d/dbus.service
/etc/needrestart/restart.d/systemd-manager
/etc/needrestart/restart.d/sysv-init
/usr/lib/needrestart/apt-pinvoke
/usr/lib/needrestart/dpkg-status
/usr/lib/needrestart/iucode-scan-versions
/usr/lib/needrestart/notify.d.sh
/usr/lib/needrestart/vmlinuz-get-version
/usr/sbin/needrestart
/usr/share/bug/needrestart/script
/usr/share/doc/needrestart/NEWS.Debian.gz
/usr/share/doc/needrestart/NEWS.gz
/usr/share/doc/needrestart/README.Cont.md
/usr/share/doc/needrestart/README.Interp.md
/usr/share/doc/needrestart/README.batch.md
/usr/share/doc/needrestart/README.md
/usr/share/doc/needrestart/README.nagios.md
/usr/share/doc/needrestart/README.uCode.md
/usr/share/doc/needrestart/changelog.Debian.gz
/usr/share/doc/needrestart/changelog.gz
/usr/share/doc/needrestart/copyright
/usr/share/doc/needrestart/examples/needrestart-nagios
/usr/share/locale/cs/LC_MESSAGES/needrestart-notify.mo
/usr/share/locale/cs/LC_MESSAGES/needrestart.mo
/usr/share/locale/de/LC_MESSAGES/needrestart-notify.mo
/usr/share/locale/de/LC_MESSAGES/needrestart.mo
/usr/share/locale/ru/LC_MESSAGES/needrestart-notify.mo
/usr/share/locale/ru/LC_MESSAGES/needrestart.mo
/usr/share/man/man1/needrestart.1.gz
/usr/share/needrestart/needrestart.templates
/usr/share/perl5/NeedRestart.pm
/usr/share/perl5/NeedRestart/CONT.pm
/usr/share/perl5/NeedRestart/Interp.pm
/usr/share/perl5/NeedRestart/Kernel.pm
/usr/share/perl5/NeedRestart/Strings.pm
/usr/share/perl5/NeedRestart/UI.pm
/usr/share/perl5/NeedRestart/Utils.pm
/usr/share/perl5/NeedRestart/uCode.pm
/usr/share/perl5/NeedRestart/CONT/LXC.pm
/usr/share/perl5/NeedRestart/CONT/docker.pm
/usr/share/perl5/NeedRestart/CONT/machined.pm
/usr/share/perl5/NeedRestart/Interp/Java.pm
/usr/share/perl5/NeedRestart/Interp/Perl.pm
/usr/share/perl5/NeedRestart/Interp/Python.pm
/usr/share/perl5/NeedRestart/Interp/Ruby.pm
/usr/share/perl5/NeedRestart/Kernel/Linux.pm
/usr/share/perl5/NeedRestart/Kernel/kFreeBSD.pm
/usr/share/perl5/NeedRestart/UI/Debconf.pm
/usr/share/perl5/NeedRestart/UI/stdio.pm
/usr/share/perl5/NeedRestart/uCode/Intel.pm
/usr/share/polkit-1/actions/net.fiasko-nw.needrestart.policy

Changelog

2019-05-24 - Patrick Matthäi <pmatthaei@debian.org>
needrestart (3.4-5) unstable; urgency=medium
* Remove 3.4-3~bpo9+1 changelog entry.
2019-05-09 - Patrick Matthäi <pmatthaei@debian.org>
needrestart (3.4-4) unstable; urgency=medium
* Add upstream patch 05-strip-leading-zeroes to remove leading zero before
testing in map_files.
Closes: #928225
* Merge 3.4-3~bpo9+1 changelog.
2019-04-18 - Patrick Matthäi <pmatthaei@debian.org>
needrestart (3.4-3) unstable; urgency=medium
* Add upstream patch 04-restore-cwd to restore the cwd when skipping
processes with unavailable cwd.
2019-03-28 - Patrick Matthäi <pmatthaei@debian.org>
needrestart (3.4-2) unstable; urgency=medium
* Add upstream patch 02-ignore-networking: Do not restart networking.service.
Closes: #922725
* Add upstream patch 03-typo-env-var: Fix typo in man page for env variable
DEBIAN_FRONT(END).
Closes: #923853
2019-02-11 - Patrick Matthäi <pmatthaei@debian.org>
needrestart (3.4-1) unstable; urgency=medium
* New upstream release.
- Skip needrestart in apt hook if system is shutting down.
Closes: #914753
- Do restart systemd-journald again.
Closes: #898818
- Complains when the microcode is newer than what Debian has.
Closes: #906958
- Complains about microcode updates on systems with microcode for multiple
CPUs in initramfs.
Closes: #907372
- Do not restart oneshot services from systemd-cron.
Closes: #917073
* Bump Standards-Version to 4.3.0.
* Add ex/nagios/needrestart-nagios as documentation example.
Closes: #916845
* Bump debian/compat to level 12.
2018-11-15 - Patrick Matthäi <pmatthaei@debian.org>
needrestart (3.3-2) unstable; urgency=medium
* Bump Standards-Version to 4.2.1.
* Merge 3.3-1~bpo9+1 changelog.
* Add NEWS file for the configuration change, that services are not restarted
anymore in non-interactive mode with the default configuration.
Closes: #894444
* Fix typo in long description.
Closes: #913322
2018-07-26 - Patrick Matthäi <pmatthaei@debian.org>
needrestart (3.3-1~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports.
2018-06-25 - Patrick Matthäi <pmatthaei@debian.org>
needrestart (3.3-1) unstable; urgency=medium
* New upstream release.
- Fixed ignored configuration files.
Closes: #901999, #902031, #902049
2018-06-19 - Patrick Matthäi <pmatthaei@debian.org>
needrestart (3.2-1) unstable; urgency=medium
* New upstream release.
- Filter microcode for CPU signature and flags.
Closes: #900298
- Do not leak fd into restarted services.
Closes: #893152
* Merge 3.1-1~bpo9+1 changelog.
* Bump Standards-Version to 4.1.4.
2018-04-11 - Patrick Matthäi <pmatthaei@debian.org>
needrestart (3.1-1~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports.

See Also

Package Description
neko-dev_2.2.0-2+b12_amd64.deb Lightweight virtual machine - headers
neko_2.2.0-2+b12_amd64.deb Lightweight virtual machine - compiler and tools
nekobee_0.1.8~repack1-1_amd64.deb Simple single-oscillator DSSI plugin
nemiver_0.9.6-1.2_amd64.deb Standalone graphical debugger for GNOME
nemo-data_3.8.5-1_all.deb File manager and graphical shell for Cinnamon (data files)
nemo-fileroller_3.8.0-2_amd64.deb File Roller integration for Nemo
nemo-gtkhash_1.2-1_amd64.deb nemo extension for computing checksums and more using gtkhash
nemo-nextcloud_2.5.1-3_all.deb Nextcloud integration for Nemo
nemo-owncloud_2.5.1.10973+dfsg-1_all.deb ownCloud integration for Nemo
nemo-python_3.8.0-2_amd64.deb Python bindings for nemo components
nemo_3.8.5-1+b1_amd64.deb File manager and graphical shell for Cinnamon
neo4j-client_2.2.0-1+b1_amd64.deb Command line shell for the Neo4j graph database
neobio_0.0.20030929-4_all.deb computes alignments of amino acid and nucleotide sequences
neofetch_6.0.0-2_all.deb Shows Linux System Information with Distribution Logo
neomutt_20180716+dfsg.1-1_amd64.deb command line mail reader based on Mutt, with added features
Advertisement
Advertisement