mpdris2_0.8-1_all.deb


Advertisement

Description

mpdris2 - media player interface (MPRIS2) bridge for MPD

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename mpdris2_0.8-1_all.deb
Package name mpdris2
Package version 0.8
Package release 1
Package architecture all
Package type deb
Category implemented-in::python interface::daemon role::program sound sound::player use::playing works-with::audio
Homepage https://github.com/eonpatapon/mpDris2
License -
Maintainer mpd maintainers <pkg-mpd-maintainers@lists.alioth.debian.org>
Download size 17.95 KB
Installed size 96.00 KB
mpDris2 is an implementation of the MPRIS2 media player interface as a
client for MPD, allowing MPRIS2 clients to control MPD and observe its
track changes via a standard D-Bus interface.
It can also respond to multimedia keys if running under GNOME,
and send track-change notifications if gir1.2-notify-0.7 is installed.

Alternatives

Package Version Architecture Repository
mpdris2_0.8-1_all.deb 0.8 all Debian Main
mpdris2 - - -

Requires

Name Value
dbus -
python3 -
python3-dbus -
python3-gi -
python3-mpd -
python3:any -

Provides

Name Value
mpd-client -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package mpdris2_0.8-1_all.deb
Source Package mpdris2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mpdris2 deb package:
    # sudo apt-get install mpdris2

Files

Path
/etc/xdg/autostart/mpdris2.desktop
/usr/bin/mpDris2
/usr/lib/systemd/user/mpDris2.service
/usr/share/applications/mpdris2.desktop
/usr/share/dbus-1/services/org.mpris.MediaPlayer2.mpd.service
/usr/share/doc/mpdris2/AUTHORS
/usr/share/doc/mpdris2/README
/usr/share/doc/mpdris2/changelog.Debian.gz
/usr/share/doc/mpdris2/copyright
/usr/share/doc/mpdris2/examples/mpDris2.conf
/usr/share/locale/fr/LC_MESSAGES/mpDris2.mo
/usr/share/locale/nl/LC_MESSAGES/mpDris2.mo
/usr/share/man/man1/mpDris2.1.gz

Changelog

2019-02-25 - Simon McVittie <smcv@debian.org>
mpdris2 (0.8-1) unstable; urgency=medium
* New upstream release
- This only differs slightly from 0.7+git20181226, so it seems worth
packaging before buster to have a real upstream release in stable.
* Use dh_missing --fail-missing instead of dh_install --fail-missing
2019-01-15 - Simon McVittie <smcv@debian.org>
mpdris2 (0.7+git20181226-1) unstable; urgency=medium
* New upstream snapshot
- Drop non-Debian-specific patches, applied upstream
2018-02-25 - Simon McVittie <smcv@debian.org>
mpdris2 (0.7+git20180205-1) unstable; urgency=medium
* New upstream snapshot
* d/watch: Really ignore +gitYYYYMMDD suffix
* d/p/Add-compatibility-with-python-mpd2-1.0.0.patch:
Add patch to interoperate with python3-mpd 1.0.0 (Closes: #891416)
* d/p/debian/: Move Debian-specific patch to Gbp-Pq: Topic debian
* Mark upstreamable patches as forwarded
2018-01-27 - Simon McVittie <smcv@debian.org>
mpdris2 (0.7+git20171012-2) unstable; urgency=medium
* Standards-Version: 4.1.3 (no changes required)
* Change Vcs-* to salsa.debian.org
* d/watch: Ignore +gitYYYYMMDD suffix when determining corresponding
upstream version
2017-12-10 - Simon McVittie <smcv@debian.org>
mpdris2 (0.7+git20171012-1) unstable; urgency=medium
* New upstream snapshot
* Standards-Version: 4.1.2
- d/copyright: Use preferred https URL
* d/mpDris.1.in: Fix a typo
2016-09-21 - Simon McVittie <smcv@debian.org>
mpdris2 (0.7+git20160917-1) unstable; urgency=medium
* New upstream snapshot
- catch and ignore ValueError if python3-gi is available, but
Notify-0.7 GIR is not (Closes: #838084)
2016-07-26 - Simon McVittie <smcv@debian.org>
mpdris2 (0.7+git20160705-1) unstable; urgency=medium
* New upstream snapshot
* Switch to Python 3 now that python3-mpd is available
* debian/gbp.conf: use DEP-14 branch names
* Set Maintainer to pkg-mpd-maintainers (git repository is still in
collab-maint)
* Add patch to make failure to update notifications non-fatal
(Closes: #830816)
2016-04-30 - Simon McVittie <smcv@debian.org>
mpdris2 (0.7+git20160206-1) unstable; urgency=medium
* New upstream snapshot
* Standards-Version: 3.9.8 (no changes needed)
* debian/rules: add glue code to export upstream snapshots
2016-01-22 - Simon McVittie <smcv@debian.org>
mpdris2 (0.7+git20151224-1) unstable; urgency=medium
* New upstream snapshot
- refresh remaining patch
- use autogen.sh instead of autoreconf, so we libtoolize
- install the new systemd user service
* Vcs-Browser: switch to https and cgit
* Switch Vcs-Git to https (see #810378)
* Fail the build if there is anything we didn't install
* Upload to unstable
2015-06-16 - Simon McVittie <smcv@debian.org>
mpdris2 (0.6+git20150606-1) experimental; urgency=medium
* New upstream snapshot
- can use python-gi instead of python-gobject and python-notify

See Also

Package Description
mpdscribble_0.22-6_amd64.deb Last.fm reporting client for mpd
mpdtoys_0.25_all.deb small command line tools and toys for MPD
mpeg2dec_0.5.1-8_amd64.deb Simple libmpeg2 video decoder application
mpeg3-utils_1.8.dfsg-2.1_amd64.deb MPEG streams decoding library
mpegdemux_0.1.4-4_amd64.deb MPEG1/2 system stream demultiplexer
mpg123-el_1.58-1_all.deb front-end to mpg321/ogg321 media players for Emacs
mpg123_1.25.10-2_amd64.deb MPEG layer 1/2/3 audio player
mpg321_0.3.2-3_amd64.deb Simple and lightweight command line MP3 player
mpgrafic_0.3.18-1_amd64.deb MPI version of N-body initial conditions grafic package
mpgtx_1.3.1-6_amd64.deb toolbox to manipulate MPEG files (video, system, and audio)
mpi-default-bin_1.13_amd64.deb Standard MPI runtime programs (metapackage)
mpi-default-dev_1.13_amd64.deb Standard MPI development files (metapackage)
mpich-doc_3.3-3_all.deb Documentation for MPICH
mpich_3.3-3_amd64.deb Implementation of the MPI Message Passing Interface standard
mpikmeans-tools_1.5+dfsg-7_amd64.deb Standalone applications for MPIKmeans
Advertisement
Advertisement