lyx_2.3.2-1_amd64.deb


Advertisement

Description

lyx - document processor

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename lyx_2.3.2-1_amd64.deb
Package name lyx
Package version 2.3.2
Package release 1
Package architecture amd64
Package type deb
Category editors implemented-in::c++ interface::commandline interface::graphical interface::x11 role::program scope::application uitoolkit::qt use::editing use::text-formatting use::typesetting works-with-format::tex works-with::text x11::application
Homepage https://www.lyx.org/
License -
Maintainer Dr. Tobias Quathamer <toddy@debian.org>
Download size 7.73 MB
Installed size 17.18 MB
LyX is an almost WYSIWYG-frontend for LaTeX. It makes the power and
typesetting quality of LaTeX available for people who are used to
word processors. Since LyX supports LaTeX's concept of general
mark-ups, it is even easier and faster to create professional quality
documents with it than with usual word processors. It is also
possible to use LaTeX commands within LyX, so nothing of LaTeX's
power is lost.
You can extend the functionality of LyX by installing these packages:
* chktex: check for typographical errors
* gnuhtml2latex: import HTML documents
* groff: improved table formatting in plain text exports
* librsvg2-bin, inkscape: use the SVG image format in LyX documents
* linuxdoc-tools: export SGML LinuxDoc documents
* mythes-*: use the OpenOffice.org/LibreOffice Thesaurus
* noweb: import noweb files
* rcs: integrated version control
* sgmltools-lite: export SGML DocBook documents
* texlive-xetex: use the XeTeX typesetting system
* wv: import MS Word documents

Alternatives

Package Version Architecture Repository
lyx_2.3.2-1_i386.deb 2.3.2 i386 Debian Main
lyx - - -

Requires

Name Value
libc6 >= 2.15
libenchant1c2a >= 1.6.0
libgcc1 >= 1:3.0
libmagic1 >= 5.12
libmythes-1.2-0 -
libqt5core5a >= 5.11.0~rc1
libqt5gui5 >= 5.8.0
libqt5svg5 >= 5.6.0~beta
libqt5widgets5 >= 5.11.0~rc1
libstdc++6 >= 5.2
lyx-common = 2.3.2-1
xdg-utils -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lyx_2.3.2-1_amd64.deb
Source Package lyx

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lyx deb package:
    # sudo apt-get install lyx

Files

Path
/usr/bin/lyx
/usr/bin/lyxclient
/usr/bin/tex2lyx
/usr/lib/mime/packages/lyx
/usr/share/applications/lyx.desktop
/usr/share/doc/lyx
/usr/share/icons/hicolor/48x48/apps/lyx.png
/usr/share/icons/hicolor/scalable/apps/lyx.svg
/usr/share/man/man1/lyx.1.gz
/usr/share/man/man1/lyxclient.1.gz
/usr/share/man/man1/tex2lyx.1.gz
/usr/share/pixmaps/lyx-32x32.xpm

Changelog

2018-12-14 - Dr. Tobias Quathamer <toddy@debian.org>
lyx (2.3.2-1) unstable; urgency=medium
* New upstream version 2.3.2
- Refresh patches
2018-10-17 - Dr. Tobias Quathamer <toddy@debian.org>
lyx (2.3.1-2-2) unstable; urgency=medium
* Fix failing configuration of a fresh LyX installation.
A fresh install of LyX results in the same /usr/share/lyx/configure.py
failure, and removing ~/.lyx/ on an existing install reproduces the
issue. It does not occur when ~/.lyx/ is already setup. Problem is
related to the move to Python 3 and comparisons of bytes and strings.
Thanks to Jonathan McDowell <noodles@earth.li> (Closes: #909995)
2018-09-17 - Dr. Tobias Quathamer <toddy@debian.org>
lyx (2.3.1-2-1) unstable; urgency=medium
* New upstream version 2.3.1-2
- Remove patch for Qt 5.11, is now included upstream
- Refresh remaining patch
* Another try to switch from Python2 to Python3. According to
the upstream release announcement:
"All python scripts distributed with LyX should now be compatible with
both python 2.x and python 3.x."
In order to fully support python3, some more patches have been created:
- Add patch to use python3 instead of python2 during configuration
- Add patch for python3 shebang line in the distributed python scripts
- Use python3 internally in the C code as well
* Update d/watch
2018-09-07 - Dr. Tobias Quathamer <toddy@debian.org>
lyx (2.3.0-3) unstable; urgency=medium
* Update upstream URL in d/watch and switch to version 4
* Update Standards-Version to 4.2.1, no changes needed
* New patch: Fix FTBFS with Qt 5.11.
This is a cherry-pick from upstream's git repository:
5394481071824b39b521d67e2acd7d509e68d0f8 (Closes: #907993)
2018-03-09 - Dr. Tobias Quathamer <toddy@debian.org>
lyx (2.3.0-2) unstable; urgency=medium
* Disable two Python3 patches.
They make the package unusable with Python2. (Closes: #892418)
2018-03-08 - Dr. Tobias Quathamer <toddy@debian.org>
lyx (2.3.0-1) unstable; urgency=medium
* New upstream version 2.3.0
* Refresh patches
* Update d/copyright
* Remove obsolete NEWS file. The lyx versions are no longer
in old-old-stable.
* Remove d/ttf-lyx.maintscript, has been part of a stable release
and is no longer needed.
* Remove d/lyx-common.maintscript, has been part of a stable release
and is no longer needed.
* Remove Pre-Depends line from lyx-common, no longer needed
* Remove Replaces/Breaks on lyx-common, no longer needed
2018-02-07 - Dr. Tobias Quathamer <toddy@debian.org>
lyx (2.2.3-5) unstable; urgency=medium
* Revert "Use Python 3 instead of 2", introduced in 2.2.3-3.
The support of Python 3 is still too fragile and results
in FTBFS bugs in packages depending on lyx conversion
scripts. Thanks to Andreas Beckmann <anbe@debian.org> for
spotting this bug and reporting it. (Closes: #889793)
2018-02-03 - Dr. Tobias Quathamer <toddy@debian.org>
lyx (2.3.0~rc2-2) experimental; urgency=medium
* Remove unneeded symlink creation to debug package.
After the dbgsym migration, there's no longer a lyx-dbg package
created and the package FTBFS twice in a row due to the leftover
directory.
Thanks to Andreas Beckmann <anbe@debian.org> (Closes: #889492)
2018-02-03 - Dr. Tobias Quathamer <toddy@debian.org>
lyx (2.2.3-4) unstable; urgency=medium
* Remove unneeded symlink creation to debug package.
After the dbgsym migration, there's no longer a lyx-dbg package
created and the package FTBFS twice in a row due to the leftover
directory.
Thanks to Andreas Beckmann <anbe@debian.org> (Closes: #889492)
2018-01-31 - Dr. Tobias Quathamer <toddy@debian.org>
lyx (2.3.0~rc2-1) experimental; urgency=medium
* New upstream version 2.3.0~rc2
* Refresh patches

See Also

Package Description
lz4_1.8.3-1_amd64.deb Fast LZ compression algorithm library - tool
lz4json_2-1_amd64.deb unpack lz4json files, usually generated by Mozilla programs
lzd_1.1-3_amd64.deb Educational, lossless data compressor based on the LZMA algorithm
lzip_1.21-3_amd64.deb lossless data compressor based on the LZMA algorithm
lziprecover_1.21-3_amd64.deb lossless data compressor based on the LZMA algorithm (recovery)
lzma-alone_9.22-2.1_amd64.deb Compression and decompression in the LZMA format - legacy utility
lzma-dev_9.22-2.1_all.deb Compression and decompression in the LZMA format - development files
lzma_9.22-2.1_amd64.deb Compression and decompression in the LZMA format - command line utility
lzop_1.03-4+b1_amd64.deb fast compression program
m16c-flash_0.1-1.1+b2_amd64.deb Flash programmer for Renesas M16C and R8C microcontrollers
m17n-db_1.8.0-1_all.deb multilingual text processing library - database
m17n-docs_1.6.2-2_all.deb multilingual text processing library - documents
m17n-im-config_0.9.0-5_amd64.deb input method configuration library for m17n-lib - utility
m17n-lib-bin_1.8.0-2_amd64.deb multilingual text processing library - utilities
m17n-lib-mimx_1.8.0-2_amd64.deb multilingual text processing library - binary modules
Advertisement
Advertisement