lua-wsapi_1.6.1-1_all.deb


Advertisement

Description

lua-wsapi - Web server API abstraction layer for the Lua language

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename lua-wsapi_1.6.1-1_all.deb
Package name lua-wsapi
Package version 1.6.1
Package release 1
Package architecture all
Package type deb
Category interpreters
Homepage http://keplerproject.github.com/wsapi/index.html
License -
Maintainer Enrico Tassi <gareuselesinge@debian.org>
Download size 17.67 KB
Installed size 96.00 KB
WSAPI is an API that abstracts the web server for Lua web applications,
allowing the same application to be used in different web servers.
This package contains the WSAPI utility libraries (for common tasks like url
encoding/decoding) as well as the following backends (server implementations):
- CGI (the regular environment-variables based protocol)
- xavante (for the Xavante web server)
The fastcgi backends is available in the separate package lua-wsapi-fcgi.

Alternatives

Package Version Architecture Repository
lua-wsapi_1.6.1-1_all.deb 1.6.1 all Debian Main
lua-wsapi - - -

Requires

Name Value
lua-cgi -
lua-coxpcall -
lua-filesystem -
lua-rings -
lua5.1 -

Provides

Name Value
lua5.1-wsapi -
lua5.2-wsapi -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lua-wsapi_1.6.1-1_all.deb
Source Package lua-wsapi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-wsapi deb package:
    # sudo apt-get install lua-wsapi

Files

Path
/usr/bin/wsapi.cgi
/usr/share/doc/lua-wsapi/changelog.Debian.gz
/usr/share/doc/lua-wsapi/copyright
/usr/share/lua/5.1/wsapi.lua
/usr/share/lua/5.1/wsapi/cgi.lua
/usr/share/lua/5.1/wsapi/common.lua
/usr/share/lua/5.1/wsapi/fastcgi.lua
/usr/share/lua/5.1/wsapi/mock.lua
/usr/share/lua/5.1/wsapi/request.lua
/usr/share/lua/5.1/wsapi/response.lua
/usr/share/lua/5.1/wsapi/ringer.lua
/usr/share/lua/5.1/wsapi/sapi.lua
/usr/share/lua/5.1/wsapi/util.lua
/usr/share/lua/5.1/wsapi/xavante.lua
/usr/share/lua/5.2/wsapi.lua
/usr/share/lua/5.2/wsapi/cgi.lua
/usr/share/lua/5.2/wsapi/common.lua
/usr/share/lua/5.2/wsapi/fastcgi.lua
/usr/share/lua/5.2/wsapi/mock.lua
/usr/share/lua/5.2/wsapi/request.lua
/usr/share/lua/5.2/wsapi/response.lua
/usr/share/lua/5.2/wsapi/ringer.lua
/usr/share/lua/5.2/wsapi/sapi.lua
/usr/share/lua/5.2/wsapi/util.lua
/usr/share/lua/5.2/wsapi/xavante.lua
/usr/share/man/man1/wsapi.cgi.1.gz

Changelog

2015-08-15 - Enrico Tassi <gareuselesinge@debian.org>
lua-wsapi (1.6.1-1) unstable; urgency=medium
* New upstream release 
* Remove transition package leftover 
2014-06-30 - Enrico Tassi <gareuselesinge@debian.org>
lua-wsapi (1.6.0-3) unstable; urgency=medium
* Ship files for Lua 5.2 
2014-06-30 - Enrico Tassi <gareuselesinge@debian.org>
lua-wsapi (1.6.0-2) unstable; urgency=medium
* Include wsapi.lua 
2012-10-23 - Enrico Tassi <gareuselesinge@debian.org>
lua-wsapi (1.6.0-1) unstable; urgency=low
* New upstream version supporting Lua 5.2 
* Packaging moved to git
* Removed transitional packages
2012-04-28 - Enrico Tassi <gareuselesinge@debian.org>
lua-wsapi (1.5-3) unstable; urgency=low
* wsapi.cgi lines ending converted to unix (Closes: #691214)
2012-04-28 - Enrico Tassi <gareuselesinge@debian.org>
lua-wsapi (1.5-2) unstable; urgency=low
* Switch to dh-lua
* Packages renamed according to the new Lua policy 
* Standards-Version to 3.9.3, no changes
* debian/compat set to 8 
* Copyright format 1.0 
2011-08-13 - Enrico Tassi <gareuselesinge@debian.org>
lua-wsapi (1.5-1) unstable; urgency=low
* New upstream release (Closes: #636232)
* fixed watch file (thanks Roland Stigge)
* refreshed patch lanuchers.patch (also renamed)
* removed patch sheebang.patch, applied upstream
2011-07-22 - Enrico Tassi <gareuselesinge@debian.org>
lua-wsapi (1.1.0-10) unstable; urgency=low
* source format 3.0 (quilt) 
2011-07-21 - Enrico Tassi <gareuselesinge@debian.org>
lua-wsapi (1.1.0-9) unstable; urgency=low
* Updated standards-version to 3.9.2, no changes 
* Multi-arch (dh >= 8.1.3, lua5.1-policy >= 32)
2010-07-16 - Enrico Tassi <gareuselesinge@debian.org>
lua-wsapi (1.1.0-8) unstable; urgency=low
* Add liblua5.1-coxpcall0 to depends (Closes: #589161)

See Also

Package Description
lua-xmlrpc_1.2.1-7_all.deb xmlrpc library for the Lua language
lua-yaml-dev_6.1-2_amd64.deb docs and test files for lua-yaml
lua-yaml_6.1-2_amd64.deb LibYAML binding for Lua
lua-zip-dev_1.2.3-12.1_amd64.deb zip development files for the Lua language
lua-zip_1.2.3-12.1_amd64.deb zip library for the Lua language
lua-zlib-dev_0.2+git+1+9622739-2.1_amd64.deb zlib development files for the Lua language
lua-zlib_0.2+git+1+9622739-2.1_amd64.deb zlib library for the Lua language
lua5.1-doc_5.1.5-8.1_all.deb Documentation for the Lua language version 5.1
lua5.1-policy-dev_33_all.deb Lua 5.1 Debian policy - template and scripts
lua5.1-policy_33_all.deb Lua 5.1 Debian policy
lua5.1_5.1.5-8.1+b2_amd64.deb Simple, extensible, embeddable programming language
lua5.2-doc_5.2.4-1.1_all.deb Documentation for the Lua language version 5.2
lua5.2_5.2.4-1.1+b2_amd64.deb Simple, extensible, embeddable programming language
lua5.3_5.3.3-1.1_amd64.deb Simple, extensible, embeddable programming language
lua50-doc_5.0.3-8_all.deb Documentation for the Lua 5.0 programming language
Advertisement
Advertisement