lua-curses_9.0.0-2+b1_amd64.deb


Advertisement

Description

lua-curses - curses library bindings for the Lua language

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename lua-curses_9.0.0-2+b1_amd64.deb
Package name lua-curses
Package version 9.0.0
Package release 2+b1
Package architecture amd64
Package type deb
Category interpreters uitoolkit::ncurses
Homepage https://github.com/lcurses/lcurses
License -
Maintainer Sophie Brun <sophie@freexian.com>
Download size 40.70 KB
Installed size 250.00 KB
This package contains bindings for the ncurses library for the Lua language.
It allows one to build simple interfaces on a text terminal.
This package used to be part of the lua-posix source package.

Alternatives

Package Version Architecture Repository
lua-curses_9.0.0-2+b1_i386.deb 9.0.0 i386 Debian Main
lua-curses - - -

Requires

Name Value
libc6 >= 2.14
libncursesw6 >= 6
libtinfo6 >= 6

Provides

Name Value
lua5.1-curses -
lua5.2-curses -
lua5.3-curses -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lua-curses_9.0.0-2+b1_amd64.deb
Source Package lua-curses

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-curses deb package:
    # sudo apt-get install lua-curses

Files

Path
/usr/lib/x86_64-linux-gnu/liblua5.1-curses.so.0
/usr/lib/x86_64-linux-gnu/liblua5.1-curses.so.0.0.0
/usr/lib/x86_64-linux-gnu/liblua5.2-curses.so.0
/usr/lib/x86_64-linux-gnu/liblua5.2-curses.so.0.0.0
/usr/lib/x86_64-linux-gnu/liblua5.3-curses.so.0
/usr/lib/x86_64-linux-gnu/liblua5.3-curses.so.0.0.0
/usr/lib/x86_64-linux-gnu/lua/5.1/curses_c.so
/usr/lib/x86_64-linux-gnu/lua/5.2/curses_c.so
/usr/lib/x86_64-linux-gnu/lua/5.3/curses_c.so
/usr/share/doc/lua-curses/changelog.Debian.amd64.gz
/usr/share/doc/lua-curses/changelog.Debian.gz
/usr/share/doc/lua-curses/changelog.gz
/usr/share/doc/lua-curses/copyright
/usr/share/lintian/overrides/lua-curses
/usr/share/lua/5.1/curses.lua
/usr/share/lua/5.2/curses.lua
/usr/share/lua/5.3/curses.lua

Changelog

2018-02-23 - Raphaƫl Hertzog <hertzog@debian.org>
lua-curses (1:9.0.0-2) unstable; urgency=medium
* Team upload to unstable.
* Drop luasandbox support as it's going away (see #891191).
2017-01-17 - Sophie Brun <sophie@freexian.com>
lua-curses (1:9.0.0-1) experimental; urgency=medium
* Initial release. This package was previously built from the source package
lua-posix. Upstream split posix and curses into two separated projects.

See Also

Package Description
lua-cyrussasl-dev_1.0.0-6.1_amd64.deb Cyrus SASL development files for the Lua language
lua-cyrussasl_1.0.0-6.1_amd64.deb Cyrus SASL library for the Lua language
lua-dbi-common_0.7.1-2_all.deb DBI library for the Lua language, common files
lua-dbi-mysql-dev_0.7.1-2_amd64.deb DBI library for the Lua language, MySQL development files
lua-dbi-mysql_0.7.1-2_amd64.deb DBI library for the Lua language, MySQL backend
lua-dbi-postgresql-dev_0.7.1-2_amd64.deb DBI library for the Lua language, PostgreSQL development files
lua-dbi-postgresql_0.7.1-2_amd64.deb DBI library for the Lua language, PostgreSQL backend
lua-dbi-sqlite3-dev_0.7.1-2_amd64.deb DBI library for the Lua language, sqlite3 development files
lua-dbi-sqlite3_0.7.1-2_amd64.deb DBI library for the Lua language, sqlite3 backend
lua-discount-dev_2.1.8-3_amd64.deb discount development files for the Lua language
lua-discount_2.1.8-3_amd64.deb Discount library for the Lua language
lua-dkjson_2.5-3_all.deb JSON module written in Lua
lua-doc_3.0.1+gitdb9e868-1_all.deb Documentation generator for lua
lua-event-dev_0.4.6-1_amd64.deb libevent development files for the Lua language
lua-event_0.4.6-1_amd64.deb asynchronous event notification library for Lua
Advertisement
Advertisement