lua-apr-dev_0.23.2.dfsg-4_amd64.deb


Advertisement

Description

lua-apr-dev - Lua development files for the Apache Portable Runtime library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename lua-apr-dev_0.23.2.dfsg-4_amd64.deb
Package name lua-apr-dev
Package version 0.23.2.dfsg
Package release 4
Package architecture amd64
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://peterodding.com/code/lua/apr/
License -
Maintainer Enrico Tassi <gareuselesinge@debian.org>
Download size 59.41 KB
Installed size 339.00 KB
This package contains the development files of the Apache Portable Runtime
library bindings, useful to create a statically linked binary (like a
C application or a standalone Lua interpreter).

Alternatives

Package Version Architecture Repository
lua-apr-dev_0.23.2.dfsg-4_i386.deb 0.23.2.dfsg i386 Debian Main
lua-apr-dev - - -

Requires

Name Value
lua-apr = 0.23.2.dfsg-4

Provides

Name Value
lua5.1-apr-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lua-apr-dev_0.23.2.dfsg-4_amd64.deb
Source Package lua-apr

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-apr-dev deb package:
    # sudo apt-get install lua-apr-dev

Files

Path
/usr/include/lua5.1/lua-apr.h
/usr/lib/x86_64-linux-gnu/liblua5.1-apr.a
/usr/lib/x86_64-linux-gnu/liblua5.1-apr.so
/usr/lib/x86_64-linux-gnu/pkgconfig/lua5.1-apr.pc
/usr/share/doc/lua-apr-dev/changelog.Debian.gz
/usr/share/doc/lua-apr-dev/copyright

Changelog

2015-08-14 - Enrico Tassi <gareuselesinge@debian.org>
lua-apr (0.23.2.dfsg-4) unstable; urgency=medium
* Fix lintian warning adding ${misc:Depends} to the -doc package 
* Fix watch file
2015-08-14 - Enrico Tassi <gareuselesinge@debian.org>
lua-apr (0.23.2.dfsg-3) unstable; urgency=medium
* Pre-Depends: use misc:Pre-Depends and not multiarch-support 
2014-01-18 - Enrico Tassi <gareuselesinge@debian.org>
lua-apr (0.23.2.dfsg-2) unstable; urgency=medium
* Fix test suite (Closes: #735830) 
2013-08-17 - Enrico Tassi <gareuselesinge@debian.org>
lua-apr (0.23.2.dfsg-1) unstable; urgency=low
* Ship doc into a separate arch-all package since markdown, used to generate
the doc, randomly obfuscates the email addresses and hence made the -dev
package non multi-arch: same (Closes: #720022, thanks Andreas Beckmann for
spotting this)
* Add to the orig tarball a copy of the LICENSE 
* Fix debian/copyright using Expat instead of MIT/X 
2013-08-09 - Enrico Tassi <gareuselesinge@debian.org>
lua-apr (0.23.2+git-2) unstable; urgency=low
* Build the docs using lua-discount
2012-04-02 - Enrico Tassi <gareuselesinge@debian.org>
lua-apr (0.23.2+git-1) unstable; urgency=low
* Packaging moved to git 
* Remove transitional packages
2012-04-02 - Enrico Tassi <gareuselesinge@debian.org>
lua-apr (0.23.2-1) unstable; urgency=low
* New upstream release
* Switch to dh-lua
* Packages renamed to conform to the new Lua policy
* debian/compat set to 7 
* Update copyright file format
* Standards-Version set to 3.9.3, no changes needed
2011-08-14 - Enrico Tassi <gareuselesinge@debian.org>
lua-apr (0.20.1-1) unstable; urgency=low
* new upstream release
* updated copyright file, mentioning that src/ldap.c is copyright
by the kepler project 
2011-07-20 - Enrico Tassi <gareuselesinge@debian.org>
lua-apr (0.19.8.1-2) unstable; urgency=low
* multi-arch compliant (lua5.1-policy >= 32 and dh >= 8.1.3)
* update standards-version to 3.9.2, no changes
2011-07-02 - Enrico Tassi <gareuselesinge@debian.org>
lua-apr (0.19.8.1-1) unstable; urgency=low
* new upstream release

See Also

Package Description
lua-apr-doc_0.23.2.dfsg-4_all.deb Lua documentation files for the Apache Portable Runtime library
lua-apr_0.23.2.dfsg-4_amd64.deb Apache Portable Runtime library for the Lua language
lua-argparse_0.6.0-1_all.deb feature-rich command line parser for Lua language
lua-augeas_0.1.1-3_amd64.deb Lua binding to the Augeas C API
lua-basexx_0.3-2_all.deb baseXX encoding/decoding library for Lua
lua-bit32-dev_5.3.0-3_amd64.deb Development files for the bit32 library for Lua 5.1
lua-bit32_5.3.0-3_amd64.deb Backport of the Lua 5.2 bit32 library to Lua 5.1
lua-bitop-dev_1.0.2-5_amd64.deb fast bit manipulation library devel files for the Lua language
lua-bitop_1.0.2-5_amd64.deb fast bit manipulation library for the Lua language
lua-busted_2.0~rc12-1-2_all.deb Lua unit testing framework focused on ease of use
lua-cgi_5.2~alpha2-1_all.deb CGI library for the Lua language
lua-check_0.23.0-1_all.deb static analyzer and a linter for the Lua language
lua-cjson-dev_2.1.0+dfsg-2.1_amd64.deb JSON parser/encoder for Lua, development files
lua-cjson_2.1.0+dfsg-2.1_amd64.deb JSON parser/encoder for Lua
lua-cliargs_3.0-2-1_all.deb command-line argument parsing module for Lua
Advertisement
Advertisement