libxfixes-dev_5.0.3-1_amd64.deb


Advertisement

Description

libxfixes-dev - X11 miscellaneous 'fixes' extension library (development headers)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libxfixes-dev_5.0.3-1_amd64.deb
Package name libxfixes-dev
Package version 5.0.3
Package release 1
Package architecture amd64
Package type deb
Category devel::library libdevel role::devel-lib
Homepage -
License -
Maintainer Debian X Strike Force <debian-x@lists.debian.org>
Download size 23.22 KB
Installed size 69.00 KB
libXfixes provides an X Window System client interface to the 'XFIXES'
extension to the X protocol.
It provides support for Region types, and some cursor functions.
This package contains the development headers for the library found in
libxfixes3.  Non-developers likely have little use for this package.
More information about X.Org can be found at:
<URL:https://www.X.org>
This module can be found at
git://anongit.freedesktop.org/git/xorg/lib/libXfixes

Alternatives

Package Version Architecture Repository
libxfixes-dev_5.0.3-1_i386.deb 5.0.3 i386 Debian Main
libxfixes-dev - - -

Requires

Name Value
libx11-dev -
libxfixes3 = 1:5.0.3-1
x11proto-fixes-dev >= 1:5.0-1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libxfixes-dev_5.0.3-1_amd64.deb
Source Package libxfixes

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libxfixes-dev deb package:
    # sudo apt-get install libxfixes-dev

Files

Path
/usr/include/X11/extensions/Xfixes.h
/usr/lib/x86_64-linux-gnu/libXfixes.a
/usr/lib/x86_64-linux-gnu/libXfixes.so
/usr/lib/x86_64-linux-gnu/pkgconfig/xfixes.pc
/usr/share/doc/libxfixes-dev/changelog.Debian.gz
/usr/share/doc/libxfixes-dev/changelog.gz
/usr/share/doc/libxfixes-dev/copyright
/usr/share/man/man3/Xfixes.3.gz

Changelog

2016-12-05 - Emilio Pozuelo Monfort <pochu@debian.org>
libxfixes (1:5.0.3-1) unstable; urgency=medium
[ Andreas Boll ]
* New upstream release.
- Fixes CVE-2016-7944 (Closes: #840442).
* Update d/upstream/signing-key.asc with Matthieu Herrb's key.
* Fix Vcs-* URLs.
* Update a bunch of URLs in packaging to https.
[ Emilio Pozuelo Monfort ]
* Bump debhelper compat to 10.
+ dh-autoreconf is now enabled by default.
+ --disable-silent-rules is passed to configure automatically.
2016-06-26 - Julien Cristau <jcristau@debian.org>
libxfixes (1:5.0.2-1) sid; urgency=medium
* Team upload.
* New upstream release.
* Let uscan verify tarball signatures.
* Bump libx11-dev build-dep to 2:1.6 per configure.ac.
* Remove Drew and Cyril from Uploaders.
* Use https for Vcs-* control fields.
* Bump Standards-Version to 3.9.8.
* Migrate to automatic dbgsym package.
2014-07-12 - Julien Cristau <jcristau@debian.org>
libxfixes (1:5.0.1-2) sid; urgency=low
* Mark libxfixes-dev as Multi-arch: same (closes: #677657).
2013-06-30 - Julien Cristau <jcristau@debian.org>
libxfixes (1:5.0.1-1) sid; urgency=low
* New upstream release.
* Remove useless dh_auto_install override.  debian/tmp is the default destdir
since we have more than one deb.
* Bump debhelper build-dep to 9 (to match compat).
* Disable silent build rules.
2013-05-14 - Julien Cristau <jcristau@debian.org>
libxfixes (1:5.0-4+deb7u1) wheezy-security; urgency=high
* integer overflow in XFixesGetCursorImage() [CVE-2013-1983]
2011-06-12 - Julien Cristau <jcristau@debian.org>
libxfixes (1:5.0-4) unstable; urgency=low
* Team upload.
* Don't include debug symbols for the udeb in libxfixes3-dbg.
2011-06-11 - Julien Cristau <jcristau@debian.org>
libxfixes (1:5.0-3) unstable; urgency=low
* Team upload.
[ Steve Langasek ]
* Build for multiarch.
[ Julien Cristau ]
* Bump Standards-Version to 3.9.2.
2011-04-29 - Julien Cristau <jcristau@debian.org>
libxfixes (1:5.0-2) unstable; urgency=low
[ Julien Cristau ]
* libxfixes3.symbols: no need to use a version for symbols that are there
forever (or close enough).
* Upload to unstable.
[ Cyril Brulebois ]
* Remove automake and libtool build-dep, they're pulled in by
dh-autoreconf.
2011-03-09 - Cyril Brulebois <kibi@debian.org>
libxfixes (1:5.0-1) experimental; urgency=low
* New upstream release:
- Pointer barriers.
* Bump x11proto-fixes-dev build-dep accordingly.
* Bump x11proto-fixes-dev dependency for libxfixes3-dev.
* Wrap Depends fields.
* Add debian/libxfixes3.symbols file.
* Pass -c4 to dh_makeshlibs to ensure updates are noticed.
* Update symbols file, and bump shlibs for new symbols:
- XFixesCreatePointerBarrier
- XFixesDestroyPointerBarrier
* Install manpages through dh_install.
* Use --fail-missing instead of --list-missing in dh_install for
additional safety.
* Switch to dh:
- Use debhelper 8.
- Use dh-autoreconf.
* Remove xsfbs accordingly.
* Update Uploaders list. Thanks, David!
* Add a placeholder series file.
* Bump Standards-Version to 3.9.1 (no changes needed).
2010-07-11 - Julien Cristau <jcristau@debian.org>
libxfixes (1:4.0.5-1) unstable; urgency=low
* New upstream release.
* Bump xutils-dev build-dep for xorg-macros 1.8.
* Update debian/copyright from upstream COPYING.
* Bump Standards-Version to 3.9.0.

See Also

Package Description
libxfixes3_5.0.3-1_amd64.deb X11 miscellaneous 'fixes' extension library
libxfont-dev_2.0.3-1_amd64.deb X11 font rasterisation library (development headers)
libxfont2_2.0.3-1_amd64.deb X11 font rasterisation library
libxft-dev_2.3.2-2_amd64.deb FreeType-based font drawing library for X (development files)
libxft2_2.3.2-2_amd64.deb FreeType-based font drawing library for X
libxgks-dev_2.6.1+dfsg.2-5+b1_amd64.deb X11 Graphical Kernel Subsystem, development files
libxgks2-data_2.6.1+dfsg.2-5_all.deb Font files for the X11 Graphical Kernel Subsystem
libxgks2_2.6.1+dfsg.2-5+b1_amd64.deb X11 Graphical Kernel Subsystem, library
libxi-dev_1.7.9-1_amd64.deb X11 Input extension library (development headers)
libxi6_1.7.9-1_amd64.deb X11 Input extension library
libxine2-all-plugins_1.2.9-1_all.deb xine video/media player library ‒ metapackage for all plugins
libxine2-bin_1.2.9-1+b2_amd64.deb xine video/media player library – binary files
libxine2-console_1.2.9-1+b2_amd64.deb libaa/libcaca/framebuffer/directfb related plugins for libxine2
libxine2-dev_1.2.9-1+b2_amd64.deb xine video player library – development packages
libxine2-doc_1.2.9-1_all.deb xine video player library – documentation files
Advertisement
Advertisement