libuid-wrapper_1.2.4+dfsg1-1_amd64.deb


Advertisement

Description

libuid-wrapper - UID wrapper library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libuid-wrapper_1.2.4+dfsg1-1_amd64.deb
Package name libuid-wrapper
Package version 1.2.4+dfsg1
Package release 1
Package architecture amd64
Package type deb
Category devel
Homepage http://cwrap.org/uid_wrapper.html
License -
Maintainer Debian SSSD Team <pkg-sssd-devel@lists.alioth.debian.org>
Download size 18.80 KB
Installed size 58.00 KB
This is a wrapper for the user, group and hosts NSS API that can
simulate uid switching as a regular user. This is useful for
testsuites that run as a regular user but need to test
privileged functions.
It works as a preload library, which overrides various
system functions.

Alternatives

Package Version Architecture Repository
libuid-wrapper_1.2.4+dfsg1-1_i386.deb 1.2.4+dfsg1 i386 Debian Main
libuid-wrapper - - -

Requires

Name Value
libc6 >= 2.14

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libuid-wrapper_1.2.4+dfsg1-1_amd64.deb
Source Package uid-wrapper

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libuid-wrapper deb package:
    # sudo apt-get install libuid-wrapper

Files

Path
/usr/lib/libuid_wrapper.so
/usr/lib/cmake/uid_wrapper/uid_wrapper-config-version.cmake
/usr/lib/cmake/uid_wrapper/uid_wrapper-config.cmake
/usr/lib/pkgconfig/uid_wrapper.pc
/usr/share/doc/libuid-wrapper/AUTHORS
/usr/share/doc/libuid-wrapper/README
/usr/share/doc/libuid-wrapper/TODO
/usr/share/doc/libuid-wrapper/buildinfo_amd64.gz
/usr/share/doc/libuid-wrapper/changelog.Debian.gz
/usr/share/doc/libuid-wrapper/changelog.gz
/usr/share/doc/libuid-wrapper/copyright
/usr/share/lintian/overrides/libuid-wrapper
/usr/share/man/man1/uid_wrapper.1.gz

Changelog

2018-04-04 - Timo Aaltonen <tjaalton@debian.org>
uid-wrapper (1.2.4+dfsg1-1) unstable; urgency=medium
* New upstream release. (Closes: #894794)
* Bump debhelper compat to 11.
* control: Bump policy to 4.1.3.
* control: Update vcs urls.
2016-09-20 - Timo Aaltonen <tjaalton@debian.org>
uid-wrapper (1.2.1+dfsg1-1) unstable; urgency=medium
* New upstream release.
* patches: Refreshed.
* control: Bump policy to 3.9.8, no changes.
* control: Use https vcs urls.
2015-12-09 - Timo Aaltonen <tjaalton@debian.org>
uid-wrapper (1.2.0+dfsg1-1) unstable; urgency=medium
* New upstream release.
* patches: Remove fix-test-gid.diff, refresh no-soname.diff.
* copyright, watch: Filter obj32/* from the tarball, rename source to
match.
2015-09-04 - Timo Aaltonen <tjaalton@debian.org>
uid-wrapper (1.1.1-1) unstable; urgency=medium
* New upstream release.
* control: Change maintainer, update Vcs. (Closes: #782374)
* patches: no-soname.diff updated, remove-access.patch removed (upstream).
* fix-test-gid.diff: Fix a failing test.
* control: Fix a typo in description.
2014-11-22 - Jelmer Vernooij <jelmer@debian.org>
uid-wrapper (1.0.2-2) unstable; urgency=medium
* Add patch remove-access.patch: remove use of SYS_access not
available on ARM64. Closes: #770307
* Bump standards version to 3.9.6 (no changes).
2014-08-08 - Jelmer Vernooij <jelmer@debian.org>
uid-wrapper (1.0.2-1) unstable; urgency=medium
* New upstream release.
2014-07-22 - Jelmer Vernooij <jelmer@debian.org>
uid-wrapper (1.0.1-1) unstable; urgency=low
* Initial release. Closes: #755557

See Also

Package Description
libuil4_2.3.8-2_amd64.deb Motif - UIL (User Interface Language) shared library
libuim-custom2_1.8.8-4_amd64.deb Universal Input Method - uim-custom API library
libuim-dev_1.8.8-4_amd64.deb Universal Input Method - development files
libuim-scm0_1.8.8-4_amd64.deb Universal Input Method - uim-scm API library
libuim8_1.8.8-4_amd64.deb Universal Input Method - uim library
libuima-adapter-soap-java_2.10.2-3_all.deb Library to provide SOAP web services within UIMA
libuima-adapter-vinci-java_2.10.2-3_all.deb Library to provide Vinci web services within UIMA
libuima-addons-java_2.3.1-8_all.deb Apache UIMA Addons
libuima-as-java-doc_2.3.1-9_all.deb Documentation for Apache UIMA Asynch Scaleout framework
libuima-as-java_2.3.1-9_all.deb Apache UIMA Asynch Scaleout framework
libuima-core-java_2.10.2-3_all.deb Core library for the UIMA framework
libuima-cpe-java_2.10.2-3_all.deb Library for the UIMA Collection Processing Engine
libuima-document-annotation-java_2.10.2-3_all.deb Library for the UIMA document annotation
libuima-tools-java_2.10.2-3_all.deb UIMA library for the UIMA tools
libuima-vinci-java_2.10.2-3_all.deb Library to handle Vinci web service protocol
Advertisement
Advertisement