libtypes-datetime-perl_0.002-1_all.deb


Advertisement

Description

libtypes-datetime-perl - type constraints and coercions for datetime objects

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libtypes-datetime-perl_0.002-1_all.deb
Package name libtypes-datetime-perl
Package version 0.002
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl
Homepage https://metacpan.org/release/Types-DateTime
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 15.41 KB
Installed size 36.00 KB
Types::DateTime is a type constraint library suitable for use with
Moo/Moose attributes, Kavorka sub signatures, and so forth.

Alternatives

Package Version Architecture Repository
libtypes-datetime-perl_0.002-1_all.deb 0.002 all Debian Main
libtypes-datetime-perl - - -

Requires

Name Value
libdatetime-locale-perl >= 1:1
libdatetime-perl -
libdatetime-timezone-perl -
libmodule-runtime-perl -
libtype-tiny-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libtypes-datetime-perl_0.002-1_all.deb
Source Package libtypes-datetime-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtypes-datetime-perl deb package:
    # sudo apt-get install libtypes-datetime-perl

Files

Path
/usr/share/doc/libtypes-datetime-perl/CREDITS
/usr/share/doc/libtypes-datetime-perl/README.gz
/usr/share/doc/libtypes-datetime-perl/buildinfo_all.gz
/usr/share/doc/libtypes-datetime-perl/changelog.Debian.gz
/usr/share/doc/libtypes-datetime-perl/changelog.gz
/usr/share/doc/libtypes-datetime-perl/copyright
/usr/share/man/man3/Types::DateTime.3pm.gz
/usr/share/perl5/Types/DateTime.pm

Changelog

2017-06-21 - Jonas Smedegaard <dr@jones.dk>
libtypes-datetime-perl (0.002-1) unstable; urgency=medium
[ upstream ]
* New release.
+ Fix compatibility with newer DateTime::Locale.
[ Jonas Smedegaard ]
* Fix bugnumber in 0.001-4 changelog entry.
Thanks to Gregor Herrmann.
* Drop patch 1001: Fixed upstream.
* Update copyright info:
+ Extend coverage for main upstream author.
+ Use https protocol in format string.
+ Extend copyright of packaging to cover recent years.
* Modernize git-buildpackage config:
+ Filter any .git* file.
* Modernize cdbs:
+ Stop explicitly suppress versioned build-dependency on debhelper.
+ Do copyright-check in maintainer script (not during build).
+ Stop build-depend on devscripts.
* Stop override lintian for
package-needs-versioned-debhelper-build-depends: Fixed in lintian.
* Declare compliance with Debian Policy 4.0.0.
* Modernize Vcs-* fields:
+ Use https protocol.
+ Use git (not cgit) in path.
* Update watch file:
+ Bump to file format 4.
+ Watch only MetaCPAN URL.
+ Mention gbp --uscan in usage comment.
+ Tighten version regex.
2015-11-21 - Jonas Smedegaard <dr@jones.dk>
libtypes-datetime-perl (0.001-4) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to use cgit web frontend.
[ Jonas Smedegaard ]
* Add patch 1001 to fix tests to pass with both new and old
DateTime::Locale versions.
Closes: Bug#805387. Thanks to Niko Tyni and Dave Rolsky.
* Declare compliance with Debian Policy 3.9.6.
* Update copyright info:
+ Use License-Grant and License-Reference fields.
Thanks to Ben Finney.
+ Extend copyright of packaging to cover current year.
* Add lintian override regarding license in License-Reference field.
See bug#786450.
* Bump debhelper compatibility level to 9.
* Add lintian override regarding debhelper 9.
* Modernize git-buildpackage config: Avoid git- prefix.
* Git-ignore quilt dir.
* Update package relations:
+ Tighten to (build-)depend versioned on libdatetime-locale-perl:
Needed for patch 1001.
+ Relax to (build-)depend unversioned on libtype-tiny-perl: Needed
version satisfied in stable (and unavailable in oldstable).
+ Relax to build-depend unversioned on libmoose-perl: Needed version
satisfied even in oldstable.
2014-05-30 - Jonas Smedegaard <dr@jones.dk>
libtypes-datetime-perl (0.001-3) unstable; urgency=medium
* Update copyright info:
+ Fix cover CONTRIBUTING file.
Thanks to Thorsten Alteholz.
2014-05-17 - Jonas Smedegaard <dr@jones.dk>
libtypes-datetime-perl (0.001-2) unstable; urgency=medium
* Build-depend on libdatetime-format-iso8601-perl and recent
libmoose-perl: Optionally needed for testsuite.
2014-05-17 - Jonas Smedegaard <dr@jones.dk>
libtypes-datetime-perl (0.001-1) unstable; urgency=low
* Initial packaging release.
Closes: bug#747706.

See Also

Package Description
libtypes-path-tiny-perl_0.006-1_all.deb Path::Tiny types and coercions for Moose and Moo
libtypes-serialiser-perl_1.0-1_all.deb module providing simple data types for common serialisation formats
libtypes-uri-perl_0.006-1_all.deb type constraints and coercions for URIs
libtypes-uuid-perl_0.004-1_all.deb type constraints for UUIDs
libtypes-xsd-lite-perl_0.005-1_all.deb type constraints based on a subset of XML schema datatypes
libtypes-xsd-perl_0.005-1_all.deb type constraints based on XML schema datatypes
libtypesafe-config-clojure_0.1.5-1_all.deb Java wrapper around libtypesafe-config-java
libtypesafe-config-java-doc_1.3.1-2_all.deb configuration library for JVM languages - documentation
libtypesafe-config-java_1.3.1-2_all.deb configuration library for JVM languages
libtyxml-ocaml-dev_4.1.0-1+b1_amd64.deb typed XML in OCaml (development files)
libtyxml-ocaml-doc_4.1.0-1_all.deb typed XML in OCaml (documentation)
libtyxml-ocaml_4.1.0-1+b1_amd64.deb typed XML in OCaml (plugins)
libu1db-dev_13.10-6.3_amd64.deb Ubuntu One structured data storage - C API development files
libu1db1_13.10-6.3_amd64.deb Ubuntu One structured data storage - C API
libu2f-host-dev_1.1.9-1_amd64.deb Development files for the U2F host C library libu2f-host
Advertisement
Advertisement