libtss2-tcti-tabrmd-dev_2.1.0-1_amd64.deb


Advertisement

Description

libtss2-tcti-tabrmd-dev - TPM2 Access Broker & Resource Management - static libraries and headers

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libtss2-tcti-tabrmd-dev_2.1.0-1_amd64.deb
Package name libtss2-tcti-tabrmd-dev
Package version 2.1.0
Package release 1
Package architecture amd64
Package type deb
Category devel::library libdevel role::devel-lib
Homepage https://github.com/intel/tpm2-abrmd
License -
Maintainer SZ Lin (林上智) <szlin@debian.org>
Download size 83.31 KB
Installed size 558.00 KB
It is intended for use with the SAPI library (libsapi) like any other TCTI.
The initialization function for this library is hard coded to connect to the
tabrmd on the system bus as this is the most common configuration.
This package contains the required static libraries, headers.

Alternatives

Package Version Architecture Repository
libtss2-tcti-tabrmd-dev_2.1.0-1_i386.deb 2.1.0 i386 Debian Main
libtss2-tcti-tabrmd-dev - - -

Requires

Name Value
libtss2-tcti-tabrmd0 = 2.1.0-1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libtss2-tcti-tabrmd-dev_2.1.0-1_amd64.deb
Source Package tpm2-abrmd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtss2-tcti-tabrmd-dev deb package:
    # sudo apt-get install libtss2-tcti-tabrmd-dev

Files

Path
/usr/include/tss2/tss2-tcti-tabrmd.h
/usr/lib/x86_64-linux-gnu/libtss2-tcti-tabrmd.a
/usr/lib/x86_64-linux-gnu/libtss2-tcti-tabrmd.so
/usr/lib/x86_64-linux-gnu/pkgconfig/tss2-tcti-tabrmd.pc
/usr/share/doc/libtss2-tcti-tabrmd-dev/changelog.Debian.gz
/usr/share/doc/libtss2-tcti-tabrmd-dev/changelog.gz
/usr/share/doc/libtss2-tcti-tabrmd-dev/copyright
/usr/share/man/man3/Tss2_Tcti_Tabrmd_Init.3.gz
/usr/share/man/man7/tss2-tcti-tabrmd.7.gz

Changelog

2019-02-11 - SZ Lin (林上智) <szlin@debian.org>
tpm2-abrmd (2.1.0-1) unstable; urgency=medium
* Import new upstream release (Closes: #902127)
* d/compat:
- Bump compat version to 12
* d/control:
- Bump debhelper version to 12
- Bump Standards-Version to 4.3.0
* d/libtss2-tcti-tabrmd0.symbols:
- Add build depends package field
* Update d/patches:
- Resolve conflict issue with new upstream release
2018-11-13 - SZ Lin (林上智) <szlin@debian.org>
tpm2-abrmd (2.0.3-1) unstable; urgency=medium
* Import new upstream release
* Update symbol table
* Add upstream metadata
* Rename binary package from libtcti-tabrmd* to libtss2-tcti-tabrmd*
* Remove Fix-gdbus-codegen-lookup-for-recent-versions-of-GLib.patch since it
was merged in upstream
* Add Fix-macro-warning-error-by-adding-escaped-symbol.patch
* d/control:
- Bump Standards-Version to 4.2.1
- Add libtss2-dev in Build-Depends (Closes: #913367)
- Remove libsapi-dev from Build-Depends
* d/rules:
- Remove extra file to avoid failure under non-clean build
* d/tpm2-abrmd.install:
- Drop unneeded file
2018-10-10 - Simon McVittie <smcv@debian.org>
tpm2-abrmd (1.3.1-1.1) unstable; urgency=medium
* Non-maintainer upload.
* d/p/0002-Fix-gdbus-codegen-lookup-for-recent-versions-of-GLib.patch:
Apply patch from upstream to make the build system compatible with
recent GLib versions. In older GLib versions,
`$PKG_CONFIG --variable=gdbus_codegen gio-2.0` always returned
"gdbus-codegen", but in newer versions or when GLib was built with
Meson it returns the absolute path to gdbus-codegen, which is not a
valid input to AC_PATH_PROG. (Closes: #910340)
* d/rules: Use dbus-run-session to give unit tests a temporary
session bus. This means that tss2-tcti-tabrmd_unit does not have to
be skipped. (Closes: #910341)
- d/p/0002-remove-unit-test-needs-dbus-daemon.patch:
Remove, no longer needed
2018-05-01 - SZ Lin (林上智) <szlin@debian.org>
tpm2-abrmd (1.3.1-1) unstable; urgency=low
* Initial release (Closes: #885774)

See Also

Package Description
libtss2-tcti-tabrmd0_2.1.0-1_amd64.deb TPM2 Access Broker & Resource Management - shared libraries
libtss2-udev_2.1.0-4_all.deb TPM2 Software stack library - udev files
libttfautohint-dev_1.8.2-1_amd64.deb Automatic font hiner - development files
libttfautohint1_1.8.2-1_amd64.deb Automatic font hiner - library
libtty-dev_0.18-1_amd64.deb terminal/ttyrec library -- development
libtty1_0.18-1_amd64.deb terminal/ttyrec library -- runtime
libtumbler-1-0_0.2.3-1_amd64.deb library for tumbler, a D-Bus thumbnailing service
libtumbler-1-dev_0.2.3-1_amd64.deb library for tumbler, a D-Bus thumbnailing service (development)
libturbojpeg0-dev_1.5.2-2+b1_amd64.deb Development files for the TurboJPEG library
libturbojpeg0_1.5.2-2+b1_amd64.deb TurboJPEG runtime library - SIMD optimized
libtut-dev_0.0.20070706-2_all.deb elegant C++ unit test framework
libtuxcap-dev_1.4.0.dfsg2-2.3+b3_amd64.deb framework for developing 2D games - development files
libtuxcap4.0_1.4.0.dfsg2-2.3+b3_amd64.deb framework for developing 2D games - runtime libraries
libtwatch-perl_0.0.7-1_all.deb watch torrent trackers and automatically download new torrents
libtweeny-dev_3-1_all.deb modern C++ tweening library
Advertisement
Advertisement