libsox-fmt-ao_14.4.2+git20190427-1_amd64.deb


Advertisement

Description

libsox-fmt-ao - SoX Libao format I/O library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libsox-fmt-ao_14.4.2+git20190427-1_amd64.deb
Package name libsox-fmt-ao
Package version 14.4.2+git20190427
Package release 1
Package architecture amd64
Package type deb
Category implemented-in::c role::shared-lib sound works-with::audio
Homepage https://sox.sourceforge.io/
License -
Maintainer Debian Multimedia Maintainers <debian-multimedia@lists.debian.org>
Download size 47.02 KB
Installed size 81.00 KB
SoX is the swiss army knife of sound processing.
This package contains the SoX Libao format I/O library.
libao: https://xiph.org/ao

Alternatives

Package Version Architecture Repository
libsox-fmt-ao_14.4.2+git20190427-1_i386.deb 14.4.2+git20190427 i386 Debian Main
libsox-fmt-ao - - -

Requires

Name Value
libao4 >= 1.1.0
libc6 >= 2.2.5
libsox3 >= 14.4.2~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libsox-fmt-ao_14.4.2+git20190427-1_amd64.deb
Source Package sox

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsox-fmt-ao deb package:
    # sudo apt-get install libsox-fmt-ao

Files

Path
/usr/lib/x86_64-linux-gnu/sox/libsox_fmt_ao.so
/usr/share/bug/libsox-fmt-ao/presubj
/usr/share/doc/libsox-fmt-ao/changelog.Debian.gz
/usr/share/doc/libsox-fmt-ao/changelog.gz
/usr/share/doc/libsox-fmt-ao/copyright

Changelog

2019-04-27 - Tiago Bortoletto Vaz <tiago@debian.org>
sox (14.4.2+git20190427-1) unstable; urgency=medium
* Add patches to fix CVE-2019-8354, CVE-2019-8355, CVE-2019-8356 and
CVE-2019-8357. Thanks to Moritz Muehlenhoff. (Closes: #927906)
2017-12-18 - Jaromír Mikeš <mira.mikes@seznam.cz>
sox (14.4.2-3) unstable; urgency=medium
* Patch 0005 refreshed. (Closes: #882599)
* Improve english in d/bug-presubj file. (Closes: #882601)
* Bump Standards.
* Use secure uri where possible.
2017-11-24 - Jaromír Mikeš <mira.mikes@seznam.cz>
sox (14.4.2-2) unstable; urgency=medium
* Upload to unstable to start transition.
* Add patch to fix CVE-2017-15372. (Closes: #878808)
* Add patch to fix CVE-2017-15642. (Closes: #882144)
* Add patch to fix CVE-2017-11333 in vorbis lib. (Closes: #882236)
2017-11-19 - Jaromír Mikeš <mira.mikes@seznam.cz>
sox (14.4.2-1) experimental; urgency=medium
[ Jaromír Mikeš ]
* New upstream version 14.4.2 (Closes: #800344)
* Set compat/dh 10.
* Bump Standards.
* Adopt package.(Closes: #876904)
* Update Homepage to avoid redirecting.
* Update Vcs entry.
* Improve description of dev package.
* Drop unused patches.
* Delete dirs files.
* Simplify install files.
* Simplify rules file.
* Set hardening all.
* Try avoid useless linking.
* Update copyright file.
* Introduce symbols file.
* Bump soname.
* Use secure uri in watch file.
* Introduce postclone.sh script.
* Add patch to fix build.
* Add patch to fix spelling.
* Add patches to fix CVE's.
(Closes: #878809) (Closes: #878810) (Closes: #870328)
* Add gbp.conf.
* Add override_dh_installchangelogs.
* Remove old configure option.
* override_dh_makeshlibs is not needed any more.
* Add 0010-wavpack_check_errors.patch. (Closes: #881145)
* Add bug-presubj file.
* Add man page fixing patch.
* Add xa-validate-channel-count patch. (Closes: #881121)
[ Sebastian Ramacher ]
* Remove shlibs file, symbols file already present
2014-12-24 - Pascal Giard <pascal@debian.org>
sox (14.4.1-5) unstable; urgency=medium
* Patches to fix memory corruptions on the heap, CVE-2014-8145
(closes: #773720):
+ 0001-Check-for-minimum-size-sphere-headers.patch
+ 0002-More-checks-for-invalid-MS-ADPCM-blocks.patch
2014-05-21 - Pascal Giard <pascal@debian.org>
sox (14.4.1-4) unstable; urgency=low
* [debian/rules,debian/control]:
- Build with dh-autoreconf instead of autotools-dev to fix FTBFS on new
architectures. Thanks to William Grant <wgrant@ubuntu.com> and Breno
Leitao <brenohl@br.ibm.com> (Closes: #746517).
* [debian/control]:
- Remove useless build-dep on libav* (Closes: #748049).
2013-04-15 - Pascal Giard <pascal@debian.org>
sox (14.4.1-3) unstable; urgency=low
* [debian/rules]:
- Added an explicit call to dh_installchangelogs as Ubuntu no longer does
does it by default. It's important for us as it contains the list of
past contributors.
* [debian/docs]:
- Fixed paths to files.
2013-02-22 - Pascal Giard <pascal@debian.org>
sox (14.4.1-2) unstable; urgency=low
* [debian/libsox-fmt-base.install.in]:
- Added all missing sndfile-derived formats. Thanks to Ulrich Klauer
<ulrich@chirlu.de> for the patch (LP: #1086889).
* [debian/control]:
- Removed duplicate section field for sox. Fixes lintian warning.
- Added Build-Dep on autotools-dev for dh_autotools_dev.
* [debian/rules]:
- Use dh_autotools_dev to update the outdated autotools helper files.
Fixes lintian warning.

See Also

Package Description
libsox-fmt-base_14.4.2+git20190427-1_amd64.deb Minimal set of SoX format libraries
libsox-fmt-mp3_14.4.2+git20190427-1_amd64.deb SoX MP2 and MP3 format library
libsox-fmt-oss_14.4.2+git20190427-1_amd64.deb SoX OSS format I/O library
libsox-fmt-pulse_14.4.2+git20190427-1_amd64.deb SoX PulseAudio format I/O library
libsox3_14.4.2+git20190427-1_amd64.deb SoX library of audio effects and processing
libsoxr-dev_0.1.2-3_amd64.deb High quality 1D sample-rate conversion library (development files)
libsoxr-lsr0_0.1.2-3_amd64.deb High quality 1D sample-rate conversion library (libsamplerate bindings)
libsoxr0_0.1.2-3_amd64.deb High quality 1D sample-rate conversion library
libspa-bluetooth_0.2.5-1_amd64.deb libraries for the PipeWire multimedia server - bluetooth plugins
libspa-ffmpeg_0.2.5-1_amd64.deb libraries for the PipeWire multimedia server - ffmpeg plugins
libspa-lib-0.1-dev_0.2.5-1_amd64.deb libraries for the PipeWire multimedia server Simple Plugin API - development
libspandsp-dev_0.0.6+dfsg-2_amd64.deb Telephony signal processing library - development headers
libspandsp-doc_0.0.6+dfsg-2_all.deb Documentation for the spandsp signal processing library
libspandsp2_0.0.6+dfsg-2_amd64.deb Telephony signal processing library
libsparkline-php_0.2-7_all.deb sparkline graphing library for php
Advertisement
Advertisement