libperinci-sub-util-perl_0.46-1_all.deb


Advertisement

Description

libperinci-sub-util-perl - Perl module that is a helper to write functions

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libperinci-sub-util-perl_0.46-1_all.deb
Package name libperinci-sub-util-perl
Package version 0.46
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl
Homepage https://metacpan.org/release/Perinci-Sub-Util
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 19.42 KB
Installed size 58.00 KB
Perinci::Sub::Util is a helper to write functions. This module could help with
handling errors, where the application can be killed or just throw some warn,
generate stub functions and be used as a caller.

Alternatives

Package Version Architecture Repository
libperinci-sub-util-perl_0.46-1_all.deb 0.46 all Debian Main
libperinci-sub-util-perl - - -

Requires

Name Value
libfunction-fallback-coreorpp-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libperinci-sub-util-perl_0.46-1_all.deb
Source Package libperinci-sub-util-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libperinci-sub-util-perl deb package:
    # sudo apt-get install libperinci-sub-util-perl

Files

Path
/usr/share/doc/libperinci-sub-util-perl/changelog.Debian.gz
/usr/share/doc/libperinci-sub-util-perl/changelog.gz
/usr/share/doc/libperinci-sub-util-perl/copyright
/usr/share/man/man3/Perinci::Sub::Util.3pm.gz
/usr/share/man/man3/Perinci::Sub::Util::Args.3pm.gz
/usr/share/man/man3/Perinci::Sub::Util::ResObj.3pm.gz
/usr/share/man/man3/Perinci::Sub::Util::Sort.3pm.gz
/usr/share/perl5/Perinci/Sub/Util.pm
/usr/share/perl5/Perinci/Sub/Util/Args.pm
/usr/share/perl5/Perinci/Sub/Util/ResObj.pm
/usr/share/perl5/Perinci/Sub/Util/Sort.pm

Changelog

2017-06-21 - Lucas Kanashiro <kanashiro@debian.org>
libperinci-sub-util-perl (0.46-1) unstable; urgency=medium
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: use HTTPS for GitHub URLs.
[ Lucas Kanashiro ]
* New upstream version 0.46
* Update years of upstream copyright
* Update Debian packaging copyright
* Bump debhelper compatibility level to 10
* Declare compliance with Debian Policy 4.0.0
* Remove explicit build dependency on libtest-simple-perl 0.98
* debian/control: update uploader's email address
2016-02-21 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libperinci-sub-util-perl (0.45-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ Lucas Kanashiro ]
* Import upstream version 0.45
* d/u/metadata: update repository links
* Update years of upstream copyright
* Update years of Debian packaging copyright
* Declare compliance with Debian policy 3.9.7
2016-01-14 - gregor herrmann <gregoa@debian.org>
libperinci-sub-util-perl (0.44-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.44
* Drop pod.patch. The patched file is now (fixed and) in a different
package.
* Update (build) dependencies.
2016-01-13 - gregor herrmann <gregoa@debian.org>
libperinci-sub-util-perl (0.43-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.43
* Add new (build) dependencies.
* Add patch to fix manpage-has-bad-whatis-entry issue.
2015-12-08 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libperinci-sub-util-perl (0.42-1) unstable; urgency=low
* Initial Release. (Closes: #807450)

See Also

Package Description
libperinci-sub-util-propertymodule-perl_0.46-1_all.deb module to detect which property modules are used with Perinci
libperl-critic-freenode-perl_0.028-1_all.deb Perl::Critic policies inspired by #perl on freenode IRC
libperl-critic-perl_1.132-1_all.deb Perl module to critique code for best practices
libperl-critic-policy-variables-prohibitlooponhash-perl_0.007-1_all.deb Perl::Critic policy to avoid writing loops on hashes
libperl-critic-pulp-perl_96-1_all.deb add-on policies for Perl::Critic
libperl-destruct-level-perl_0.02-2+b6_amd64.deb Perl module to change Perl's destruction level
libperl-dev_5.28.1-6_amd64.deb Perl library: development files
libperl-metrics-simple-perl_0.18-1_all.deb module to provide metrics of Perl code
libperl-minimumversion-perl_1.38-2_all.deb module to determine minimum required version of perl required
libperl-osnames-perl_0.11-1_all.deb Perl module to list possible $^O ($OSNAME) values with description
libperl-prereqscanner-perl_1.023-1_all.deb module for extracting prerequisites from Perl code
libperl-version-perl_1.013-2_all.deb module to parse and manipulate Perl version strings
libperl4-corelibs-perl_0.004-1_all.deb libraries historically supplied with Perl 4
libperl4caml-ocaml-dev_0.9.5-5+b4_amd64.deb Use Perl code in OCaml programs, development files
libperl4caml-ocaml-doc_0.9.5-5_all.deb Use Perl code in OCaml programs, documentation
Advertisement
Advertisement