libpbbam0.19.0_0.19.0+dfsg-4_amd64.deb


Advertisement

Description

libpbbam0.19.0 - Pacific Biosciences binary alignment/map (BAM) library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libpbbam0.19.0_0.19.0+dfsg-4_amd64.deb
Package name libpbbam0.19.0
Package version 0.19.0+dfsg
Package release 4
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://pbbam.readthedocs.org/en/latest/index.html
License -
Maintainer Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>
Download size 538.33 KB
Installed size 1.93 MB
The BAM format is a binary, compressed, record-oriented container format
for raw or aligned sequence reads. The associated SAM format is a text
representation of the same data. The specifications for BAM/SAM are maintained
by the SAM/BAM Format Specification Working Group.
PacBio-produced BAM files are fully compatible with the BAM specification,
but makes use of the extensibility mechanisms of the BAM specification to
encode PacBio-specific information. The pbbam library provides tools to
work with these files

Alternatives

Package Version Architecture Repository
libpbbam0.19.0 - - -

Requires

Name Value
libc6 >= 2.25
libgcc1 >= 1:3.0
libhts2 >= 1.3
libstdc++6 >= 5.2

Replaces

Name Value
libpbbam -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libpbbam0.19.0_0.19.0+dfsg-4_amd64.deb
Source Package pbbam

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpbbam0.19.0 deb package:
    # sudo apt-get install libpbbam0.19.0

Files

Path
/usr/lib/x86_64-linux-gnu/libpbbam.so.0.19.0
/usr/share/doc/libpbbam0.19.0/changelog.Debian.gz
/usr/share/doc/libpbbam0.19.0/changelog.gz
/usr/share/doc/libpbbam0.19.0/copyright

Changelog

2019-02-06 - Andreas Tille <tille@debian.org>
pbbam (0.19.0+dfsg-4) unstable; urgency=medium
* Team upload.
[ Steve Langasek ]
* Fix autopkgtest on different architectures
[ Andreas Tille ]
* Cleanup d/rules
* No "Provides: libpbbam" due to ABI incompatibility
2019-02-04 - Andreas Tille <tille@debian.org>
pbbam (0.19.0+dfsg-3) unstable; urgency=medium
* Team upload.
[ Steve Langasek ]
* Fix build dir name for tests
Closes: #909071
2019-02-03 - Andreas Tille <tille@debian.org>
pbbam (0.19.0+dfsg-2) unstable; urgency=medium
* Team upload.
[ Steve Langasek ]
* Provide generated files to autopkgtest
Closes: #921122
[ Andreas Tille ]
* debhelper 12
* Standards-Version: 4.3.0
* Secure URI in copyright format
* Remove trailing whitespace in debian/copyright
2018-10-10 - Andreas Tille <tille@debian.org>
pbbam (0.19.0+dfsg-1) unstable; urgency=medium
* Team upload.
* New upstream version
* Fix samtools call in tests
* d/control: Bump (fake) SOVERSION (=release version)
2018-10-03 - Andreas Tille <tille@debian.org>
pbbam (0.18.0+dfsg-2) unstable; urgency=medium
* Team upload.
* Missing Breaks+Replaces: libpbbam (<< 0.18)
Closes: #910206
* No needs-recommends restrictions, just Test-Depends: samtools
2018-09-06 - Andreas Tille <tille@debian.org>
pbbam (0.18.0+dfsg-1) unstable; urgency=medium
[ Andreas Tille ]
* Team upload.
* New upstream version
* Upstream is now tagging releases -> adapt watch file
* Upstream switched from cmake to meson
* debhelper 11
* Point Vcs fields to salsa.debian.org
* Standards-Version: 4.2.1
* Use d-shlibs
* Remove unneeded trigger
* Respect DEB_BUILD_OPTIONS in override_dh_auto_test
* hardening=+all
* Add Breaks/Provides/Replaces libpbbam
[ Fabian Kloetzl ]
* fix dependency check for meson
2017-01-21 - Afif Elghraoui <afif@debian.org>
pbbam (0.7.4+ds-1) unstable; urgency=medium
* New upstream release snapshot
- Exclude dependency convenience copy
- Update patches
- Update running of tests at build-time
- Update .install files
- Update autopkgtest commands
* Use debhelper compat 10
* libpbbam-dev: depend on libssl-dev
2016-10-30 - Afif Elghraoui <afif@debian.org>
pbbam (0.7.0-1) unstable; urgency=medium
* Imported Upstream version 0.7.0
* Update patches
2016-10-23 - Afif Elghraoui <afif@debian.org>
pbbam (0.5.0-3) unstable; urgency=low
* Fix cmake arguments to properly position LDFLAGS for -Wl,--as-needed.
Thanks to Steve Langasek (Closes: #841671)
2016-07-17 - Afif Elghraoui <afif@debian.org>
pbbam (0.5.0-2) unstable; urgency=low
* libpbbam-dev: add dependency on libhts-dev

See Also

Package Description
libpbcopper-dev_0.4.1+dfsg-2_amd64.deb data structures, algorithms, and utilities for C++ applications -- header files
libpbdata-dev_5.3.1+dfsg-2.1_amd64.deb tools for handling PacBio sequences (development files)
libpbdata_5.3.1+dfsg-2.1_amd64.deb tools for handling PacBio sequences
libpbihdf-dev_5.3.1+dfsg-2.1_amd64.deb tools for handling PacBio hdf5 files (development files)
libpbihdf_5.3.1+dfsg-2.1_amd64.deb tools for handling PacBio hdf5 files
libpbkdf2-tiny-perl_0.005-2_all.deb Minimalist PBKDF2 (RFC 2898) with HMAC-SHA1 or HMAC-SHA2
libpbseq-dev_5.3.1+dfsg-2.1_all.deb library for analyzing PacBio sequencing data (development files)
libpbseq_5.3.1+dfsg-2.1_all.deb library for analyzing PacBio sequencing data
libpcap-dev_1.8.1-6_amd64.deb development library for libpcap (transitional package)
libpcap0.8-dev_1.8.1-6_amd64.deb development library and header files for libpcap0.8
libpcap0.8_1.8.1-6_amd64.deb system interface for user-level packet capture
libpcaudio-dev_1.1-3_amd64.deb C API to different audio devices - development files
libpcaudio0_1.1-3_amd64.deb C API to different audio devices - shared library
libpcc-dev_1.2.0~DEVEL+20180604-2.1_amd64.deb Portable C Compiler (development files)
libpcg-cpp-dev_0.98.1-2_all.deb compile-time library for PCG random number generation
Advertisement
Advertisement