libpam-ldapd_0.9.10-2_amd64.deb


Advertisement

Description

libpam-ldapd - PAM module for using LDAP as an authentication service

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libpam-ldapd_0.9.10-2_amd64.deb
Package name libpam-ldapd
Package version 0.9.10
Package release 2
Package architecture amd64
Package type deb
Category admin admin::login admin::user-management implemented-in::c protocol::ldap role::plugin role::program security::authentication use::configuring use::login
Homepage https://arthurdejong.org/nss-pam-ldapd/
License -
Maintainer Arthur de Jong <adejong@debian.org>
Download size 57.10 KB
Installed size 98.00 KB
This package provides a Pluggable Authentication Module that provides user
authentication, authorization and password management based on credentials
stored in an LDAP server.

Alternatives

Package Version Architecture Repository
libpam-ldapd_0.9.10-2_i386.deb 0.9.10 i386 Debian Main
libpam-ldapd - - -

Requires

Name Value
libc6 >= 2.17
libpam-runtime >= 1.0.1-6
libpam0g >= 1.1.3-2
nslcd >= 0.9.0
nslcd-2 -

Provides

Name Value
libpam-ldap -

Conflicts

Name Value
libpam-ldap -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libpam-ldapd_0.9.10-2_amd64.deb
Source Package nss-pam-ldapd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpam-ldapd deb package:
    # sudo apt-get install libpam-ldapd

Files

Path
/lib/x86_64-linux-gnu/security/pam_ldap.so
/usr/share/doc/libpam-ldapd/NEWS.Debian.gz
/usr/share/doc/libpam-ldapd/changelog.Debian.gz
/usr/share/doc/libpam-ldapd/changelog.gz
/usr/share/doc/libpam-ldapd/copyright
/usr/share/man/man8/pam_ldap.8.gz
/usr/share/pam-configs/ldap

Changelog

2019-01-20 - Arthur de Jong <adejong@debian.org>
nss-pam-ldapd (0.9.10-2) unstable; urgency=medium
[ Arthur de Jong ]
* Fix crash in chsh.ldap (closes: 908319)
* Make signing key minimal (thanks lintian)
* Upgrade to standards-version 4.3.0 (no changes needed)
* Remove code that handled upgrades from pre-0.9 versions of nss-pam-ldapd
[ Sunil Mohan Adapa ]
* Change ca-certificates as dependency instead of recommends since
initial configuration uses certificates (closes: #877002).
2018-09-02 - Arthur de Jong <adejong@debian.org>
nss-pam-ldapd (0.9.10-1) unstable; urgency=medium
* New upstream release:
- make password expiry messages correct and consistent (thanks Têko
Mihinto)
- add domain variable for use in pam_authz_search
- allow logging longer lines
- create nslcd socket after dropping privileges to avoid slow start-ups
* Set Vcs-* to salsa.debian.org
* Upgrade to standards-version 4.2.1 (no changes needed)
2018-02-19 - Arthur de Jong <adejong@debian.org>
nss-pam-ldapd (0.9.9-1) unstable; urgency=medium
* new upstream release:
- support spaces in attribute mapping expressions
- allow parsing longer lines in the configuration file
- allow for longer host names (closes: #890508)
* upgrade to debhelper compatibility level 7
* upgrade to standards-version 4.1.3 (change package priority to optional)
* do not run test suite if DEB_BUILD_OPTIONS contains nocheck
2017-06-27 - Arthur de Jong <adejong@debian.org>
nss-pam-ldapd (0.9.8-1) unstable; urgency=medium
* new upstream release:
- add a pam_authc_search option that can be used to configure the search
operation that is performed after authentication
- add nss_uid_offset and nss_gid_offset options that can be used to
change returned numeric user and group ids from LDAP (thanks Seth
Wright)
- do not retry failed user password on second LDAP server
- the validnames option now also applies to shadow lookups
- support ethernet addresses in LDAP in compact and long formats
- improvements to getent.ldap command (a few minor bug fixes and
preparations for Python 3 support)
- log entries and lookups failing nss_min_uid at debug level
* update links to use HTTPS
* remove --no-create-home from adduser to hide a few warnings
(closes: #858826)
* remove pie from hardening blacklist because it is no longer needed for
stretch (thanks Adrian Bunk) (closes: #859432)
* update debian/copyright
* upgrade to standards-version 4.0.0 (no changes needed)
2017-01-22 - Arthur de Jong <adejong@debian.org>
nss-pam-ldapd (0.9.7-2) unstable; urgency=medium
* recommend ca-certificate which is needed due to adding tls_cacertfile by
default (see #750949) and the checking of tls_cacertfile in 0.9.7
(closes: #836720)
* fix parsing of nslcd.conf tls_cacert option in package configuration
(closes: #851564)
* add dependency on lsb-base for init script (thanks lintian)

See Also

Package Description
libpam-mklocaluser_0.14_all.deb Configure PAM to create a local user if it do not exist already
libpam-modules-bin_1.3.1-5_amd64.deb Pluggable Authentication Modules for PAM - helper binaries
libpam-modules_1.3.1-5_amd64.deb Pluggable Authentication Modules for PAM
libpam-mount-bin_2.16-9_amd64.deb PAM module that can mount volumes for a user session - helper
libpam-mount_2.16-9_amd64.deb PAM module that can mount volumes for a user session
libpam-mysql_0.8.1-1+b1_amd64.deb PAM module interfacing with MySQL databases
libpam-oath_2.6.1-1.3_amd64.deb OATH Toolkit libpam_oath PAM module
libpam-ocaml-dev_1.1-5+b1_amd64.deb OCaml bindings for the PAM library (development files)
libpam-ocaml_1.1-5+b1_amd64.deb OCaml bindings for the PAM library (runtime)
libpam-otpw_1.5-2_amd64.deb Use OTPW for PAM authentication
libpam-p11_0.2.0-2_amd64.deb PAM module for using PKCS#11 smart cards
libpam-passwdqc_1.3.0-1+b1_amd64.deb PAM module for password strength policy enforcement
libpam-pkcs11_0.6.9-3+b1_amd64.deb Fully featured PAM module for using PKCS#11 smart cards
libpam-poldi_0.4.2+git20161115.553060d-1_amd64.deb PAM module allowing authentication using a OpenPGP smartcard
libpam-pwdfile_1.0-1+b1_amd64.deb PAM module allowing authentication via an /etc/passwd-like file
Advertisement
Advertisement