libntl35_10.5.0-2_amd64.deb


Advertisement

Description

libntl35 - Number Theory Library, shared library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libntl35_10.5.0-2_amd64.deb
Package name libntl35
Package version 10.5.0
Package release 2
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://www.shoup.net/ntl/
License -
Maintainer Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Download size 674.61 KB
Installed size 2.21 MB
NTL is a high-performance, portable C++ library providing
data structures and algorithms for manipulating signed,
arbitrary length integers, and for vectors, matrices,
and polynomials over the integers and over finite fields.
This package contains the NTL shared library.

Alternatives

Package Version Architecture Repository
libntl35_10.5.0-2_i386.deb 10.5.0 i386 Debian Main
libntl35 - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
libgf2x1 -
libgmp10 -
libstdc++6 >= 5.2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libntl35_10.5.0-2_amd64.deb
Source Package ntl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libntl35 deb package:
    # sudo apt-get install libntl35

Files

Path
/usr/lib/libntl.so.35
/usr/lib/libntl.so.35.0.0
/usr/share/doc/libntl35/changelog.Debian.gz
/usr/share/doc/libntl35/copyright

Changelog

2018-01-05 - Ximin Luo <infinity0@debian.org>
ntl (10.5.0-2) unstable; urgency=medium
* Team upload.
* Upload to unstable.
2018-01-03 - Ximin Luo <infinity0@debian.org>
ntl (10.5.0-1) experimental; urgency=medium
* Team upload.
[ Julien Puydt ]
* New upstream release.
* Bump dh compat to 10.
* Bump std-ver to 4.0.1.
* Bump d/watch to version 4.
* Remove obsolete patch (MIPS and gcc 4.5)
* Refresh the patch for typos.
* Rewrote d/copyright since upstream license changed.
* Follow the soname bump from 27 to 35.
* Enable linking to gf2x (Closes: #872711).
[ Ximin Luo ]
* Don't set MAKEFLAGS. Together with the incompletely-duplicated dependency
information in d/rules, it was causing subtle miscompilations which
resulted in test failures on other packages (FLINT). See "Recursive Make
considered harmful" for a description of this general problem.
* Rewrite d/rules in modern debhelper style, removing the bad dependency
information in the process.
* Update to new Standards-Version.
+ Priority of libntl-dev changed from extra to optional.
2016-07-06 - Julien Puydt <julien.puydt@laposte.net>
ntl (9.9.1-3) unstable; urgency=medium
* disable NATIVE to fix illegal instruction problems
2016-07-03 - Julien Puydt <julien.puydt@laposte.net>
ntl (9.9.1-2) unstable; urgency=medium
* upload to unstable for transition
2016-06-08 - Julien Puydt <julien.puydt@laposte.net>
ntl (9.9.1-1) experimental; urgency=medium
* new upstream release
* rework d/copyright
* upstream's soname is now up to libntl27
2016-06-01 - Julien Puydt <julien.puydt@laposte.net>
ntl (9.9.0-1) experimental; urgency=medium
* new upstream release
* drop the MD5 patch (obsolete)
* drop the sage callback patch (obsolete)
* push standards-version up
* rewrite Vcs-* fields (use https)
* upstream's soname is now up to libntl26
2014-08-26 - Julien Puydt <julien.puydt@laposte.net>
ntl (6.2.1-1) unstable; urgency=low
[Julien Puydt]
* new upstream relase (Closes: 758006)
* added myself to uploaders
* upstream configure doesn't know about CFLAGS anymore
* upstream's soname is now up to libntl5
* build-depend on libtool-bin since that is what the build
system uses (Closes: #761780)
* remove the symbols file (it's a pain to keep up to date
for ridiculous return on investment)
* work on d/copyright
2012-05-15 - Bernhard R. Link <brlink@debian.org>
ntl (5.5.2-2) unstable; urgency=low
* add more optional symbols to avoid
failure with g++-4.7 (Closes: 667300)
* increase Standards-Version
2012-02-11 - Bernhard R. Link <brlink@debian.org>
ntl (5.5.2-1) unstable; urgency=low
* this is still a preview, but most likely already complete
* moved to debian-science team as new maintainer
- old uploader removed so no longer misspelled (Closes: 512636)
[ Bernhard R. Link ]
* upstream uses libtool with proper soname, so it's libntl0 now
* repackage using plain debhelper instead of cdbs
* "3.0 (quilt)" format source package
* include documentation to -dev package (Closes: 585158)
* add a symbols file
[ Felix Salfelder ]
* debian/copyright
2011-05-09 - Aurelien Jarno <aurel32@debian.org>
ntl (5.4.2-4.1) unstable; urgency=low
* Non-maintainer upload.
* Fix gcc-4.5 FTBFS on mips, due to old assembly constraints usage
(Closes: #623162).

See Also

Package Description
libntlm0-dev_1.5-1_amd64.deb Development files for the NTLM authentication library
libntlm0_1.5-1_amd64.deb NTLM authentication library
libntrack-dev_016-1.4_amd64.deb Development package for ntrack
libntrack-glib-dev_016-1.4_amd64.deb development package for libntrack glib API
libntrack-glib2_016-1.4_amd64.deb glib API for ntrack
libntrack-gobject-dev_016-1.4_amd64.deb Development package for libntrack-gobject API
libntrack-gobject1_016-1.4_amd64.deb GObject API for ntrack
libntrack-qt4-1_016-1.4_amd64.deb Qt 4 API for ntrack
libntrack-qt4-dev_016-1.4_amd64.deb Development package for libntrack-qt4
libntrack0_016-1.4_amd64.deb lightweight connectivity tracking library
libntru-0.5-dev_0.5-2_amd64.deb C implementation of the public-key encryption scheme NTRUEncrypt
libntru-0.5_0.5-2_amd64.deb C implementation of the public-key encryption scheme NTRUEncrypt
libnucleotidelikelihoodcore0_1.10.4+dfsg-1_amd64.deb implementation of LikelihoodCore for nucleotides used by beast-mcmc
libnuget-core-cil-dev_2.8.7+md510+dhx1-1_all.deb Package manager for NuGet repos - development
libnuget-core-cil_2.8.7+md510+dhx1-1_all.deb Package manager for NuGet repos - library
Advertisement
Advertisement