libnss-ldapd_0.9.10-2_amd64.deb


Advertisement

Description

libnss-ldapd - NSS module for using LDAP as a naming service

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libnss-ldapd_0.9.10-2_amd64.deb
Package name libnss-ldapd
Package version 0.9.10
Package release 2
Package architecture amd64
Package type deb
Category admin admin::user-management implemented-in::c protocol::ldap role::plugin role::program security::authentication use::configuring
Homepage https://arthurdejong.org/nss-pam-ldapd/
License -
Maintainer Arthur de Jong <adejong@debian.org>
Download size 68.11 KB
Installed size 152.00 KB
This package provides a Name Service Switch module that allows using an LDAP
server to provide user account, group, host name, alias, netgroup, and
basically any other information that would normally be retrieved from /etc
flat files or NIS.

Alternatives

Package Version Architecture Repository
libnss-ldapd_0.9.10-2_i386.deb 0.9.10 i386 Debian Main
libnss-ldapd - - -

Requires

Name Value
debconf >= 0.5
debconf-2.0 -
libc6 >= 2.17
nslcd >= 0.9.0
nslcd-2 -

Provides

Name Value
libnss-ldap -

Conflicts

Name Value
libnss-ldap -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libnss-ldapd_0.9.10-2_amd64.deb
Source Package nss-pam-ldapd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libnss-ldapd deb package:
    # sudo apt-get install libnss-ldapd

Files

Path
/lib/x86_64-linux-gnu/libnss_ldap.so.2
/usr/share/doc/libnss-ldapd/NEWS.Debian.gz
/usr/share/doc/libnss-ldapd/changelog.Debian.gz
/usr/share/doc/libnss-ldapd/changelog.gz
/usr/share/doc/libnss-ldapd/copyright
/usr/share/lintian/overrides/libnss-ldapd

Changelog

2019-01-20 - Arthur de Jong <adejong@debian.org>
nss-pam-ldapd (0.9.10-2) unstable; urgency=medium
[ Arthur de Jong ]
* Fix crash in chsh.ldap (closes: 908319)
* Make signing key minimal (thanks lintian)
* Upgrade to standards-version 4.3.0 (no changes needed)
* Remove code that handled upgrades from pre-0.9 versions of nss-pam-ldapd
[ Sunil Mohan Adapa ]
* Change ca-certificates as dependency instead of recommends since
initial configuration uses certificates (closes: #877002).
2018-09-02 - Arthur de Jong <adejong@debian.org>
nss-pam-ldapd (0.9.10-1) unstable; urgency=medium
* New upstream release:
- make password expiry messages correct and consistent (thanks Têko
Mihinto)
- add domain variable for use in pam_authz_search
- allow logging longer lines
- create nslcd socket after dropping privileges to avoid slow start-ups
* Set Vcs-* to salsa.debian.org
* Upgrade to standards-version 4.2.1 (no changes needed)
2018-02-19 - Arthur de Jong <adejong@debian.org>
nss-pam-ldapd (0.9.9-1) unstable; urgency=medium
* new upstream release:
- support spaces in attribute mapping expressions
- allow parsing longer lines in the configuration file
- allow for longer host names (closes: #890508)
* upgrade to debhelper compatibility level 7
* upgrade to standards-version 4.1.3 (change package priority to optional)
* do not run test suite if DEB_BUILD_OPTIONS contains nocheck
2017-06-27 - Arthur de Jong <adejong@debian.org>
nss-pam-ldapd (0.9.8-1) unstable; urgency=medium
* new upstream release:
- add a pam_authc_search option that can be used to configure the search
operation that is performed after authentication
- add nss_uid_offset and nss_gid_offset options that can be used to
change returned numeric user and group ids from LDAP (thanks Seth
Wright)
- do not retry failed user password on second LDAP server
- the validnames option now also applies to shadow lookups
- support ethernet addresses in LDAP in compact and long formats
- improvements to getent.ldap command (a few minor bug fixes and
preparations for Python 3 support)
- log entries and lookups failing nss_min_uid at debug level
* update links to use HTTPS
* remove --no-create-home from adduser to hide a few warnings
(closes: #858826)
* remove pie from hardening blacklist because it is no longer needed for
stretch (thanks Adrian Bunk) (closes: #859432)
* update debian/copyright
* upgrade to standards-version 4.0.0 (no changes needed)
2017-01-22 - Arthur de Jong <adejong@debian.org>
nss-pam-ldapd (0.9.7-2) unstable; urgency=medium
* recommend ca-certificate which is needed due to adding tls_cacertfile by
default (see #750949) and the checking of tls_cacertfile in 0.9.7
(closes: #836720)
* fix parsing of nslcd.conf tls_cacert option in package configuration
(closes: #851564)
* add dependency on lsb-base for init script (thanks lintian)

See Also

Package Description
libnss-libvirt_5.0.0-4+deb10u1_amd64.deb nss plugin providing IP address resolution for virtual machines
libnss-lwres_0.93-7+b4_amd64.deb NSS module for using bind9's lwres as a naming service
libnss-mdns_0.14.1-1_amd64.deb NSS module for Multicast DNS name resolution
libnss-myhostname_241-7~deb10u3_amd64.deb nss module providing fallback resolution for the current hostname
libnss-mymachines_241-7~deb10u3_amd64.deb nss module to resolve hostnames for local container instances
libnss-pgsql2_1.4.0debian-8_amd64.deb NSS module for using PostgreSQL as a naming service
libnss-rainbow2_0.8.7-2_amd64.deb nss library for rainbow
libnss-resolve_241-7~deb10u3_amd64.deb nss module to resolve names via systemd-resolved
libnss-sss_1.16.3-3.1_amd64.deb Nss library for the System Security Services Daemon
libnss-systemd_241-7~deb10u3_amd64.deb nss module providing dynamic user and group name resolution
libnss-unknown_0.0.2-2_amd64.deb nss module to handle unknown uids
libnss-winbind_4.9.5+dfsg-5_amd64.deb Samba nameservice integration plugins
libnss-wrapper_1.1.3-1_amd64.deb NSS wrapper library
libnss3-dev_3.42.1-1+deb10u2_amd64.deb Development files for the Network Security Service libraries
libnss3-tools_3.42.1-1+deb10u2_amd64.deb Network Security Service tools
Advertisement
Advertisement