libnlopt0_2.4.2+dfsg-8+b1_amd64.deb


Advertisement

Description

libnlopt0 - nonlinear optimization library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libnlopt0_2.4.2+dfsg-8+b1_amd64.deb
Package name libnlopt0
Package version 2.4.2+dfsg
Package release 8+b1
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://ab-initio.mit.edu/wiki/index.php/NLopt
License -
Maintainer Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Download size 161.00 KB
Installed size 446.00 KB
NLopt is a free/open-source library for nonlinear optimization, providing
a common interface for a number of different free optimization routines
available online as well as original implementations of various other
algorithms. Its features include:
* Callable from C, C++, Fortran, GNU Octave, Python, GNU Guile, GNU R.
* A common interface for many different algorithms
* Support for large-scale optimization.
* Both global and local optimization algorithms.
* Algorithms using function values only (derivative-free) and also
algorithms exploiting user-supplied gradients.
* Algorithms for unconstrained optimization, bound-constrained optimization,
and general nonlinear inequality/equality constraints.
This package provides the shared libraries required to run programs
compiled with NLopt. To compile your own programs you also need to
install libnlopt-dev.

Alternatives

Package Version Architecture Repository
libnlopt0_2.4.2+dfsg-8+b1_i386.deb 2.4.2+dfsg i386 Debian Main
libnlopt0 - - -

Requires

Name Value
libc6 >= 2.14

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libnlopt0_2.4.2+dfsg-8+b1_amd64.deb
Source Package nlopt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libnlopt0 deb package:
    # sudo apt-get install libnlopt0

Files

Path
/usr/lib/x86_64-linux-gnu/libnlopt.so.0
/usr/lib/x86_64-linux-gnu/libnlopt.so.0.8.2
/usr/share/doc/libnlopt0/NEWS.gz
/usr/share/doc/libnlopt0/README
/usr/share/doc/libnlopt0/README.Debian
/usr/share/doc/libnlopt0/TODO
/usr/share/doc/libnlopt0/changelog.Debian.amd64.gz
/usr/share/doc/libnlopt0/changelog.Debian.gz
/usr/share/doc/libnlopt0/changelog.gz
/usr/share/doc/libnlopt0/copyright
/usr/share/lintian/overrides/libnlopt0

Changelog

2018-07-16 - Andreas Tille <tille@debian.org>
nlopt (2.4.2+dfsg-8) unstable; urgency=medium
* Team upload
* Add missing Depends: libnlopt-cxx0 to libnlopt-cpp-dev
Closes: #903347
* Standards-Version: 4.1.5
* Files-Excluded in d/copyright to document repackaging
2018-07-06 - Andreas Tille <tille@debian.org>
nlopt (2.4.2+dfsg-7) unstable; urgency=medium
* Team upload.
* libnlopt-cpp-dev actually Depends: libnlopt-dev (not only ibnlopt0)
2018-06-11 - Sébastien Villemot <sebastien@debian.org>
nlopt (2.4.2+dfsg-6) unstable; urgency=medium
* Team upload.
* octave4.4.patch: new patch, fixes FTBFS against Octave 4.4
2018-05-29 - Andreas Tille <tille@debian.org>
nlopt (2.4.2+dfsg-5) unstable; urgency=medium
* Team upload.
* Provide C++ interface
Closes: #855600
* hardening=+all
* cme fix dpkg-control
* Remove ancient Python version field
2018-02-13 - Sébastien Villemot <sebastien@debian.org>
nlopt (2.4.2+dfsg-4) unstable; urgency=medium
* Team upload.
[ Rafael Laboissiere ]
* Build-depend on dh-octave instead of octave-pkg-dev (Closes: #890088)
[ Sébastien Villemot ]
* Update Vcs-* fields for salsa.
* Bump to debhelper compat level 11, simplify debian/rules.
* Add Testsuite: autopkgtest-pkg-python.
2017-07-08 - Sergey B Kirpichev <skirpichev@gmail.com>
nlopt (2.4.2+dfsg-3) unstable; urgency=medium
[ Afif Elghraoui ]
* initial upstream branch
* Imported Upstream version 2.4.2+dfsg
[ Sergey B Kirpichev ]
* override_dh_auto_reconf -> override_dh_autoreconf (Closes: #834653)
* Bump up Standards-Version (to 4.0.0)
* Set "Multi-Arch: same" for libnlopt-dev and octave-nlopt
* Fix some spelling warnings from lintian
* Init .gitignore
* Adapt Vcs-* fields for Git
2015-07-20 - Sébastien Villemot <sebastien@debian.org>
nlopt (2.4.2+dfsg-2) unstable; urgency=medium
* Team upload.
* d/p/octave-4.0.patch: new patch, fixes FTBFS against Octave 4.0.
(Closes: #792826)
2014-05-20 - Sergey B Kirpichev <skirpichev@gmail.com>
nlopt (2.4.2+dfsg-1) unstable; urgency=low
* Install Octave files into private directories (Closes: #734044,
thanks to Rafael Laboissiere)
* Fix *.oct path in override_dh_shlibdeps
* Call libtoolize with --force to update libtool.m4 (thanks
to Matthias Klose)
* Imported Upstream version 2.4.2+dfsg
* Migrate to guile-2.0 (Closes: #746009)
* Removed obsoleted patch
2013-12-03 - Sergey B Kirpichev <skirpichev@gmail.com>
nlopt (2.4.1+dfsg-1) unstable; urgency=low
* New upstream version (Closes: #728556)
* Bump up Standards-Version (to 3.9.5)
* Change Section to libs for libnlopt-guile0
2013-11-16 - Sergey B Kirpichev <skirpichev@gmail.com>
nlopt (2.4+dfsg-1) unstable; urgency=low
* New upstream version
* Fix lintian error: vcs-field-not-canonical
* Fix permissions on debian/orig-tar.sh
* Remove patches, applied by upstream
* Refresh patches for the new upstream release
* Update debian/libnlopt0.symbols
* Change octave-nlopt priority to optional (See: #706761)
* Override lintian error(X) shlib-calls-exit for libnlopt0

See Also

Package Description
libnm-dev_1.14.6-2_amd64.deb GObject-based client library for NetworkManager (development files)
libnm0_1.14.6-2_amd64.deb GObject-based client library for NetworkManager
libnma-dev_1.8.20-1.1_amd64.deb library for wireless and mobile dialogs - development files
libnma0_1.8.20-1.1_amd64.deb library for wireless and mobile dialogs (libnm version)
libnmap-parser-perl_1.37-1_all.deb module to parse nmap scan results with perl
libnmz7-dev_2.0.21-22_amd64.deb full text search engine - header files and static libraries
libnmz7_2.0.21-22_amd64.deb full text search engine - shared library
libnode-dev_10.15.2~dfsg-2_amd64.deb evented I/O for V8 javascript (development files)
libnode64_10.15.2~dfsg-2_amd64.deb evented I/O for V8 javascript - runtime library
libnodelet-dev_1.9.16-1+b1_amd64.deb Robot OS nodelet library - service header files
libnodelet-topic-tools-dev_1.9.16-1+b1_amd64.deb Robot OS nodelet_topic_tools library - development files
libnodeletlib-dev_1.9.16-1+b1_amd64.deb Robot OS nodelet library - development
libnodeletlib-tools_1.9.16-1+b1_amd64.deb Robot OS nodelet library
libnodeletlib1d_1.9.16-1+b1_amd64.deb Robot OS nodelet library
libnoggit-java_0.7-1_all.deb Fast streaming JSON parser for Java
Advertisement
Advertisement