libnet-luminis-build-plugin-java_0.2.0-3_all.deb


Advertisement

Description

libnet-luminis-build-plugin-java - Wrapper around Bnd to allow easy bundle creation from ant builds

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libnet-luminis-build-plugin-java_0.2.0-3_all.deb
Package name libnet-luminis-build-plugin-java
Package version 0.2.0
Package release 3
Package architecture all
Package type deb
Category java
Homepage https://opensource.luminis.net/wiki/display/SITE/OSGi+Bundle+Ant+Task
License -
Maintainer Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Download size 6.87 KB
Installed size 16.00 KB
The OSGi bundle ant task is a wrapper around Bnd to allow easy bundle creation
from ant builds.
Creates an OSGi bundle. Computes OSGi headers (most notably the importPackage
and exportPackage) from class analysis.

Alternatives

Package Version Architecture Repository
libnet-luminis-build-plugin-java_0.2.0-3_all.deb 0.2.0 all Debian Main
libnet-luminis-build-plugin-java - - -

Requires

Name Value
bnd -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libnet-luminis-build-plugin-java_0.2.0-3_all.deb
Source Package net-luminis-build-plugin

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libnet-luminis-build-plugin-java deb package:
    # sudo apt-get install libnet-luminis-build-plugin-java

Files

Path
/usr/share/doc/libnet-luminis-build-plugin-java/changelog.Debian.gz
/usr/share/doc/libnet-luminis-build-plugin-java/copyright
/usr/share/java/net.luminis.build.plugin-0.2.0.jar
/usr/share/java/net.luminis.build.plugin.jar

Changelog

2015-11-20 - Markus Koschany <apo@debian.org>
net-luminis-build-plugin (0.2.0-3) unstable; urgency=medium
* Team upload.
* Transition to bnd 2.1.0.
* Add bnd-2.1.0.patch and make the package compatible with bnd 2.1.0.
* Remove versioned build dependency on javahelper.
2015-11-14 - Markus Koschany <apo@debian.org>
net-luminis-build-plugin (0.2.0-2) unstable; urgency=medium
* Team upload.
* Declare compliance with Debian Policy 3.9.6.
* wrap-and-sort -sa.
* Switch to bnd1.50 because this package FTBFS with bnd >= 2.1.
* Vcs-Browser: Use https.
* Use compat level 9 and require debhelper >= 9.
* Fix Lintian warnings dep5-copyright-license-name-not-unique
and invalid-short-name-in-dep5-copyright.
2012-04-10 - Mathieu Malaterre <malat@debian.org>
net-luminis-build-plugin (0.2.0-1) unstable; urgency=low
* Initial Debian Upload (Closes: #641295)

See Also

Package Description
libnet-mac-perl_2.103622-2_all.deb module for representing and manipulating MAC addresses
libnet-mac-vendor-perl_1.262-1_all.deb module to look up the vendor by OUI
libnet-managesieve-perl_0.13-1_all.deb Perl client module for ManageSieve
libnet-nbname-perl_0.26-2_all.deb NetBIOS Name Service Requests
libnet-nessus-rest-perl_0.7.0-1_all.deb REST interface for Nessus 6.0
libnet-nessus-xmlrpc-perl_0.30-2_all.deb module for communication with Nessus scanner(v4.2+) via XMLRPC
libnet-netmask-perl_1.9104-1_all.deb module to parse, manipulate and lookup IP network blocks
libnet-nis-perl_0.44-1+b6_amd64.deb Interface to Sun's Network Information Service
libnet-nslookup-perl_2.04-2_all.deb simple DNS lookup module for perl
libnet-ntp-perl_1.5-1_all.deb Perl module to query NTP servers
libnet-oauth-perl_0.28-3_all.deb implementation of the OAuth 1.0 protocol
libnet-oauth2-authorizationserver-perl_0.20-1_all.deb implementation of an OAuth2 Authorization Server
libnet-oauth2-perl_0.64-1_all.deb implementation of the OAuth 2.0 protocol
libnet-openid-common-perl_1.20-1_all.deb libraries shared between Net::OpenID::Consumer and Net::OpenID::Server
libnet-openid-consumer-perl_1.18-1_all.deb library for consumers of OpenID identities
Advertisement
Advertisement