libmagics++-dev_3.3.1-1_amd64.deb


Advertisement

Description

libmagics++-dev - Development files for ECMWF plotting software MAGICS++

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libmagics++-dev_3.3.1-1_amd64.deb
Package name libmagics++-dev
Package version 3.3.1
Package release 1
Package architecture amd64
Package type deb
Category devel::library libdevel role::devel-lib
Homepage https://software.ecmwf.int/wiki/display/MAGP/Magics
License -
Maintainer Alastair McKinstry <mckinstry@debian.org>
Download size 115.19 KB
Installed size 558.00 KB
Magics++ is the latest generation of the ECMWF's Meteorological plotting
software MAGICS. Although completely redesigned in C++, it is intended to be
as backwards-compatible as possible with the Fortran interface.
Besides its programming interfaces (Fortran and C), Magics++ offers MagML,
a plot description language based on XML aimed at automatic web production.
This package includes the header files and static libraries needed to build
against libmagics++.

Alternatives

Package Version Architecture Repository
libmagics++-dev_3.3.1-1_i386.deb 3.3.1 i386 Debian Main
libmagics++-dev - - -

Requires

Name Value
libmagplus3v5 = 3.3.1-1
libodb-api-dev -
libterralib-dev -
magics++ -
python-all-dev -
python3-all-dev -
python:any -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmagics++-dev_3.3.1-1_amd64.deb
Source Package magics++

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmagics++-dev deb package:
    # sudo apt-get install libmagics++-dev

Files

Path
/usr/bin/magicsCompatibilityChecker
/usr/include/magics/BaseDriver.h
/usr/include/magics/BaseDriverAttributes.h
/usr/include/magics/BaseParameter.h
/usr/include/magics/BasePointsHandler.h
/usr/include/magics/BasicGraphicsObject.h
/usr/include/magics/BasicSceneObject.h
/usr/include/magics/BinningObject.h
/usr/include/magics/BinningObjectAttributes.h
/usr/include/magics/Colour.h
/usr/include/magics/ColourTable.h
/usr/include/magics/ColourTableDefinition.h
/usr/include/magics/ContinuousLegendMethodAttributes.h
/usr/include/magics/CustomisedPoint.h
/usr/include/magics/Data.h
/usr/include/magics/DataStats.h
/usr/include/magics/DateGribLoopStepAttributes.h
/usr/include/magics/DateTime.h
/usr/include/magics/Decoder.h
/usr/include/magics/DisplayManager.h
/usr/include/magics/DriverManager.h
/usr/include/magics/Factory.cc
/usr/include/magics/Factory.h
/usr/include/magics/FixedTableModeAttributes.h
/usr/include/magics/FortranRootSceneNodeAttributes.h
/usr/include/magics/GeoRectangularProjection.h
/usr/include/magics/GeoRectangularProjectionAttributes.h
/usr/include/magics/GribAddressMode.h
/usr/include/magics/GribDecoder.h
/usr/include/magics/GribDecoderAttributes.h
/usr/include/magics/GribInterpretor.h
/usr/include/magics/GribLoopAttributes.h
/usr/include/magics/GribLoopStep.h
/usr/include/magics/GribSatelliteInterpretor.h
/usr/include/magics/HistogramLegendMethodAttributes.h
/usr/include/magics/Image.h
/usr/include/magics/ImageProperties.h
/usr/include/magics/IntervalMap.h
/usr/include/magics/Label.h
/usr/include/magics/Layer.h
/usr/include/magics/Layout.h
/usr/include/magics/LegendMethod.h
/usr/include/magics/LegendVisitor.h
/usr/include/magics/LegendVisitorAttributes.h
/usr/include/magics/LookupTableMode.h
/usr/include/magics/LookupTableModeAttributes.h
/usr/include/magics/MagException.h
/usr/include/magics/MagFont.h
/usr/include/magics/MagLog.h
/usr/include/magics/MagPlus.h
/usr/include/magics/MagRequest.h
/usr/include/magics/MagTranslator.h
/usr/include/magics/MagicsEvent.h
/usr/include/magics/MagicsObserver.h
/usr/include/magics/Matrix.h
/usr/include/magics/MatrixHandler.h
/usr/include/magics/MgQ.h
/usr/include/magics/MgQLayerItem.h
/usr/include/magics/MgQLayoutItem.h
/usr/include/magics/MgQPlotScene.h
/usr/include/magics/MgQRootItem.h
/usr/include/magics/MgQScene.h
/usr/include/magics/MgQSceneItem.h
/usr/include/magics/MgQStepMetaData.h
/usr/include/magics/OutputFactory.h
/usr/include/magics/OutputHandler.h
/usr/include/magics/OutputHandlerAttributes.h
/usr/include/magics/PaperPoint.h
/usr/include/magics/ParameterManager.h
/usr/include/magics/PointsHandler.h
/usr/include/magics/QtDriver.h
/usr/include/magics/QtDriverAttributes.h
/usr/include/magics/RasterData.h
/usr/include/magics/RootSceneNode.h
/usr/include/magics/SceneVisitor.h
/usr/include/magics/Text.h
/usr/include/magics/ThinningMethod.h
/usr/include/magics/Timer.h
/usr/include/magics/Tokenizer.h
/usr/include/magics/Transformation.h
/usr/include/magics/UserPoint.h
/usr/include/magics/VectorOfPointers.h
/usr/include/magics/Visdef.h
/usr/include/magics/WindMode.h
/usr/include/magics/WrepRootNodeAttributes.h
/usr/include/magics/XmlBasicNodeAttributes.h
/usr/include/magics/XmlMagics.h
/usr/include/magics/XmlNode.h
/usr/include/magics/XmlReader.h
/usr/include/magics/XmlRootNodeAttributes.h
/usr/include/magics/XmlTree.h
/usr/include/magics/magics.h
/usr/include/magics/magics_api.h
/usr/include/magics/magics_config.h
/usr/lib/x86_64-linux-gnu/libMagPlus.so
/usr/lib/x86_64-linux-gnu/libMagPlusDouble.so
/usr/lib/x86_64-linux-gnu/libMagPlusSingle.so
/usr/lib/x86_64-linux-gnu/cmake/magics/magics-config-version.cmake
/usr/lib/x86_64-linux-gnu/cmake/magics/magics-config.cmake
/usr/lib/x86_64-linux-gnu/cmake/magics/magics-config.cmake.tpls
/usr/lib/x86_64-linux-gnu/cmake/magics/magics-import.cmake
/usr/lib/x86_64-linux-gnu/cmake/magics/magics-targets-none.cmake
/usr/lib/x86_64-linux-gnu/cmake/magics/magics-targets.cmake
/usr/lib/x86_64-linux-gnu/pkgconfig/magics.pc
/usr/share/doc/libmagics++-dev/AUTHORS
/usr/share/doc/libmagics++-dev/NEWS.gz
/usr/share/doc/libmagics++-dev/NOTICE.gz
/usr/share/doc/libmagics++-dev/changelog.Debian.gz
/usr/share/doc/libmagics++-dev/changelog.gz
/usr/share/doc/libmagics++-dev/copyright

Changelog

2018-12-20 - Alastair McKinstry <mckinstry@debian.org>
magics++ (3.3.1-1) unstable; urgency=medium
* New upstream release
* Sanitize build path for magics*cmake scripts in -dev pkg
2018-11-19 - Alastair McKinstry <mckinstry@debian.org>
magics++ (3.2.2-2) unstable; urgency=medium
* Rebuild against eccodes (>= 2.9.2-3) to avoid eccodes_memfs
2018-11-15 - Alastair McKinstry <mckinstry@debian.org>
magics++ (3.2.2-1) unstable; urgency=medium
* New upstream release
* Fix path on metgram script to /usr/bin/perl
* Drop unused lintian-overrides
2018-11-06 - Gianfranco Costamagna <locutusofborg@debian.org>
magics++ (3.2.1-2) unstable; urgency=medium
* Team upload
* Fixup VCS fields
* Add python3:Depends to -dev package, and runtime python development
packages:
- cmake files are currently needing python libraries
2018-10-26 - Alastair McKinstry <mckinstry@debian.org>
magics++ (3.2.1-1) unstable; urgency=medium
* New upstream release
2018-10-01 - Alastair McKinstry <mckinstry@debian.org>
magics++ (3.2.0-1) unstable; urgency=medium
* New upstream release
* Standards-Version: 4.2.1
* Drop hard-coded xz compression
* Drop option of building with obsolete grib-api (eccodes only)
2018-07-27 - Alastair McKinstry <mckinstry@debian.org>
magics++ (3.1.0-2) unstable; urgency=medium
* Standards-Version: 4.1.5
* Change HAVE_ODB -> ENABLE_ODB in cmake rules
* Update URLs in debian/watch
* Add python3-all-dev for python3.7 transition
2018-07-03 - Alastair McKinstry <mckinstry@debian.org>
magics++ (3.1.0-1) unstable; urgency=medium
* New upstream release
* Cmake dependency >= 3.1
2018-05-14 - Alastair McKinstry <mckinstry@debian.org>
magics++ (3.0.4-1) unstable; urgency=medium
* New upstream release
* Standards-Version: 4.1.4
2018-04-27 - Alastair McKinstry <mckinstry@debian.org>
magics++ (3.0.3-1) unstable; urgency=medium
* New upstream release

See Also

Package Description
libmagics++-metview-dev_3.3.1-1_amd64.deb Libraries needed for building MetView
libmagpie-perl_1.163200-1_all.deb RESTful Web Framework for Perl5
libmagplus3v5_3.3.1-1_amd64.deb ECMWF meteorological plotting software library
libmail-box-imap4-perl_3.003-1_all.deb perl module for handling of IMAP4 folders as client
libmail-box-perl_3.006-1_all.deb message-folder management module
libmail-box-pop3-perl_3.004-1_all.deb POP3 handler for Mail::Box
libmail-bulkmail-perl_3.12-5_all.deb Platform independent mailing list module
libmail-checkuser-perl_1.24-1_all.deb Perl module for checking email addresses for validity
libmail-chimp3-perl_0.06-1_all.deb interface to mailchimp.com's RESTful Web API v3
libmail-deliverystatus-bounceparser-perl_1.542+repacked-1_all.deb module for analyzing bounce messages
libmail-dkim-perl_0.54-1_all.deb cryptographically identify the sender of email - perl library
libmail-field-received-perl_0.26-1_all.deb mostly RFC822-compliant parser of Received headers
libmail-gnupg-perl_0.23-2_all.deb Perl module for processing email with GPG
libmail-imapclient-perl_3.42-1_all.deb Perl library for manipulating IMAP mail stores
libmail-imaptalk-perl_4.04-1_all.deb IMAP client interface with lots of features
Advertisement
Advertisement