liblwjgl-java-jni_2.9.3+dfsg-5_amd64.deb


Advertisement

Description

liblwjgl-java-jni - Lightweight Java Game Library (jni)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename liblwjgl-java-jni_2.9.3+dfsg-5_amd64.deb
Package name liblwjgl-java-jni
Package version 2.9.3+dfsg
Package release 5
Package architecture amd64
Package type deb
Category java role::shared-lib
Homepage https://www.lwjgl.org
License -
Maintainer Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Download size 83.60 KB
Installed size 446.00 KB
The Lightweight Java Game Library (LWJGL) is a solution aimed directly at
professional and amateur Java programmers alike to enable commercial quality
games to be written in Java. LWJGL provides developers access to high
performance crossplatform libraries such as OpenGL (Open Graphics Library)
and OpenAL (Open Audio Library) allowing for state of the art 3D games and 3D
sound. Additionally LWJGL provides access to controllers such as Gamepads,
Steering wheel and Joysticks. All in a simple and straight forward API.
This package contains the java jni library.

Alternatives

Package Version Architecture Repository
liblwjgl-java-jni_2.9.3+dfsg-5_i386.deb 2.9.3+dfsg i386 Debian Main
liblwjgl-java-jni - - -

Requires

Name Value
libc6 >= 2.2.5
libx11-6 -
libxcursor1 >> 1.1.2
libxrandr2 >= 4.3
libxxf86vm1 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liblwjgl-java-jni_2.9.3+dfsg-5_amd64.deb
Source Package lwjgl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblwjgl-java-jni deb package:
    # sudo apt-get install liblwjgl-java-jni

Files

Path
/usr/lib/jni/liblwjgl.so
/usr/share/doc/liblwjgl-java-jni/changelog.Debian.gz
/usr/share/doc/liblwjgl-java-jni/copyright

Changelog

2018-12-28 - Markus Koschany <apo@debian.org>
lwjgl (2.9.3+dfsg-5) unstable; urgency=medium
* Team upload.
* Fix broken liblwjgl-java-jni package by compiling all needed source files.
Thanks to Petr Cvek for the report and Le Gall Guillaume for further
investigations and the patch. (Closes: #912631)
* Declare compliance with Debian Policy 4.3.0.
* Override dh_shlibdeps and fix broken link against libjawt.so.
2018-10-10 - Emmanuel Bourg <ebourg@apache.org>
lwjgl (2.9.3+dfsg-4) unstable; urgency=medium
* Team upload.
* Fixed the build failures with Java 9/10/11 (Closes: #893302)
* Simplified the OS X and ASM patches
* Filter the upstream tarball with the Files-Excluded field in d/copyright
* Standards-Version updated to 4.2.1
* Use salsa.debian.org Vcs-* URLs
2018-07-28 - Markus Koschany <apo@debian.org>
lwjgl (2.9.3+dfsg-3) unstable; urgency=medium
* Team upload.
* Use the arch specific version of OpenJDK 8, otherwise the build will fail
on non-amd64 architectures.
2018-07-28 - Markus Koschany <apo@debian.org>
lwjgl (2.9.3+dfsg-2) unstable; urgency=medium
[ tony mancill ]
* Team upload.
* remove Gabriele Giacone from Uploaders (Closes: #856765)
* update Homepage to use https URL
[ Markus Koschany ]
* Build-depend on OpenJDK 8 to work around the FTBFS with later versions.
(Closes: #893302)
* Declare compliance with Debian Policy 4.1.5.
* Switch to compat level 11.
* Use https for Format field.
2016-04-09 - Markus Koschany <apo@debian.org>
lwjgl (2.9.3+dfsg-1) unstable; urgency=medium
* Team upload.
* Imported Upstream version 2.9.3+dfsg. (Closes: #648624)
* d/control: Build-depend on default-jdk instead of openjdk-7-jdk.
(Closes: #814167)
* Declare compliance with Debian Policy 3.9.7.
* Vcs-Git: Use https.
* d/rules: Use default-java as JAVA_HOME.
* Fix debian/watch file and track the latest 2.x releases.
* Refresh all patches for new release.
* debian/rules: Build with parallel and javahelper.
* Add build-failure.patch and fix a FTBFS.
* Add no-asm-support.patch and remove optional code for asm.jar.
* Export DEB_BUILD_MAINT_OPTIONS = hardening=+all.
* Update debian/copyright for new release.
2015-12-09 - tony mancill <tmancill@debian.org>
lwjgl (2.7.1+dfsg-5) unstable; urgency=medium
* Team upload.
* debian/patches/ppc64el.patch: adds cflag -mcpu=powerpc for
to fix ftbfs on ppc64el. (Closes: #807420)
Thank you to Fernando Seiti Furusato <ferseiti@br.ibm.com>
for the patch.
2014-10-13 - Michael Gilbert <mgilbert@debian.org>
lwjgl (2.7.1+dfsg-4) unstable; urgency=low
* Update packaging standards.
* Remove binutils-gold build conflict (closes: #749957).
* Build-depend openjdk-7 >= 7u71-2.5.3-1 (closes: #761269).
2012-05-07 - Michael Gilbert <mgilbert@debian.org>
lwjgl (2.7.1+dfsg-3) unstable; urgency=low
* add java bin dir to the PATH environment (closes: #664180)
* update my email address
* build-conflict with binutils-gold
* bump standards to 3.9.3
* add a .gitignore file
* utilize jutils.jar via jinput.jar's classpath
2011-11-13 - Michael Gilbert <michael.s.gilbert@gmail.com>
lwjgl (2.7.1+dfsg-2) unstable; urgency=low
[ Miguel Landaeta ]
* Team upload.
* Switch to default-jdk. (Closes: #643537).
* Make copyright file DEP-5 compliant.
[ Michael Gilbert ]
* Fix clean rule.
* Fix Vcs-Git field.
* Update copyright file.
2011-05-08 - Michael Gilbert <michael.s.gilbert@gmail.com>
lwjgl (2.7.1+dfsg-1) unstable; urgency=low
[ Michael Gilbert ]
* new upstream release:
- refresh debian patches.
* add myself as an uploader.
* don't build-depend on sun-java-6
* use jh_clean
[ Niels Thykier ]
* Bumped Standards-Version to 3.9.2 - no changes required.

See Also

Package Description
liblwjgl-java_2.9.3+dfsg-5_all.deb Lightweight Java Game Library
liblwp-authen-negotiate-perl_0.08-2.1_all.deb Perl module for GSSAPI based Authentication Plugin for LWP
liblwp-authen-oauth-perl_1.01-1_all.deb OAuth authentication plugin for LWP
liblwp-authen-oauth2-perl_0.16-1_all.deb module enabling OAuth 2 requests via LWP
liblwp-authen-wsse-perl_0.05-3_all.deb library for enabling X-WSSE authentication in LWP
liblwp-mediatypes-perl_6.02-1_all.deb module to guess media type for a file or a URL
liblwp-online-perl_1.08-2_all.deb module to check if there is Internet access
liblwp-protocol-http-socketunix-perl_0.02-3_all.deb Perl module to speak http through unix sockets
liblwp-protocol-https-perl_6.07-2_all.deb HTTPS driver for LWP::UserAgent
liblwp-protocol-psgi-perl_0.10-1_all.deb override LWP's HTTP/HTTPS backend with your own PSGI application
liblwp-protocol-socks-perl_1.7-1_all.deb SOCKS proxy support for LWP
liblwp-useragent-chicaching-perl_0.04-1_all.deb LWP::UserAgent with caching based on CHI
liblwp-useragent-determined-perl_1.07-1_all.deb LWP useragent that retries errors
liblwp-useragent-progressbar-perl_1.100810-2_all.deb LWP user agent that can display a progress bar
liblwpx-paranoidagent-perl_1.12-1_all.deb "paranoid" subclass of LWP::UserAgent
Advertisement
Advertisement