liblwgeom-2.5-0_2.5.1+dfsg-1_amd64.deb


Advertisement

Description

liblwgeom-2.5-0 - PostGIS "Lightweight Geometry" library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename liblwgeom-2.5-0_2.5.1+dfsg-1_amd64.deb
Package name liblwgeom-2.5-0
Package version 2.5.1+dfsg
Package release 1
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://postgis.net/
License -
Maintainer Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Download size 712.41 KB
Installed size 1.11 MB
PostGIS adds support for geographic objects to the PostgreSQL
object-relational database. In effect, PostGIS "spatially enables"
the PostgreSQL server, allowing it to be used as a backend spatial
database for geographic information systems (GIS), much like ESRI's
SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
"Simple Features Specification for SQL".
This library is the generic geometry handling section of PostGIS. The
geometry objects, constructors, destructors, and a set of spatial
processing functions, are implemented here.

Alternatives

Package Version Architecture Repository
liblwgeom-2.5-0_2.5.1+dfsg-1_i386.deb 2.5.1+dfsg i386 Debian Main
liblwgeom-2.5-0 - - -

Requires

Name Value
libc6 >= 2.14
libgeos-c1v5 >= 3.5.0
libjson-c3 >= 0.10
libproj13 >= 4.9.0
libsfcgal1 >= 1.1.0

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liblwgeom-2.5-0_2.5.1+dfsg-1_amd64.deb
Source Package postgis

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblwgeom-2.5-0 deb package:
    # sudo apt-get install liblwgeom-2.5-0

Files

Path
/usr/lib/liblwgeom-2.5.so.0
/usr/lib/liblwgeom-2.5.so.0.0.0
/usr/share/doc/liblwgeom-2.5-0/NEWS.Debian.gz
/usr/share/doc/liblwgeom-2.5-0/changelog.Debian.gz
/usr/share/doc/liblwgeom-2.5-0/changelog.gz
/usr/share/doc/liblwgeom-2.5-0/copyright
/usr/share/lintian/overrides/liblwgeom-2.5-0

Changelog

2018-11-22 - Bas Couwenberg <sebastic@debian.org>
postgis (2.5.1+dfsg-1) unstable; urgency=medium
* New upstream release.
* Add Build-Depends-Package field to symbols file.
2018-10-14 - Bas Couwenberg <sebastic@debian.org>
postgis (2.5.0+dfsg-2) unstable; urgency=medium
* Move from experimental to unstable.
2018-10-05 - Bas Couwenberg <sebastic@debian.org>
postgis (2.5.0+dfsg-2~exp1) experimental; urgency=medium
* Strip trailing comma from Uploaders.
* Reorder Breaks/Provides/Replaces fields.
* Update packaging for postgresql-11.
2018-09-24 - Bas Couwenberg <sebastic@debian.org>
postgis (2.5.0+dfsg-1) unstable; urgency=medium
* New upstream release.
* Move from experimental to unstable.
2018-09-17 - Bas Couwenberg <sebastic@debian.org>
postgis (2.5.0~rc2+dfsg-1~exp1) experimental; urgency=medium
* New upstream release candidate.
* Bump Standards-Version to 4.2.1, no changes.
2018-08-20 - Bas Couwenberg <sebastic@debian.org>
postgis (2.5.0~rc1+dfsg-1~exp1) experimental; urgency=medium
[ Christoph Berg ]
* Provide postgresql-PGVERSION-postgis{,-scripts} so pgrouting can depend on
us without an explicit postgis version.
[ Bas Couwenberg ]
* New upstream release candidate.
2018-08-11 - Bas Couwenberg <sebastic@debian.org>
postgis (2.5.0~beta2+dfsg-1~exp1) experimental; urgency=medium
[ Bas Couwenberg ]
* New upstream beta release.
* Don't quote filter string to fix match of first and last items.
* Bump Standards-Version to 4.2.0, no changes.
* Update copyright years for Paul Ramsey.
* Drop rt_gdalwarp.patch, worked around by upstream.
* Drop unused override for hardening-no-fortify-functions.
* Separate test restrictions with a comma.
[ Christoph Berg ]
* Re-enable tests on arm64 armel armhf i386 ppc64el, fixed upstream.
* Use make check RUNTESTFLAGS="-v" instead of cat'ing the failed results
from /tmp. Suggested by Darafei Praliaskouski, thanks!
* Provide postgresql-postgis and postgresql-postgis-scripts, so we can
depend on them in autopkgtests in other packages.
* Drop transitional postgresql-*-postgis-scripts package. The PG 9.6 variant
was already transitional in stretch, and the PG 10 variant was never in a
stable release.
2018-07-16 - Christoph Berg <myon@debian.org>
postgis (2.5.0~beta1+dfsg-1~exp2) experimental; urgency=medium
[ Bas Couwenberg ]
* Bump Standards-Version to 4.1.5, no changes.
* Skip tests on arm64 & ppc64el too.
* Drop parallel patches, fixed upstream.
[ Christoph Berg ]
* debian/pgversions: Bump to 9.4+, 9.3 is no longer supported.
* Bump required GEOS version to 3.5.
* Work around failure in building the postgis_tiger_geocoder extension.
* debian/rules: Ignore test failures instead of disabling tests completely
on specific architectures; ignore tests on i386.
* Don't run tests in -indep builds.
* debian/rules: Import architecture from /usr/share/dpkg/architecture.mk.
* Re-enable tests on Ubuntu.
* Add myself to Uploaders.
2018-07-04 - Bas Couwenberg <sebastic@debian.org>
postgis (2.5.0~beta1+dfsg-1~exp1) experimental; urgency=medium
* New upstream beta release.
* Re-enable SFCGAL support, FTBFS with CGAL 4.12 is fixed.
* Disable PIE only on older Ubuntu releases.
* Update copyright file, add copyright holders, update copyright years.
* Refresh patches.
* Disable parallel patches, may be fixed upstream.
* Update Conflicts for postgis-2.4.
* Update lintian override for address_standardizer.
* Update symbols for 2.5.0~beta1.
2018-06-10 - Bas Couwenberg <sebastic@debian.org>
postgis (2.4.4+dfsg-4) unstable; urgency=medium
* Add patches to fix parallel build of other extensions.

See Also

Package Description
liblwgeom-dev_2.5.1+dfsg-1_amd64.deb PostGIS "Lightweight Geometry" library - Development files
liblwip-dev_2.0.3-3_amd64.deb small implementation of the TCP/IP protocol suite - development files
liblwip-doc_2.0.3-3_all.deb small implementation of the TCP/IP protocol suite - documentation
liblwip0_2.0.3-3_amd64.deb small implementation of the TCP/IP protocol suite - shared library
liblwipv6-2_1.5a-4_amd64.deb User level (lightweight) TCP/IP stack with IPv6 support
liblwipv6-dev_1.5a-4_amd64.deb Development files for the LWIPv6 library
liblwjgl-java-doc_2.9.3+dfsg-5_all.deb Lightweight Java Game Library (javadoc)
liblwjgl-java-jni_2.9.3+dfsg-5_amd64.deb Lightweight Java Game Library (jni)
liblwjgl-java_2.9.3+dfsg-5_all.deb Lightweight Java Game Library
liblwp-authen-negotiate-perl_0.08-2.1_all.deb Perl module for GSSAPI based Authentication Plugin for LWP
liblwp-authen-oauth-perl_1.01-1_all.deb OAuth authentication plugin for LWP
liblwp-authen-oauth2-perl_0.16-1_all.deb module enabling OAuth 2 requests via LWP
liblwp-authen-wsse-perl_0.05-3_all.deb library for enabling X-WSSE authentication in LWP
liblwp-mediatypes-perl_6.02-1_all.deb module to guess media type for a file or a URL
liblwp-online-perl_1.08-2_all.deb module to check if there is Internet access
Advertisement
Advertisement