libluksmeta0_9-3_amd64.deb


Advertisement

Description

libluksmeta0 - library to access metadata in the LUKSv1 header

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libluksmeta0_9-3_amd64.deb
Package name libluksmeta0
Package version 9
Package release 3
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage https://github.com/latchset/luksmeta
License -
Maintainer Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
Download size 7.72 KB
Installed size 33.00 KB
LUKSMeta is a simple library for storing metadata in the LUKSv1 header.

Alternatives

Package Version Architecture Repository
libluksmeta0_9-3_i386.deb 9 i386 Debian Main
libluksmeta0 - - -

Requires

Name Value
libc6 >= 2.7
libcryptsetup12 >= 2:1.6

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libluksmeta0_9-3_amd64.deb
Source Package luksmeta

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libluksmeta0 deb package:
    # sudo apt-get install libluksmeta0

Files

Path
/usr/lib/x86_64-linux-gnu/libluksmeta.so.0
/usr/lib/x86_64-linux-gnu/libluksmeta.so.0.0.0
/usr/share/doc/libluksmeta0/changelog.Debian.gz
/usr/share/doc/libluksmeta0/copyright

Changelog

2019-03-01 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
luksmeta (9-3) unstable; urgency=high
* Use cryptsetup-bin as build dependency, following the cryptsetup
transition
* Fix error in test-luksmeta introduced by cryptsetup defaulting to
luks2
2018-12-09 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
luksmeta (9-2) unstable; urgency=high
* Relax content tests in test suite. Closes: #915256
2018-08-25 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
luksmeta (9-1) unstable; urgency=medium
* New upstream version 9
2017-11-16 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
luksmeta (8-3) unstable; urgency=medium
* Restrict to linux-any as cryptsetup is available only there
* Don't fail test if the cryptsetup backend fails. Closes: #881864
2017-11-11 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
luksmeta (8-2) unstable; urgency=medium
* Add missing dependencies
2017-11-04 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
luksmeta (8-1) unstable; urgency=medium
* Initial release. Closes: #873940

See Also

Package Description
liblunar-date-2.0-0_2.4.0-5_amd64.deb Chinese Lunar library based on GObject
liblunar-date-dev_2.4.0-5_amd64.deb Chinese Lunar library based on GObject - develop files
liblunar-date-doc_2.4.0-5_all.deb Chinese Lunar library based on GObject - API documents
liblur-dev_0.9.905-1_amd64.deb Logitech Unifying Receiver access library - dev files
liblur3_0.9.905-1_amd64.deb Logitech Unifying Receiver access library
liblv2dynparam1-dev_2-6_amd64.deb lv2dynparam is a LV2 plugin interface extension
liblv2dynparamhost1-1_2-6_amd64.deb LV2 plugin interface extension - host
liblv2dynparamplugin1-0_2-6_amd64.deb LV2 plugin interface extension - plugin
liblvm2-dev_2.03.02-3_amd64.deb LVM2 libraries - development files
liblvm2cmd2.03_2.03.02-3_amd64.deb LVM2 command library
liblwgeom-2.5-0_2.5.1+dfsg-1_amd64.deb PostGIS "Lightweight Geometry" library
liblwgeom-dev_2.5.1+dfsg-1_amd64.deb PostGIS "Lightweight Geometry" library - Development files
liblwip-dev_2.0.3-3_amd64.deb small implementation of the TCP/IP protocol suite - development files
liblwip-doc_2.0.3-3_all.deb small implementation of the TCP/IP protocol suite - documentation
liblwip0_2.0.3-3_amd64.deb small implementation of the TCP/IP protocol suite - shared library
Advertisement
Advertisement