liblttng-ust-python-agent0_2.10.3-1_amd64.deb


Advertisement

Description

liblttng-ust-python-agent0 - LTTng 2.0 Userspace Tracer (Python agent native library)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename liblttng-ust-python-agent0_2.10.3-1_amd64.deb
Package name liblttng-ust-python-agent0
Package version 2.10.3
Package release 1
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage https://lttng.org/
License -
Maintainer Jon Bernard <jbernard@debian.org>
Download size 33.53 KB
Installed size 89.00 KB
The userspace tracer is designed to provide detailed information about
userspace activity. Like the kernel tracer, performance is the main goal.
Tracing does not require system calls or traps. UST instrumentation points may
be added in any userspace code including signal handlers and libraries.
This package contains a library used by the Python agents.

Alternatives

Package Version Architecture Repository
liblttng-ust-python-agent0_2.10.3-1_i386.deb 2.10.3 i386 Debian Main
liblttng-ust-python-agent0 - - -

Requires

Name Value
libc6 >= 2.4
liblttng-ust0 = 2.10.3-1
liburcu6 >= 0.10.0

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liblttng-ust-python-agent0_2.10.3-1_amd64.deb
Source Package ust

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblttng-ust-python-agent0 deb package:
    # sudo apt-get install liblttng-ust-python-agent0

Files

Path
/usr/lib/x86_64-linux-gnu/liblttng-ust-python-agent.so.0
/usr/lib/x86_64-linux-gnu/liblttng-ust-python-agent.so.0.0.0
/usr/share/doc/liblttng-ust-python-agent0/changelog.Debian.gz
/usr/share/doc/liblttng-ust-python-agent0/changelog.gz
/usr/share/doc/liblttng-ust-python-agent0/copyright

Changelog

2019-02-07 - Michael Jeanson <mjeanson@debian.org>
ust (2.10.3-1) unstable; urgency=medium
[ Ondřej Nový ]
* [33735c4] d/copyright: Change Format URL to correct one
[ Michael Jeanson ]
* [1e46cac] Add Salsa CI configuration
* [259748c] Remove partial changelog entry
* [b5cc43a] New upstream version 2.10.3
* [69b1488] Bump debhelper from old 9 to 10.
* [01e08c4] Re-export upstream signing key without extra signatures.
* [f655798] Drop unnecessary dependency on dh-autoconf.
* [9050194] Add Build-Depends-Package to symbols file
* [62988f4] Bump standards version to 4.3.0
* [550936c] Add upstream metadata file
2018-08-20 - Michael Jeanson <mjeanson@debian.org>
ust (2.10.2-1) unstable; urgency=medium
* [6ee169b] Fix symbols for riscv64
* [29a5184] New upstream version 2.10.2
* [9cea2f8] Drop patch applied upstream
* [b312339] Remove symbols erroneously exported by liblttng-ust-fd.so.0
* [ed3731f] Drop x-python3-version
* [0acbf69] Drop removed files from copyright
* [8bd76e8] Bump standard to 4.2.0, no changes necessary
2018-05-04 - Michael Jeanson <mjeanson@debian.org>
ust (2.10.1-3) unstable; urgency=medium
* [6798480] Update symbols for new riscv64 architecture
* [f81465e] Drop patch forcing obsolete java bytecode version 1.6
* [26128f4] Drop gcj compat patch
* [ca241ec] Fix build failure with openjdk >= 10 (Closes: #897483)
2018-04-24 - Michael Jeanson <mjeanson@debian.org>
ust (2.10.1-2) unstable; urgency=medium
* [4561e9b] Moved VCS to salsa.debian.org
* [9132150] Add python3-distutils builddep (Closes: #896794)
* [f47371c] Bump standard to 4.1.4, no changes necessary
* [ef662e3] Use salsa canonical uri in VCS-Browser
2017-11-30 - Michael Jeanson <mjeanson@debian.org>
ust (2.10.1-1) unstable; urgency=medium
* [cd47deb] New upstream version 2.10.1
* [4d1422b] Drop patch merged upstream
* [3dda0df] Switched my uploader email to @debian.org
* [74fb6ad] Update symbols for 2.10.1
2017-11-21 - Michael Jeanson <mjeanson@ubuntu.com>
ust (2.10.0-4) unstable; urgency=medium
* [cae46a9] Fix python3-lttngust load un-versioned library (Closes: #882366)
2017-10-18 - Michael Jeanson <mjeanson@ubuntu.com>
ust (2.10.0-3) unstable; urgency=medium
* [68cef23] Add perf symbols to all archs
* [af1103b] Forgot m68k symbols in liblttng-ust-ctl4
* [7960048] Change priority to optional, as per policy
* [d5b199b] Bump standards version to 4.1.1
* [38c2762] Use https url in watch file
2017-10-16 - Michael Jeanson <mjeanson@ubuntu.com>
ust (2.10.0-2) unstable; urgency=medium
* [4e2e3ec] Add a 'nojava' build profile
* [b60dc6d] Update symbols for m68k arch (Closes: #876149)
* [0432f3b] Disable java on hppa. (Closes: #876148)
2017-09-14 - Jon Bernard <jbernard@debian.org>
ust (2.10.0-1) unstable; urgency=medium
[ Michael Jeanson ]
* [f34755c] Move to DEP-14 branch naming
* [01efc7c] Rename source package to lttng-ust
* [a4bb887] Don't ship static lib, it's broken and useless
* [bfa2833] Install headers in multiarch path (Closes: #687460)
* [668fa1d] New upstream version 2.10.0
* [13a4c58] Bump soname of liblttng-ust-ctl from 2 to 4
* [5f3f693] Update symbols for 2.10.0
* [99fea0d] Updated debian copyright
* [56d0c0e] Revert source package rename
[ Jon Bernard ]
* [cfa34cd] Include missing symbols from previous update
2017-06-30 - Michael Jeanson <mjeanson@ubuntu.com>
ust (2.9.1-1) unstable; urgency=medium
* [dfb524d] Do not consider rc versions in watch file
* [c14b0be] New upstream version 2.9.1
* [18e7752] Refreshed patches for 2.9.1
* [40eaada] Remove python3 -dev build-depends (Closes: #866535)
* [b575fa7] Update symbols for 2.9.1
* [be69e6c] Enable hardening flags
* [3ff18c8] Bump standards version to 4.0.0

See Also

Package Description
liblttng-ust0_2.10.3-1_amd64.deb LTTng 2.0 Userspace Tracer (tracing libraries)
liblttoolbox3-3.5-1_3.5.0-3_amd64.deb Shared library for lttoolbox
liblua5.1-0-dev_5.1.5-8.1+b2_amd64.deb Development files for the Lua language version 5.1
liblua5.1-0_5.1.5-8.1+b2_amd64.deb Shared library for the Lua interpreter version 5.1
liblua5.1-bitop-dev_1.0.2-5_all.deb Transitional package for lua-bitop-dev
liblua5.1-bitop0_1.0.2-5_all.deb Transitional package for lua-bitop
liblua5.1-luacsnd_6.12.2~dfsg-3.1_amd64.deb Lua bindings for the Csound API
liblua5.2-0_5.2.4-1.1+b2_amd64.deb Shared library for the Lua interpreter version 5.2
liblua5.2-dev_5.2.4-1.1+b2_amd64.deb Development files for the Lua language version 5.2
liblua5.3-0_5.3.3-1.1_amd64.deb Shared library for the Lua interpreter version 5.3
liblua5.3-dev_5.3.3-1.1_amd64.deb Development files for the Lua language version 5.3
liblua50-dev_5.0.3-8+b1_amd64.deb Main interpreter library for Lua 5.0: static library and headers
liblua50_5.0.3-8+b1_amd64.deb Main interpreter library for the Lua 5.0 programming language
libluabind-dev_0.9.1+dfsg-11_amd64.deb luabind c++ binding for lua: static library and headers
libluabind-doc_0.9.1+dfsg-11_all.deb luabind c++ binding for lua: documentation files
Advertisement
Advertisement