liblouis17_3.8.0-2_amd64.deb


Advertisement

Description

liblouis17 - Braille translation library - shared libs

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename liblouis17_3.8.0-2_amd64.deb
Package name liblouis17
Package version 3.8.0
Package release 2
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://liblouis.org/
License -
Maintainer Debian Accessibility Team <pkg-a11y-devel@lists.alioth.debian.org>
Download size 89.64 KB
Installed size 201.00 KB
Liblouis is a braille translator and back-translator.  It features support for
computer and literary braille, supports contracted and uncontracted translation
for many languages and has support for hyphenation.  Liblouis also supports
math braille (Nemeth and Marburg).
This package contains shared libraries.

Alternatives

Package Version Architecture Repository
liblouis17_3.8.0-2_i386.deb 3.8.0 i386 Debian Main
liblouis17 - - -

Requires

Name Value
libc6 >= 2.14
liblouis-data -
libyaml-0-2 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liblouis17_3.8.0-2_amd64.deb
Source Package liblouis

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblouis17 deb package:
    # sudo apt-get install liblouis17

Files

Path
/usr/lib/x86_64-linux-gnu/liblouis.so.17
/usr/lib/x86_64-linux-gnu/liblouis.so.17.0.0
/usr/share/doc/liblouis17/changelog.Debian.gz
/usr/share/doc/liblouis17/changelog.gz
/usr/share/doc/liblouis17/copyright

Changelog

2019-01-04 - Samuel Thibault <sthibault@debian.org>
liblouis (3.8.0-2) unstable; urgency=medium
* Upload to unstable.
2019-01-01 - Samuel Thibault <sthibault@debian.org>
liblouis (3.8.0-1) experimental; urgency=medium
[ Samuel Thibault ]
* New upstream release.
- Rename liblouis16 to liblouis17 according to soname bump.
[ Helmut Grohne ]
* Demote python stuff to Build-Depends-Indep. (Closes: Bug#913081)
2018-09-15 - Samuel Thibault <sthibault@debian.org>
liblouis (3.7.0-1) unstable; urgency=medium
* New upstream release.
- debian/patches/automake-1.16: upstream.
- debian/patches/cve-2018-12085: upstream.
- debian/patches/da-dk: upstream.
2018-08-17 - Samuel Thibault <sthibault@debian.org>
liblouis (3.6.0-3) unstable; urgency=medium
* control: Bump Standards-Version to 4.2.0 (no changes).
* debian/tests/control: Add autopkgtest.
* patches/automake-1.16: Fix build against automake 1.16 (Closes: #906376).
2018-07-07 - Samuel Thibault <sthibault@debian.org>
liblouis (3.6.0-2) unstable; urgency=medium
* Upload to unstable.
2018-06-30 - Samuel Thibault <sthibault@debian.org>
liblouis (3.6.0-1) experimental; urgency=medium
* New upstream release.
- Rename liblibouis14 to liblouis16 according to soname bump.
- cve-2018-11410, cve-2018-11440, cve-2018-11577, 32bit-crash.diff,
cve-2018-11683, cve-2018-11684, cve-2018-11685: Remove patches merged
upstream.
- patches/da-dk: Fix testsuite failure.
* control: Drop ancien python version requirement.
2018-06-12 - Samuel Thibault <sthibault@debian.org>
liblouis (3.5.0-4) unstable; urgency=high
* patches/cve-2018-12085: Fix another buffer overflow for CVE 2018-12085
(Closes: Bug#901202).
2018-06-04 - Samuel Thibault <sthibault@debian.org>
liblouis (3.5.0-3) unstable; urgency=medium
* patches/32bit-crash.diff: Fix crash on 32bit execution.
* patches/cve-2018-11440: Fix another buffer overflow for CVE 2018-11440
(Closes: #900085).
* patches/cve-2018-11577: Fix another segfault for CVE 2018-11577
(Closes: #900607).
* patches/cve-2018-11683: Fix a buffer overflow for CVE 2018-11683.
* patches/cve-2018-11684: Fix a buffer overflow for CVE 2018-11684.
* patches/cve-2018-11685: Fix a buffer overflow for CVE 2018-11685.
2018-05-25 - Samuel Thibault <sthibault@debian.org>
liblouis (3.5.0-2) unstable; urgency=high
* Bump Standards-Version to 4.1.4 (no changes).
* patches/cve-2018-11410: Buffer overflow fix for CVE 2018-11410
(Closes: #899999).
2018-03-11 - Samuel Thibault <sthibault@debian.org>
liblouis (3.5.0-1) unstable; urgency=medium
* New upstream release.

See Also

Package Description
liblouisutdml-bin_2.7.0-5+b1_amd64.deb Braille UTDML translation utilities
liblouisutdml-data_2.7.0-5_all.deb Braille UTDML translation library - data
liblouisutdml-dev_2.7.0-5+b1_amd64.deb Braille UTDML translation library - static libs and headers
liblouisutdml-java-doc_2.7.0-5_all.deb Braille UTDML translation library - java bindings documentation
liblouisutdml-java_2.7.0-5_all.deb Braille UTDML translation library - java bindings
liblouisutdml8_2.7.0-5+b1_amd64.deb Braille UTDML translation library - shared libs
liblouisxml-bin_2.4.0-8+b1_amd64.deb Braille XML translation utilities
liblouisxml-data_2.4.0-8_all.deb Braille XML translation library - data
liblouisxml-dev_2.4.0-8+b1_amd64.deb Braille XML translation library - static libs and headers
liblouisxml1_2.4.0-8+b1_amd64.deb Braille XML translation library - shared libs
liblpsolve55-dev_5.5.0.15-4+b1_amd64.deb Solve (mixed integer) linear programming problems - library
liblqr-1-0-dev_0.4.2-2.1_amd64.deb converts plain array images into multi-size representation (developments files)
liblqr-1-0_0.4.2-2.1_amd64.deb converts plain array images into multi-size representation
liblrcalc-dev_1.2-2+b1_amd64.deb library for calculating Littlewood-Richardson coefficients - development files
liblrcalc1_1.2-2+b1_amd64.deb library for calculating Littlewood-Richardson coefficients
Advertisement
Advertisement