liblombok-ast-java_0.2+ds-4_all.deb


Advertisement

Description

liblombok-ast-java - Robust parser + AST for the Java language

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename liblombok-ast-java_0.2+ds-4_all.deb
Package name liblombok-ast-java
Package version 0.2+ds
Package release 4
Package architecture all
Package type deb
Category java
Homepage https://projectlombok.org
License -
Maintainer Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Download size 1.78 MB
Installed size 1.93 MB
Lombok wraps the Abstract Syntax Tree (AST) produced by a target
platform into its own AST system, mostly because both Eclipse and
javac do not allow upward traversal (from a method to its owning
type, for example).

Alternatives

Package Version Architecture Repository
liblombok-ast-java_0.2+ds-4_all.deb 0.2+ds all Debian Main
liblombok-ast-java - - -

Requires

Name Value
libecj-java -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liblombok-ast-java_0.2+ds-4_all.deb
Source Package lombok-ast

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblombok-ast-java deb package:
    # sudo apt-get install liblombok-ast-java

Files

Path
/usr/share/doc/liblombok-ast-java/changelog.Debian.gz
/usr/share/doc/liblombok-ast-java/copyright
/usr/share/java/lombok-ast-0.2.3.jar
/usr/share/java/lombok-ast.jar
/usr/share/maven-repo/com/android/tools/external/lombok/lombok-ast/0.2.3/lombok-ast-0.2.3.jar
/usr/share/maven-repo/com/android/tools/external/lombok/lombok-ast/0.2.3/lombok-ast-0.2.3.pom
/usr/share/maven-repo/com/android/tools/external/lombok/lombok-ast/debian/lombok-ast-debian.jar
/usr/share/maven-repo/com/android/tools/external/lombok/lombok-ast/debian/lombok-ast-debian.pom

Changelog

2018-10-04 - Markus Koschany <apo@debian.org>
lombok-ast (0.2+ds-4) unstable; urgency=medium
* Switch to compat level 11.
* Declare compliance with Debian Policy 4.2.1.
* Use https for Format field.
* Tighten B-D on lombok to fix a FTBFS. (Closes: #906382)
2017-09-29 - Emmanuel Bourg <ebourg@apache.org>
lombok-ast (0.2+ds-3) unstable; urgency=medium
* Team upload.
* Build with libasm-java (>= 5.0) instead of libasm3-java/libasm4-java
* Standards-Version updated to 4.1.1
* Switch to debhelper level 10
2016-04-16 - Markus Koschany <apo@debian.org>
lombok-ast (0.2+ds-2) unstable; urgency=medium
* Drop liblombok-ast-java.jlibs and use maven-repo-helper to install
jars into /usr/share/java and to reduce the duplication.
* Declare compliance with Debian Policy 3.9.8.
2016-03-13 - Markus Koschany <apo@debian.org>
lombok-ast (0.2+ds-1) unstable; urgency=medium
* Initial release. (Closes: #807815)

See Also

Package Description
liblombok-java_1.16.22-7_all.deb Reduce boilerplate code in Java projects
liblombok-patcher-java_0.30-1_all.deb live-rewrite classes as a JVM runs
liblorene-debian1_0.0.0~cvs20161116+dfsg-1+b13_amd64.deb liblorene shared library
liblorene-dev_0.0.0~cvs20161116+dfsg-1+b13_amd64.deb development files for the LORENE framework for numerical relativity
liblorene-export-debian0_0.0.0~cvs20161116+dfsg-1+b13_amd64.deb liblorene_export shared library
liblorenef77-debian1_0.0.0~cvs20161116+dfsg-1+b13_amd64.deb liblorenef77 shared library
libloudmouth1-0_1.5.3-5_amd64.deb Lightweight C Jabber library
libloudmouth1-dev_1.5.3-5_amd64.deb Development files for Loudmouth Jabber library
liblouis-bin_3.8.0-2_amd64.deb Braille translation library - utilities
liblouis-data_3.8.0-2_all.deb Braille translation library - data
liblouis-dev_3.8.0-2_amd64.deb Braille translation library - static libs and headers
liblouis17_3.8.0-2_amd64.deb Braille translation library - shared libs
liblouisutdml-bin_2.7.0-5+b1_amd64.deb Braille UTDML translation utilities
liblouisutdml-data_2.7.0-5_all.deb Braille UTDML translation library - data
liblouisutdml-dev_2.7.0-5+b1_amd64.deb Braille UTDML translation library - static libs and headers
Advertisement
Advertisement