libleatherman1.4.2_1.4.2+dfsg-2+b1_amd64.deb


Advertisement

Description

libleatherman1.4.2 - collection of C++ and CMake utility libraries - shared libraries

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package name libleatherman1.4.2
Package version 1.4.2+dfsg
Package release 2+b1
Package architecture amd64
Package type deb
Installed size 2.06 KB
Download size 338.16 KB
Official Mirror ftp.br.debian.org
Leatherman is a collection of C++ and CMake utility libraries, primarily used
in the Puppet ecosystem.
This package contains the actual shared libraries.

Alternatives

Package Version Architecture Repository
libleatherman1.4.2_1.4.2+dfsg-2+b1_i386.deb 1.4.2+dfsg i386 Debian Main
libleatherman1.4.2 - - -

Requires

Name Value
libboost chrono1.67.0
libboost thread1.67.0
libboost locale1.67.0
libboost system1.67.0
libboost log1.67.0
libboost filesystem1.67.0
libboost atomic1.67.0
libboost-date time1.67.0
libboost-regex1.67.0 >= 1.67.0-10
libc6 >= 2.25
libcurl4 >= 7.16.2
libgcc1 >= 1:3.0
libstdc++6 >= 5.2

Download

Type URL
Binary Package libleatherman1.4.2_1.4.2+dfsg-2+b1_amd64.deb
Source Package leatherman

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libleatherman1.4.2 deb package:
    # sudo apt-get install libleatherman1.4.2

Files

Path
/usr/lib/x86_64-linux-gnu/libleatherman_curl.so.1.4.2
/usr/lib/x86_64-linux-gnu/libleatherman_dynamic_library.so.1.4.2
/usr/lib/x86_64-linux-gnu/libleatherman_execution.so.1.4.2
/usr/lib/x86_64-linux-gnu/libleatherman_file_util.so.1.4.2
/usr/lib/x86_64-linux-gnu/libleatherman_json_container.so.1.4.2
/usr/lib/x86_64-linux-gnu/libleatherman_locale.so.1.4.2
/usr/lib/x86_64-linux-gnu/libleatherman_logging.so.1.4.2
/usr/lib/x86_64-linux-gnu/libleatherman_ruby.so.1.4.2
/usr/lib/x86_64-linux-gnu/libleatherman_util.so.1.4.2
/usr/share/doc/libleatherman1.4.2/changelog.Debian.amd64.gz
/usr/share/doc/libleatherman1.4.2/changelog.Debian.gz
/usr/share/doc/libleatherman1.4.2/changelog.gz
/usr/share/doc/libleatherman1.4.2/copyright
/usr/share/lintian/overrides/libleatherman1.4.2

Changelog

2018-08-22 - Apollon Oikonomopoulos <apoikos@debian.org>
leatherman (1.4.2+dfsg-2) unstable; urgency=medium
* Drop the libleatherman-data package; the translations shipped therein are
actually test data
* Fix option_set.count() "endless" loop (Closes: #905463)
* Bump Standards-Version to 4.2.0; no changes needed
2018-07-31 - Apollon Oikonomopoulos <apoikos@debian.org>
leatherman (1.4.2+dfsg-1) unstable; urgency=medium
[ Nicolas Dandrimont ]
* Explicit build-dependency version constraints to ease backports
* Force LC_CTYPE=C for tests as well
[ Apollon Oikonomopoulos ]
* B-D on ruby (Closes: #897553)
* New upstream release
+ Bump SONAME to 1.4.2
* Bump Standards-Version to 4.1.5; no changes needed
* d/copyright: add Files-Excluded field
* Disable -Werror (Closes: #897778)
2018-02-23 - Apollon Oikonomopoulos <apoikos@debian.org>
leatherman (1.4.0+dfsg-1) unstable; urgency=medium
* Initial release (Closes: #891226)

See Also

Package Description
libledit-ocaml-dev_2.04-1_amd64.deb OCaml line editor library
liblemon-dev_1.3.1+dfsg-2_amd64.deb Library for Efficient Modeling and Optimization in Networks (development)
liblemon-doc_1.3.1+dfsg-2_all.deb Library for Efficient Modeling and Optimization in Networks (doc)
liblemon-utils_1.3.1+dfsg-2_amd64.deb Library for Efficient Modeling and Optimization in Networks (utilities)
liblemon1.3.1_1.3.1+dfsg-2_amd64.deb Library for Efficient Modeling and Optimization in Networks
liblemonldap-ng-common-perl_2.0.2+ds-4_all.deb Lemonldap::NG common files
liblemonldap-ng-handler-perl_2.0.2+ds-4_all.deb Lemonldap::NG handler common libraries
liblemonldap-ng-manager-perl_2.0.2+ds-4_all.deb Lemonldap::NG manager part
liblemonldap-ng-portal-perl_2.0.2+ds-4_all.deb Lemonldap::NG authentication portal part
liblensfun-bin_0.3.2-4_amd64.deb Lens Correction library - Utilities
liblensfun-data-v1_0.3.2-4_all.deb Lens Correction library - Data
liblensfun-dev_0.3.2-4_amd64.deb Lens Correction library - Development files
liblensfun-doc_0.3.2-4_all.deb Lens Correction library - Documentation
liblensfun1_0.3.2-4_amd64.deb Lens Correction library - Runtime files
liblept5_1.76.0-1_amd64.deb image processing library
Advertisement
Advertisement