libkdf5-dev_2.9.3+dfsg-2_amd64.deb


Advertisement

Description

libkdf5-dev - hdf5 access to data in the INSDC Sequence Read Archives (devel)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libkdf5-dev_2.9.3+dfsg-2_amd64.deb
Package name libkdf5-dev
Package version 2.9.3+dfsg
Package release 2
Package architecture amd64
Package type deb
Category devel::library libdevel role::devel-lib
Homepage https://github.com/ncbi/ncbi-vdb
License -
Maintainer Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>
Download size 16.11 KB
Installed size 62.00 KB
NGS is a new, domain-specific API for accessing reads, alignments and
pileups produced from Next Generation Sequencing. The API itself is
independent from any particular back-end implementation, and supports
use of multiple back-ends simultaneously. It also provides a library for
building new back-end "engines". The engine for accessing SRA data is
contained within the sister repository ncbi-vdb.
This library is part of the ncbi-vdb package and provides an interface
to the Hierarchical Data Format 5 (HDF5).
This is the development package.

Alternatives

Package Version Architecture Repository
libkdf5-dev_2.9.3+dfsg-2_i386.deb 2.9.3+dfsg i386 Debian Main
libkdf5-dev - - -

Requires

Name Value
libkdf5-2 = 2.9.3+dfsg-2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libkdf5-dev_2.9.3+dfsg-2_amd64.deb
Source Package ncbi-vdb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libkdf5-dev deb package:
    # sudo apt-get install libkdf5-dev

Files

Path
/usr/lib/x86_64-linux-gnu/libkdf5.a
/usr/lib/x86_64-linux-gnu/libkdf5.so
/usr/share/doc/libkdf5-dev/changelog.Debian.gz
/usr/share/doc/libkdf5-dev/changelog.gz
/usr/share/doc/libkdf5-dev/copyright

Changelog

2019-01-14 - Andreas Tille <tille@debian.org>
ncbi-vdb (2.9.3+dfsg-2) unstable; urgency=medium
* Replace remainin occurrence of vdb_mbedtls_ssl_conf_authmode by
mbedtls_ssl_conf_authmode
Closes: #919306
2019-01-11 - Andreas Tille <tille@debian.org>
ncbi-vdb (2.9.3+dfsg-1) unstable; urgency=medium
* New upstream version
* debhelper 12
* Standards-Version: 4.3.0
2018-09-04 - Andreas Tille <tille@debian.org>
ncbi-vdb (2.9.2-1+dfsg-1) unstable; urgency=medium
* New upstream version
[ Steve Langasek ]
* add missing implementation of uint64_msbit for i386
Closes: #907358
[ Andreas Tille ]
* d/rules:
- DEB_LDFLAGS_MAINT_APPEND := -Wl,--as-needed
- Considered using
DEB_LDFLAGS_MAINT_APPEND := -Wl,-z,defs
which should prevent successful build of a broken library (thanks
for the hint to Steve Langasek) Unfortunately this uncovers several
other build failures - volunteers to provide the correct linker
flags are welcome
- dh_auto_build --no-parallel
* Standards-Version: 4.2.1
2018-06-28 - Andreas Tille <tille@debian.org>
ncbi-vdb (2.9.1-1+dfsg-1) unstable; urgency=medium
* New upstream version
* Fixes accidental ABI break in 2.9.1
Closes: #902566
2018-06-27 - Andreas Tille <tille@debian.org>
ncbi-vdb (2.9.1+dfsg-1) unstable; urgency=medium
* New upstream version
* Point Vcs fields to salsa.debian.org
* Standards-Version: 4.1.4
2018-04-01 - Andreas Tille <tille@debian.org>
ncbi-vdb (2.9.0-1+dfsg-2) unstable; urgency=medium
* Drop some unneeded d-shlibs overrides available in version 0.82
* New library package libvdb-sqlite2 / libvdb-sqlite-dev featuring
the sqlite interface
2018-03-19 - Andreas Tille <tille@debian.org>
ncbi-vdb (2.9.0-1+dfsg-1) unstable; urgency=medium
* New upstream version
* Standards-Version: 4.1.3
* debhelper 11
* d/rules: s/DEB_BUILD_OPTIONS/DH_BUILD_MAINT_OPTIONS/
2017-10-19 - Andreas Tille <tille@debian.org>
ncbi-vdb (2.8.2-2+dfsg-1) unstable; urgency=medium
* New upstream version
* cme fix dpkg-control
* Standards-Version: 4.1.1
* More adaptations to Debian packaged libmbedx
* d/rules: Do not parse changelog
* Try better hardening
2017-04-01 - Andreas Tille <tille@debian.org>
ncbi-vdb (2.8.1+dfsg-2) unstable; urgency=medium
* Fix install dir by using DEB_HOST_MULTIARCH instead of DEB_BUILD_GNU_TYPE
(thanks for the patch to Graham Inggs <ginggs@debian.org>)
Closes: #859260
2017-01-11 - Andreas Tille <tille@debian.org>
ncbi-vdb (2.8.1+dfsg-1) unstable; urgency=medium
* New upstream version
* Install libs/kfg/*.kfg into /usr/lib/ncbi-vdb/kfg/

See Also

Package Description
libkdgcommons-java_1.0.15-1_all.deb utility library for web programming
libkdl-parser-dev_1.13.1-1+b1_amd64.deb Development files for ROS kdl_parser library
libkdl-parser1d_1.13.1-1+b1_amd64.deb ROS kdl_parser library
libkdnssd4_4.14.38-3_amd64.deb DNS-SD Protocol Library for the KDE Platform
libkdtree++-dev_0.7.1+git20101123-4_all.deb C++ template container implementation of kd-tree sorting
libkeduvocdocument-dev_17.08.3-1_amd64.deb development files for KEduVocDocument
libkeduvocdocument5_17.08.3-1_amd64.deb library for reading and writing vocabulary files
libkeepalive0_0.3-2_amd64.deb enable tcp keepalive support in programs using shared libraries
libkemoticons4_4.14.38-3_amd64.deb utility classes to deal with emoticon themes
libkernlib1-dev_20061220+dfsg3-4.4_amd64.deb CERNLIB data analysis suite - core library of basic functions (development)
libkernlib1-gfortran_20061220+dfsg3-4.4_amd64.deb CERNLIB data analysis suite - core library of basic functions
libkeybinder-3.0-0_0.3.2-1_amd64.deb registers global key bindings for applications - Gtk+3
libkeybinder-3.0-dev_0.3.2-1_amd64.deb registers global key bindings for applications - Gtk+3 - development headers
libkeybinder-dev_0.3.1-1_amd64.deb registers global key bindings for applications - development headers
libkeybinder0_0.3.1-1_amd64.deb registers global key bindings for applications
Advertisement
Advertisement