libjava3d-java_1.5.2+dfsg-16_all.deb


Advertisement

Description

libjava3d-java - Java 3D API (java library)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename libjava3d-java_1.5.2+dfsg-16_all.deb
Package name libjava3d-java
Package version 1.5.2+dfsg
Package release 16
Package architecture all
Package type deb
Category java role::shared-lib
Homepage http://java3d.java.net
License -
Maintainer Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Download size 1.12 MB
Installed size 4.55 MB
The Java 3D API enables the creation of three-dimensional graphics
applications and Internet-based 3D applets. It provides high-level
constructs for creating and manipulation 3D geometry and building the
structures used in rendering that geometry. With this software, you can
efficiently define and render very large virtual worlds.
This package contains the java library.

Alternatives

Package Version Architecture Repository
libjava3d-java_1.5.2+dfsg-16_all.deb 1.5.2+dfsg all Debian Main
libjava3d-java - - -

Requires

Name Value
libjava3d-jni >= 1.5.2+dfsg-16
libvecmath-java -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libjava3d-java_1.5.2+dfsg-16_all.deb
Source Package java3d

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libjava3d-java deb package:
    # sudo apt-get install libjava3d-java

Files

Path
/usr/share/doc/libjava3d-java/changelog.Debian.gz
/usr/share/doc/libjava3d-java/copyright
/usr/share/java/j3dcore-1.5.2+dfsg.jar
/usr/share/java/j3dcore.jar
/usr/share/java/j3dutils-1.5.2+dfsg.jar
/usr/share/java/j3dutils.jar

Changelog

2018-11-04 - Emmanuel Bourg <ebourg@apache.org>
java3d (1.5.2+dfsg-16) unstable; urgency=medium
* No longer build the applet to fix the build failure with Java 11
(Closes: #912468)
* Standards-Version updated to 4.2.1
2018-05-15 - Emmanuel Bourg <ebourg@apache.org>
java3d (1.5.2+dfsg-15) unstable; urgency=medium
* Team upload.
* Fixed the build failure with Java 10 (Closes: #898669)
* Standards-Version updated to 4.1.4
* Use salsa.debian.org Vcs-* URLs
2018-03-27 - tony mancill <tmancill@debian.org>
java3d (1.5.2+dfsg-14) unstable; urgency=medium
* Team upload.
* Link with gcc -shared, not ld; don't explicitly link with libc.
- Thank you to Matthias Klose for the patch.  (Closes: #894063)
2018-03-08 - Emmanuel Bourg <ebourg@apache.org>
java3d (1.5.2+dfsg-13) unstable; urgency=medium
* Team upload.
* Added the client JVM to the link path (Closes: #892411)
2018-03-08 - Emmanuel Bourg <ebourg@apache.org>
java3d (1.5.2+dfsg-12) unstable; urgency=medium
* Team upload.
[ tony mancill ]
* Address lintian warnings: pipe-symbol-used-as-license-disjunction
and invalid-short-name-in-dep5-copyright in debian/copyright.
[ Emmanuel Bourg ]
* Fixed the build failure with Java 9 (Closes: #875418)
* Moved the javadoc to /usr/share/doc/libjava3d-java
* Build with the DH sequencer instead of CDBS
* Moved the package to Git
* Standards-Version updated to 4.1.3
* Switch to debhelper level 11
* Fixed some duplicate license short ids in debian/copyright
2014-11-23 - tony mancill <tmancill@debian.org>
java3d (1.5.2+dfsg-11) unstable; urgency=medium
* Team upload.
* Revert debian/compat to debhelper 7 to allow the package to be compatible
with the Jessie release policy for unblock requests.
2014-11-23 - Markus Koschany <apo@gambaru.de>
java3d (1.5.2+dfsg-10) unstable; urgency=medium
* Team upload.
[ tony mancill ]
* Updated Standards-Version to 3.9.6 (no changes)
* Update Upstream URL in d/control and d/copyright. (Closes: #758413)
* Use canonical Vcs URLs for packaging repo.
* Use debhelper 9.
[ Markus Koschany ]
* Add typedef.patch. Define GLsizeiptr and GLintptr explicitly to
prevent a FTBFS. (Closes: #769301)
2013-04-28 - Emmanuel Bourg <ebourg@apache.org>
java3d (1.5.2+dfsg-9) unstable; urgency=low
* Team upload.
* Fixed the watch file
* Updated Standards-Version to 3.9.4 (no changes)
* Removed the deprecated DMUA flag
* Removed the obsolete patching instructions in debian/README.source
* debian/copyright: Updated to comply with the DEP5 format
2012-06-24 - Niels Thykier <niels@thykier.net>
java3d (1.5.2+dfsg-8) unstable; urgency=low
* Team upload.
* Remove -G flag from ia64 compiler flags.  (Closes: #650799)
* Replace use of com.sun JPEG library with ImageIO.
2011-09-08 - Miguel Landaeta <miguel@miguel.cc>
java3d (1.5.2+dfsg-7) unstable; urgency=low
[Miguel Landaeta]
* Team upload.
* Switch to default-jdk. (Closes: #640937).
* Bump Standards-Version to 3.9.2. No changes were required.
[tony mancill]
* Update Vcs-Svn URL in debian/control.

See Also

Package Description
libjava3d-jni_1.5.2+dfsg-16_amd64.deb Java3D API (java jni library)
libjavacc-maven-plugin-java_2.6-4_all.deb maven plugin which uses JavaCC to process JavaCC grammar files
libjavaewah-java-doc_0.7.9-1_all.deb Compressed variant of the Java bitset class (documentation)
libjavaewah-java_0.7.9-1_all.deb Compressed variant of the Java bitset class
libjavafxsvg-java_1.2.1-2_all.deb CenterDevice JavaFxSVG library
libjavaparser-java-doc_1.0.11-1_all.deb Java library for parsing Java 7 (documentation)
libjavaparser-java_1.0.11-1_all.deb Java library for parsing Java 7
libjavapoet-java_1.11.1-1_all.deb Java API for generating .java source files
libjavascript-beautifier-perl_0.25-1_all.deb Perl module to beautify JavaScript code
libjavascript-minifier-perl_1.14-1_all.deb Perl extension for minifying JavaScript code
libjavascript-minifier-xs-perl_0.11-1+b5_amd64.deb XS based JavaScript minifier
libjavascript-packer-perl_2.04-1_all.deb module to compact JavaScript code
libjavascript-rpc-perl_0.10-1.3_all.deb Perl module to process Remote procedure calls from JavaScript
libjavascriptcoregtk-4.0-18_2.24.2-1_amd64.deb JavaScript engine library from WebKitGTK
libjavascriptcoregtk-4.0-bin_2.24.2-1_amd64.deb JavaScript engine library from WebKitGTK - command-line interpreter
Advertisement
Advertisement